summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-11-11 19:30:02 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-11-11 19:30:02 +0000
commita0ae9d4e715239b9c0c5ea822385ef0cb80aea29 (patch)
treea59d50f256fcbc8643c2947baf59dae5690f1f8a /games-util/linux-wbfs-manager
parentFix SRC_URI to current gentoo defaults... (diff)
downloadgentoo-2-a0ae9d4e715239b9c0c5ea822385ef0cb80aea29.tar.gz
gentoo-2-a0ae9d4e715239b9c0c5ea822385ef0cb80aea29.tar.bz2
gentoo-2-a0ae9d4e715239b9c0c5ea822385ef0cb80aea29.zip
sync with live ebuild
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-util/linux-wbfs-manager')
-rw-r--r--games-util/linux-wbfs-manager/ChangeLog6
-rw-r--r--games-util/linux-wbfs-manager/linux-wbfs-manager-0.1.11.ebuild29
2 files changed, 29 insertions, 6 deletions
diff --git a/games-util/linux-wbfs-manager/ChangeLog b/games-util/linux-wbfs-manager/ChangeLog
index 10c572559ef5..3e59f66a8cc2 100644
--- a/games-util/linux-wbfs-manager/ChangeLog
+++ b/games-util/linux-wbfs-manager/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-util/linux-wbfs-manager
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/linux-wbfs-manager/ChangeLog,v 1.3 2009/11/11 19:28:17 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/linux-wbfs-manager/ChangeLog,v 1.4 2009/11/11 19:30:02 mr_bones_ Exp $
+
+ 11 Nov 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ linux-wbfs-manager-0.1.11.ebuild:
+ sync with live ebuild
*linux-wbfs-manager-9999 (11 Nov 2009)
diff --git a/games-util/linux-wbfs-manager/linux-wbfs-manager-0.1.11.ebuild b/games-util/linux-wbfs-manager/linux-wbfs-manager-0.1.11.ebuild
index 2f4c400ec1c7..3b7789be5857 100644
--- a/games-util/linux-wbfs-manager/linux-wbfs-manager-0.1.11.ebuild
+++ b/games-util/linux-wbfs-manager/linux-wbfs-manager-0.1.11.ebuild
@@ -1,23 +1,42 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/linux-wbfs-manager/linux-wbfs-manager-0.1.11.ebuild,v 1.2 2009/10/11 21:38:19 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/linux-wbfs-manager/linux-wbfs-manager-0.1.11.ebuild,v 1.3 2009/11/11 19:30:02 mr_bones_ Exp $
EAPI=2
-inherit toolchain-funcs
+if [[ "${PV}" == "9999" ]]; then
+ ESVN_REPO_URI="http://linux-wbfs-manager.googlecode.com/svn/trunk/"
+ inherit toolchain-funcs subversion
+ SRC_URI=""
+ KEYWORDS=""
+else
+ inherit toolchain-funcs
+ SRC_URI="http://linux-wbfs-manager.googlecode.com/files/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi;
DESCRIPTION="WBFS manager for Linux using GTK+"
HOMEPAGE="http://code.google.com/p/linux-wbfs-manager/"
-SRC_URI="http://linux-wbfs-manager.googlecode.com/files/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND="dev-libs/glib:2
gnome-base/libglade:2.0"
-S=${WORKDIR}/${PN}
+if [[ ${PV} == "9999" ]] ; then
+ S=${WORKDIR}/${ECVS_MODULE}
+else
+ S=${WORKDIR}/${PN}
+fi
+
+src_unpack() {
+ if [[ ${PV} == "9999" ]]; then
+ subversion_src_unpack
+ else
+ unpack ${A}
+ fi
+}
src_compile() {
emake CC="$(tc-getCC)" || die