summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-09-10 08:44:49 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-09-10 08:44:49 +0000
commitf2c37d5bf51491965cfa6987ce962490bca687b8 (patch)
tree75023c4d005e52720097cd074b6231e7a01d4d02 /games-strategy
parentarm stable (diff)
downloadgentoo-2-f2c37d5bf51491965cfa6987ce962490bca687b8.tar.gz
gentoo-2-f2c37d5bf51491965cfa6987ce962490bca687b8.tar.bz2
gentoo-2-f2c37d5bf51491965cfa6987ce962490bca687b8.zip
add built_with_use check for bug #146427
(Portage version: 2.1.1)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/wesnoth/ChangeLog6
-rw-r--r--games-strategy/wesnoth/wesnoth-1.0.2.ebuild5
-rw-r--r--games-strategy/wesnoth/wesnoth-1.1.9.ebuild5
3 files changed, 13 insertions, 3 deletions
diff --git a/games-strategy/wesnoth/ChangeLog b/games-strategy/wesnoth/ChangeLog
index eb0879e290e1..57de7f140e5a 100644
--- a/games-strategy/wesnoth/ChangeLog
+++ b/games-strategy/wesnoth/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-strategy/wesnoth
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.75 2006/08/27 09:25:40 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.76 2006/09/10 08:44:49 mr_bones_ Exp $
+
+ 10 Sep 2006; Michael Sterrett <mr_bones_@gentoo.org> wesnoth-1.0.2.ebuild,
+ wesnoth-1.1.9.ebuild:
+ add built_with_use check for bug #146427
*wesnoth-1.1.9 (27 Aug 2006)
diff --git a/games-strategy/wesnoth/wesnoth-1.0.2.ebuild b/games-strategy/wesnoth/wesnoth-1.0.2.ebuild
index 3112babcae02..212d306a6e09 100644
--- a/games-strategy/wesnoth/wesnoth-1.0.2.ebuild
+++ b/games-strategy/wesnoth/wesnoth-1.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-1.0.2.ebuild,v 1.10 2006/08/21 03:18:33 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-1.0.2.ebuild,v 1.11 2006/09/10 08:44:49 mr_bones_ Exp $
inherit eutils toolchain-funcs flag-o-matic games
@@ -31,6 +31,9 @@ pkg_setup() {
if ! built_with_use -o media-libs/sdl-mixer vorbis oggvorbis ; then
die "Please emerge sdl-mixer with USE=vorbis"
fi
+ if ! built_with_use media-libs/sdl-image png ; then
+ die "Please emerge sdl-image with USE=png"
+ fi
games_pkg_setup
}
diff --git a/games-strategy/wesnoth/wesnoth-1.1.9.ebuild b/games-strategy/wesnoth/wesnoth-1.1.9.ebuild
index 196f0bd111b5..b2b9508ebaa6 100644
--- a/games-strategy/wesnoth/wesnoth-1.1.9.ebuild
+++ b/games-strategy/wesnoth/wesnoth-1.1.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-1.1.9.ebuild,v 1.1 2006/08/27 09:25:40 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-1.1.9.ebuild,v 1.2 2006/09/10 08:44:49 mr_bones_ Exp $
inherit autotools eutils toolchain-funcs flag-o-matic games
@@ -31,6 +31,9 @@ pkg_setup() {
if ! built_with_use -o media-libs/sdl-mixer vorbis oggvorbis ; then
die "Please emerge sdl-mixer with USE=vorbis"
fi
+ if ! built_with_use media-libs/sdl-image png ; then
+ die "Please emerge sdl-image with USE=png"
+ fi
games_pkg_setup
}