summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-04-25 22:36:04 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-04-25 22:36:04 +0000
commitc087e3c2d8e1f096b16a1bb7efb7ca3653a9bb18 (patch)
tree010fe879452935a60f4ed34db7c7b167b8102b9d /games-strategy
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-c087e3c2d8e1f096b16a1bb7efb7ca3653a9bb18.tar.gz
gentoo-2-c087e3c2d8e1f096b16a1bb7efb7ca3653a9bb18.tar.bz2
gentoo-2-c087e3c2d8e1f096b16a1bb7efb7ca3653a9bb18.zip
version bump
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/warzone2100/ChangeLog8
-rw-r--r--games-strategy/warzone2100/warzone2100-2.3.0.ebuild63
2 files changed, 70 insertions, 1 deletions
diff --git a/games-strategy/warzone2100/ChangeLog b/games-strategy/warzone2100/ChangeLog
index 026482e356ac..81ef6ceacac5 100644
--- a/games-strategy/warzone2100/ChangeLog
+++ b/games-strategy/warzone2100/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/warzone2100
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/warzone2100/ChangeLog,v 1.39 2010/01/23 15:45:33 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/warzone2100/ChangeLog,v 1.40 2010/04/25 22:36:04 mr_bones_ Exp $
+
+*warzone2100-2.3.0 (25 Apr 2010)
+
+ 25 Apr 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ +warzone2100-2.3.0.ebuild:
+ version bump
23 Jan 2010; Brent Baude <ranger@gentoo.org> warzone2100-2.2.4.ebuild:
stable ppc, bug 296688
diff --git a/games-strategy/warzone2100/warzone2100-2.3.0.ebuild b/games-strategy/warzone2100/warzone2100-2.3.0.ebuild
new file mode 100644
index 000000000000..7c2ad5f5860c
--- /dev/null
+++ b/games-strategy/warzone2100/warzone2100-2.3.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/warzone2100/warzone2100-2.3.0.ebuild,v 1.1 2010/04/25 22:36:04 mr_bones_ Exp $
+
+EAPI=2
+inherit versionator games
+
+MY_PV=$(get_version_component_range -2)
+VIDEO_PV=2.2
+DESCRIPTION="3D real-time strategy game"
+HOMEPAGE="http://wz2100.net/"
+SRC_URI="mirror://sourceforge/warzone2100/${P}.tar.gz
+ videos? ( http://download.gna.org/warzone/videos/sequences-${VIDEO_PV}.wz )"
+
+LICENSE="GPL-2 CCPL-Attribution-ShareAlike-3.0 public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+# upstream requested debug support
+IUSE="debug nls +videos"
+
+RDEPEND="dev-db/sqlite:3
+ >=dev-games/physfs-2[zip]
+ dev-libs/popt
+ media-libs/libogg
+ media-libs/libpng
+ media-libs/libsdl[opengl,video]
+ media-libs/libtheora
+ media-libs/libvorbis
+ media-libs/openal
+ media-libs/sdl-net
+ media-libs/quesoglc
+ virtual/glu
+ virtual/opengl
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ app-arch/zip
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+RDEPEND="${RDEPEND}
+ media-fonts/dejavu"
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --docdir=/usr/share/doc/${PF} \
+ --localedir=/usr/share/locale \
+ --with-distributor="Gentoo ${PF}" \
+ --with-icondir=/usr/share/pixmaps \
+ --with-applicationdir=/usr/share/applications \
+ $(use_enable debug debug relaxed) \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ rm -f "${D}"/usr/share/doc/${PF}/COPYING*
+ if use videos ; then
+ insinto "${GAMES_DATADIR}"/${PN}
+ newins "${DISTDIR}"/sequences-${VIDEO_PV}.wz sequences.wz \
+ || die "newins failed"
+ fi
+ prepgamesdirs
+}