summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-06-25 17:25:46 +0000
committerMichał Górny <mgorny@gentoo.org>2014-06-25 17:25:46 +0000
commit9f9f1122cc9d845c72fa032f5ef2b6dba31a042f (patch)
tree28d3dc2c75195bfdaf07ec228c846eba07096458 /games-strategy
parentSupport multilib dependencies aside to emul-linux-x86. (diff)
downloadgentoo-2-9f9f1122cc9d845c72fa032f5ef2b6dba31a042f.tar.gz
gentoo-2-9f9f1122cc9d845c72fa032f5ef2b6dba31a042f.tar.bz2
gentoo-2-9f9f1122cc9d845c72fa032f5ef2b6dba31a042f.zip
Support multilib dependencies aside to emul-linux-x86.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/coldwar-demo/ChangeLog8
-rw-r--r--games-strategy/coldwar-demo/coldwar-demo-1-r2.ebuild84
2 files changed, 90 insertions, 2 deletions
diff --git a/games-strategy/coldwar-demo/ChangeLog b/games-strategy/coldwar-demo/ChangeLog
index cd066952dc06..e7996853dd43 100644
--- a/games-strategy/coldwar-demo/ChangeLog
+++ b/games-strategy/coldwar-demo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/coldwar-demo
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/coldwar-demo/ChangeLog,v 1.8 2014/05/07 15:41:03 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/coldwar-demo/ChangeLog,v 1.9 2014/06/25 17:25:46 mgorny Exp $
+
+*coldwar-demo-1-r2 (25 Jun 2014)
+
+ 25 Jun 2014; Michał Górny <mgorny@gentoo.org> +coldwar-demo-1-r2.ebuild:
+ Support multilib dependencies aside to emul-linux-x86.
07 May 2014; Ulrich Müller <ulm@gentoo.org> coldwar-demo-1-r1.ebuild:
Fix LICENSE, add mirror and bindist restrictions, bug 505752.
@@ -33,4 +38,3 @@
+coldwar-demo-1.ebuild:
Initial import. Ebuild by Paul Bredbury <brebs@sent.com> and modified by me.
Closing bug #111884.
-
diff --git a/games-strategy/coldwar-demo/coldwar-demo-1-r2.ebuild b/games-strategy/coldwar-demo/coldwar-demo-1-r2.ebuild
new file mode 100644
index 000000000000..f9f364e7adcc
--- /dev/null
+++ b/games-strategy/coldwar-demo/coldwar-demo-1-r2.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/coldwar-demo/coldwar-demo-1-r2.ebuild,v 1.1 2014/06/25 17:25:46 mgorny Exp $
+
+EAPI=5
+
+inherit eutils unpacker games
+
+MY_PN=${PN%-demo}
+
+DESCRIPTION="Third-person sneaker like Splinter Cell"
+HOMEPAGE="http://linuxgamepublishing.com/info.php?id=coldwar"
+SRC_URI="http://demofiles.linuxgamepublishing.com/coldwar/coldwar-demo.run"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="mirror bindist strip"
+
+RDEPEND="
+ || (
+ (
+ dev-libs/glib[abi_x86_32(-)]
+ media-libs/libogg[abi_x86_32(-)]
+ media-libs/libvorbis[abi_x86_32(-)]
+ media-libs/openal[abi_x86_32(-)]
+ media-libs/smpeg[abi_x86_32(-)]
+ virtual/opengl[abi_x86_32(-)]
+ x11-libs/libX11[abi_x86_32(-)]
+ x11-libs/libXext[abi_x86_32(-)]
+ )
+ amd64? (
+ (
+ app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
+ app-emulation/emul-linux-x86-opengl[-abi_x86_32(-)]
+ app-emulation/emul-linux-x86-sdl[-abi_x86_32(-)]
+ app-emulation/emul-linux-x86-soundlibs[-abi_x86_32(-)]
+ app-emulation/emul-linux-x86-xlibs[-abi_x86_32(-)]
+ )
+ )
+ )"
+DEPEND=""
+
+S=${WORKDIR}
+dir=${GAMES_PREFIX_OPT}/${PN}
+
+QA_PREBUILT="${dir:1}/lib/*
+ ${dir:1}/bin/meng"
+
+src_unpack() {
+ unpack_makeself
+ unpack ./data/data.tar.gz
+
+ mv bin/Linux/x86/${MY_PN}_demo .
+ mv bin/Linux/x86/bin/meng bin
+
+ rm -r bin/{Linux,*BSD} lgp_* setup.* data/data.tar.gz
+}
+
+src_install() {
+ insinto "${dir}"
+ doins -r *
+ rm "${D}/${dir}"/{${MY_PN}_demo,bin/{launcher,meng}}
+
+ exeinto "${dir}"
+ doexe ${MY_PN}_demo
+ exeinto "${dir}/bin"
+ doexe bin/{launcher,meng}
+
+ games_make_wrapper ${PN} ./${MY_PN}_demo "${dir}" "${dir}"
+ newicon icon.xpm ${PN}.xpm
+ make_desktop_entry ${PN} "Cold War (Demo)" ${PN}
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "The instruction manual is available as:"
+ elog " http://demofiles.linuxgamepublishing.com/coldwar/manual.pdf"
+ echo
+ einfo "To play the game, run: ${PN}"
+}