summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2011-01-23 07:50:36 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2011-01-23 07:50:36 +0000
commit9329cd79d6f57759bf5b7a2a27cf2b81e8ca319f (patch)
tree139a22a1bc9b39ad58a552a967c7d86bd9afde7b /games-strategy
parentVersion bump. (diff)
downloadgentoo-2-9329cd79d6f57759bf5b7a2a27cf2b81e8ca319f.tar.gz
gentoo-2-9329cd79d6f57759bf5b7a2a27cf2b81e8ca319f.tar.bz2
gentoo-2-9329cd79d6f57759bf5b7a2a27cf2b81e8ca319f.zip
version bump
(Portage version: 2.1.9.25/cvs/Linux i686)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/warmux/ChangeLog16
-rw-r--r--games-strategy/warmux/files/warmux-11.01-gentoo.patch67
-rw-r--r--games-strategy/warmux/warmux-11.01.ebuild56
3 files changed, 136 insertions, 3 deletions
diff --git a/games-strategy/warmux/ChangeLog b/games-strategy/warmux/ChangeLog
index 9674fd702f96..941032b8cda7 100644
--- a/games-strategy/warmux/ChangeLog
+++ b/games-strategy/warmux/ChangeLog
@@ -1,6 +1,16 @@
-# ChangeLog for games-strategy/wormux
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/warmux/ChangeLog,v 1.1 2011/01/23 06:46:17 mr_bones_ Exp $
+# ChangeLog for games-strategy/warmux
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/warmux/ChangeLog,v 1.2 2011/01/23 07:50:36 mr_bones_ Exp $
+
+ 23 Jan 2011; Michael Sterrett <mr_bones_@gentoo.org> +warmux-11.01.ebuild,
+ +files/warmux-11.01-gentoo.patch:
+ version bump
+
+*warmux-11.01 (23 Jan 2011)
+
+ 23 Jan 2011; Michael Sterrett <mr_bones_@gentoo.org> +warmux-11.01.ebuild,
+ +files/warmux-11.01-gentoo.patch:
+ version bump
20 Jun 2010; Markus Meier <maekke@gentoo.org> wormux-0.9.2.1.ebuild:
x86 stable, bug #320903
diff --git a/games-strategy/warmux/files/warmux-11.01-gentoo.patch b/games-strategy/warmux/files/warmux-11.01-gentoo.patch
new file mode 100644
index 000000000000..683db09f83fa
--- /dev/null
+++ b/games-strategy/warmux/files/warmux-11.01-gentoo.patch
@@ -0,0 +1,67 @@
+--- warmux-11.01.orig/configure.ac
++++ warmux-11.01/configure.ac
+@@ -43,8 +43,6 @@
+ AC_MSG_ERROR([*** No C++ compiler can be found!])
+ fi
+
+-AX_CFLAGS_WARN_ALL([CXXFLAGS])
+-
+ # ========================================================================
+ # == Set flags for various environments =
+ # ========================================================================
+@@ -345,14 +343,7 @@
+ exit 1
+ fi
+
+-dnl === Add Werror flag for gcc/g++ if debug mode is enabled, ==============
+-dnl === but allow RTTI (ie dynamic_cast, typeid/typeinfo unavailable) ======
+-if test "x${debug}" = "xyes"; then
+- CFLAGS="$CFLAGS -Werror"
+- CXXFLAGS="$CXXFLAGS -Werror"
+-else
+- CXXFLAGS="$CXXFLAGS -fno-rtti"
+-fi
++CXXFLAGS="$CXXFLAGS -fno-rtti"
+
+ dnl === Forbid exceptions (Android platform requirement) ===================
+ CXXFLAGS="$CXXFLAGS -fno-exceptions"
+--- warmux-11.01.orig/data/Makefile.am
++++ warmux-11.01/data/Makefile.am
+@@ -1,8 +1,2 @@
+-xdg_appsdir = $(prefix)/share/applications
+-xdg_apps_DATA = warmux.desktop
+-pixmapsdir = $(prefix)/share/pixmaps
+-pixmaps_DATA = icon/warmux_128x128.png
+-
+ nobase_dist_pkgdata_DATA = @DATA_FILES@
+ pkgdatadir = @DATADIR@
+-EXTRA_DIST = $(pixmaps_DATA)
+--- warmux-11.01.orig/src/menu/options_menu.cpp
++++ warmux-11.01/src/menu/options_menu.cpp
+@@ -506,26 +506,7 @@
+
+ void OptionMenu::CheckUpdates()
+ {
+- if (!Config::GetInstance()->GetCheckUpdates()
+- || Constants::WARMUX_VERSION.find("svn") != std::string::npos)
+ return;
+-
+- Downloader *dl = Downloader::GetInstance();
+- std::string latest_version;
+- if (dl->GetLatestVersion(latest_version)) {
+- const char *cur_version = Constants::GetInstance()->WARMUX_VERSION.c_str();
+- if (latest_version != cur_version) {
+- Question new_version;
+- std::string txt = Format(_("A new version %s is available, while your version is %s. "
+- "You may want to check whether an update is available for your OS!"),
+- latest_version.c_str(), cur_version);
+- new_version.Set(txt, true, 0);
+- new_version.Ask();
+- }
+- } else {
+- AppWarmux::DisplayError(Format(_("Version verification failed because: %s"),
+- dl->GetLastError().c_str()));
+- }
+ }
+
+ uint OptionMenu::toVolume(uint level)
diff --git a/games-strategy/warmux/warmux-11.01.ebuild b/games-strategy/warmux/warmux-11.01.ebuild
new file mode 100644
index 000000000000..23b915caa315
--- /dev/null
+++ b/games-strategy/warmux/warmux-11.01.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/warmux/warmux-11.01.ebuild,v 1.1 2011/01/23 07:50:36 mr_bones_ Exp $
+
+EAPI=2
+inherit autotools eutils games
+
+DESCRIPTION="A free Worms clone"
+HOMEPAGE="http://www.wormux.org/"
+SRC_URI="http://download.gna.org/warmux/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug nls unicode"
+
+RDEPEND="media-libs/libsdl[joystick,video]
+ media-libs/sdl-image[jpeg,png]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-ttf
+ media-libs/sdl-net
+ media-libs/sdl-gfx
+ net-misc/curl
+ media-fonts/dejavu
+ dev-libs/libxml2
+ x11-libs/libX11
+ nls? ( virtual/libintl )
+ unicode? ( dev-libs/fribidi )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --with-localedir-name=/usr/share/locale \
+ --with-datadir-name="${GAMES_DATADIR}/${PN}" \
+ --with-font-path=/usr/share/fonts/dejavu/DejaVuSans.ttf \
+ $(use_enable debug) \
+ $(use_enable nls) \
+ $(use_enable unicode fribidi)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README TODO
+ rm -f "${D}${GAMES_DATADIR}/${PN}/font/DejaVuSans.ttf"
+ doicon data/icon/warmux.svg || die
+ make_desktop_entry warmux Warmux || die
+ prepgamesdirs
+}