summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-12-07 18:57:00 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-12-07 18:57:00 +0000
commit874c0e9e26d291aca868ed36a315aae521cf7306 (patch)
tree9ed695feecf3011f3796cbf9514f0a56c8e24c29 /games-strategy
parentStable for HPPA (bug #289887). (diff)
downloadgentoo-2-874c0e9e26d291aca868ed36a315aae521cf7306.tar.gz
gentoo-2-874c0e9e26d291aca868ed36a315aae521cf7306.tar.bz2
gentoo-2-874c0e9e26d291aca868ed36a315aae521cf7306.zip
fix building with --as-needed with patch from Kacper Kowalik via bug #295827
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/freecnc/ChangeLog8
-rw-r--r--games-strategy/freecnc/files/freecnc-0.2.1.31072003-as-needed.patch11
-rw-r--r--games-strategy/freecnc/freecnc-0.2.1.31072003.ebuild24
3 files changed, 33 insertions, 10 deletions
diff --git a/games-strategy/freecnc/ChangeLog b/games-strategy/freecnc/ChangeLog
index ae3b1b475618..c2da4ebc9df8 100644
--- a/games-strategy/freecnc/ChangeLog
+++ b/games-strategy/freecnc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/freecnc
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/freecnc/ChangeLog,v 1.13 2009/06/13 18:01:40 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freecnc/ChangeLog,v 1.14 2009/12/07 18:57:00 mr_bones_ Exp $
+
+ 07 Dec 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ freecnc-0.2.1.31072003.ebuild,
+ +files/freecnc-0.2.1.31072003-as-needed.patch:
+ fix building with --as-needed with patch from Kacper Kowalik via bug
+ #295827
13 Jun 2009; Tristan Heaven <nyhm@gentoo.org>
freecnc-0.2.1.31072003.ebuild,
diff --git a/games-strategy/freecnc/files/freecnc-0.2.1.31072003-as-needed.patch b/games-strategy/freecnc/files/freecnc-0.2.1.31072003-as-needed.patch
new file mode 100644
index 000000000000..a8654cb3e5c9
--- /dev/null
+++ b/games-strategy/freecnc/files/freecnc-0.2.1.31072003-as-needed.patch
@@ -0,0 +1,11 @@
+--- freecnc++.org/tools/tmpinied/Makefile 2009-12-07 18:18:23.985443151 +0000
++++ freecnc++/tools/tmpinied/Makefile 2009-12-07 18:19:45.869476911 +0000
+@@ -13,7 +13,7 @@
+ CFLAGS = -g -Wall -Werror -I../../src/include `sdl-config --cflags`
+
+ ../../tmpinied: $(LOCALOBJS) $(OBJECTS)
+- $(CXX) -o ../../tmpinied -g `sdl-config --libs` $(LOCALOBJS) $(OBJECTS) $(LIBS) $(LDFLAGS)
++ $(CXX) -g $(LDFLAGS) -o ../../tmpinied $(LOCALOBJS) $(OBJECTS) $(LIBS) `sdl-config --libs`
+ clean:
+ \rm -f $(LOCALOBJS) ../../tmpinied
+
diff --git a/games-strategy/freecnc/freecnc-0.2.1.31072003.ebuild b/games-strategy/freecnc/freecnc-0.2.1.31072003.ebuild
index b63d6809de0b..17e20c211d43 100644
--- a/games-strategy/freecnc/freecnc-0.2.1.31072003.ebuild
+++ b/games-strategy/freecnc/freecnc-0.2.1.31072003.ebuild
@@ -1,22 +1,23 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/freecnc/freecnc-0.2.1.31072003.ebuild,v 1.15 2009/06/13 18:01:40 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freecnc/freecnc-0.2.1.31072003.ebuild,v 1.16 2009/12/07 18:57:00 mr_bones_ Exp $
+EAPI=2
inherit flag-o-matic eutils games
DESCRIPTION="SDL-rewrite of the classical real time strategy hit Command & Conquer"
HOMEPAGE="http://www.freecnc.org/"
#mirror://sourceforge/freecnc/freecnc++-${PV}-src.tar.bz2
SRC_URI="mirror://gentoo/freecnc++-${PV}-src.tar.bz2
- nocd? ( ftp://ftp.westwood.com/pub/cc1/previews/demo/cc1demo1.zip )
- nocd? ( ftp://ftp.westwood.com/pub/cc1/previews/demo/cc1demo2.zip )"
+ nocd? ( ftp://ftp.westwood.com/pub/cc1/previews/demo/cc1demo1.zip
+ ftp://ftp.westwood.com/pub/cc1/previews/demo/cc1demo2.zip )"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~ppc x86"
IUSE="nocd"
-RDEPEND="media-libs/libsdl
+RDEPEND="media-libs/libsdl[audio,video]
media-libs/sdl-net"
DEPEND="${RDEPEND}
app-arch/unzip"
@@ -32,14 +33,17 @@ src_unpack() {
mv ${f} $(echo ${f} | awk '{print tolower($1)}') || die "moving $f"
done
fi
- cd "${S}"
+}
+
+src_prepare() {
epatch \
"${FILESDIR}"/${PV}-makefile-cflags.patch \
"${FILESDIR}"/${PV}-remove-root.patch \
"${FILESDIR}"/${PV}-gentoo-paths.patch \
"${FILESDIR}"/${P}-gcc4.patch \
"${FILESDIR}"/${P}-gcc42.patch \
- "${FILESDIR}"/${P}-glibc2.10.patch
+ "${FILESDIR}"/${P}-glibc2.10.patch \
+ "${FILESDIR}"/${P}-as-needed.patch
sed -i \
-e "s:GENTOO_LOGDIR:${GAMES_LOGDIR}:" \
-e "s:GENTOO_CONFDIR:${GAMES_SYSCONFDIR}/${PN}/:" \
@@ -82,7 +86,9 @@ src_install() {
pkg_postinst() {
games_pkg_postinst
- elog "If you have the C&C games, then just copy the .mix"
- elog "to ${GAMES_DATADIR}/${PN}"
- elog "Otherwise, re-emerge freecnc with 'nocd' in your USE."
+ if ! use nocd ; then
+ elog "If you have the C&C games, then just copy the .mix"
+ elog "to ${GAMES_DATADIR}/${PN}"
+ elog "Otherwise, re-emerge freecnc with 'nocd' in your USE."
+ fi
}