summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-01-27 00:58:04 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-01-27 00:58:04 +0000
commit8718d144a7d29f0d92ef931a3d01ddded5530e66 (patch)
tree93dc95887ea8fd2e3c226a02c3ed5b0e7faa814c /games-strategy
parentversion bump (diff)
downloadgentoo-2-8718d144a7d29f0d92ef931a3d01ddded5530e66.tar.gz
gentoo-2-8718d144a7d29f0d92ef931a3d01ddded5530e66.tar.bz2
gentoo-2-8718d144a7d29f0d92ef931a3d01ddded5530e66.zip
version bump
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/megaglest-data/ChangeLog9
-rw-r--r--games-strategy/megaglest-data/megaglest-data-3.9.1.ebuild44
2 files changed, 51 insertions, 2 deletions
diff --git a/games-strategy/megaglest-data/ChangeLog b/games-strategy/megaglest-data/ChangeLog
index 32e53033581a..3ff691a16982 100644
--- a/games-strategy/megaglest-data/ChangeLog
+++ b/games-strategy/megaglest-data/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/megaglest-data
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/megaglest-data/ChangeLog,v 1.10 2013/11/21 17:22:33 hasufell Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/megaglest-data/ChangeLog,v 1.11 2014/01/27 00:58:04 hasufell Exp $
+
+*megaglest-data-3.9.1 (27 Jan 2014)
+
+ 27 Jan 2014; Julian Ospald <hasufell@gentoo.org> +megaglest-data-3.9.1.ebuild:
+ version bump
21 Nov 2013; Julian Ospald <hasufell@gentoo.org> megaglest-data-3.9.0.ebuild:
fix dep wrt #492206
diff --git a/games-strategy/megaglest-data/megaglest-data-3.9.1.ebuild b/games-strategy/megaglest-data/megaglest-data-3.9.1.ebuild
new file mode 100644
index 000000000000..adcc52b02fe7
--- /dev/null
+++ b/games-strategy/megaglest-data/megaglest-data-3.9.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/megaglest-data/megaglest-data-3.9.1.ebuild,v 1.1 2014/01/27 00:58:04 hasufell Exp $
+
+EAPI=5
+inherit cmake-utils games
+
+MY_PN="megaglest"
+DESCRIPTION="Data files for the cross-platform 3D realtime strategy game MegaGlest"
+HOMEPAGE="http://www.megaglest.org/"
+SRC_URI="https://github.com/MegaGlest/megaglest-data/releases/download/${PV}/megaglest-data-${PV}.tar.xz"
+
+LICENSE="CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="~games-strategy/megaglest-${PV}"
+
+DOCS=( docs/AUTHORS.data.txt docs/CHANGELOG.txt docs/README.txt )
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_configure() {
+ local mycmakeargs=(
+ -DMEGAGLEST_BIN_INSTALL_PATH="${GAMES_BINDIR}"
+ -DMEGAGLEST_DATA_INSTALL_PATH="${GAMES_DATADIR}/${MY_PN}"
+ -DMEGAGLEST_ICON_INSTALL_PATH="/usr/share/pixmaps"
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ use doc && HTML_DOCS="docs/glest_factions/"
+
+ cmake-utils_src_install
+
+ prepgamesdirs
+
+}