summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-05-28 06:24:19 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-05-28 06:24:19 +0000
commit2e9aa045c3b17de2965db4f52091a183d480b1d0 (patch)
treee08da0618cacecf40f2a8f3171714604b68ed11e /games-strategy
parentRemoving the f77 USE flag check - just giving a hint when no g77 found. (Mani... (diff)
downloadgentoo-2-2e9aa045c3b17de2965db4f52091a183d480b1d0.tar.gz
gentoo-2-2e9aa045c3b17de2965db4f52091a183d480b1d0.tar.bz2
gentoo-2-2e9aa045c3b17de2965db4f52091a183d480b1d0.zip
version bump
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/wesnoth/ChangeLog7
-rw-r--r--games-strategy/wesnoth/Manifest2
-rw-r--r--games-strategy/wesnoth/files/digest-wesnoth-0.7.81
-rw-r--r--games-strategy/wesnoth/wesnoth-0.7.8.ebuild40
4 files changed, 49 insertions, 1 deletions
diff --git a/games-strategy/wesnoth/ChangeLog b/games-strategy/wesnoth/ChangeLog
index 87dce1f64804..5be1f7e5b759 100644
--- a/games-strategy/wesnoth/ChangeLog
+++ b/games-strategy/wesnoth/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/wesnoth
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.25 2004/05/24 23:10:30 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.26 2004/05/28 06:24:19 mr_bones_ Exp $
+
+*wesnoth-0.7.8 (27 May 2004)
+
+ 27 May 2004; Michael Sterrett <mr_bones_@gentoo.org> wesnoth-0.7.8.ebuild:
+ version bump
*wesnoth-0.7.7 (24 May 2004)
diff --git a/games-strategy/wesnoth/Manifest b/games-strategy/wesnoth/Manifest
index 21e93ded3fb9..f5a5a0be3731 100644
--- a/games-strategy/wesnoth/Manifest
+++ b/games-strategy/wesnoth/Manifest
@@ -1,6 +1,8 @@
MD5 8e69a78da8c7ddba59713f6da921f3ed wesnoth-0.7.7.ebuild 1060
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 3211378725e7a42249bbaaa653a0627b ChangeLog 3653
+MD5 8e69a78da8c7ddba59713f6da921f3ed wesnoth-0.7.8.ebuild 1060
MD5 8a9578dd0bbb80276a00175aa2ca8371 wesnoth-0.7.6.ebuild 1060
MD5 d8fa195a2ff1df49d290b1ed77e38a87 files/digest-wesnoth-0.7.7 67
+MD5 2cd6699b20930421a34650e4a1c03b83 files/digest-wesnoth-0.7.8 67
MD5 85c8760fa128b26e3a29168510ffe3fd files/digest-wesnoth-0.7.6 67
diff --git a/games-strategy/wesnoth/files/digest-wesnoth-0.7.8 b/games-strategy/wesnoth/files/digest-wesnoth-0.7.8
new file mode 100644
index 000000000000..d2c2a5913a1d
--- /dev/null
+++ b/games-strategy/wesnoth/files/digest-wesnoth-0.7.8
@@ -0,0 +1 @@
+MD5 cf3d1d963b26c79306a46247ee7a10a8 wesnoth-0.7.8.tar.gz 20175742
diff --git a/games-strategy/wesnoth/wesnoth-0.7.8.ebuild b/games-strategy/wesnoth/wesnoth-0.7.8.ebuild
new file mode 100644
index 000000000000..752e610271bd
--- /dev/null
+++ b/games-strategy/wesnoth/wesnoth-0.7.8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-0.7.8.ebuild,v 1.1 2004/05/28 06:24:19 mr_bones_ Exp $
+
+inherit flag-o-matic games
+
+DESCRIPTION="A fantasy turn-based strategy game"
+HOMEPAGE="http://www.wesnoth.org/"
+SRC_URI="http://www.wesnoth.org/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 amd64 ppc ~sparc"
+IUSE="server editor tools gnome kde"
+
+DEPEND=">=media-libs/libsdl-1.2
+ >=media-libs/sdl-image-1.2
+ >=media-libs/sdl-mixer-1.2
+ >=media-libs/sdl-ttf-2.0
+ media-libs/sdl-net
+ virtual/x11"
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ $(use_enable server) \
+ $(use_enable editor) \
+ $(use_enable tools) \
+ $(use_enable gnome) \
+ $(use_enable kde) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ mv "${D}${GAMES_DATADIR}/icons" "${D}/usr/share/"
+ dodoc MANUAL changelog || die "dodoc failed"
+ prepgamesdirs
+}