summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-08-11 00:44:32 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-08-11 00:44:32 +0000
commit2a82fbe6436f127fc4e61679334b65eb1f159ad0 (patch)
treef463674ee2e4a06e9a0e6637b0cac7b55185f1ae /games-strategy
parentFix configure typo stripping -gcc from compiler name on cross-compiles. Bug (diff)
downloadgentoo-2-2a82fbe6436f127fc4e61679334b65eb1f159ad0.tar.gz
gentoo-2-2a82fbe6436f127fc4e61679334b65eb1f159ad0.tar.bz2
gentoo-2-2a82fbe6436f127fc4e61679334b65eb1f159ad0.zip
version bump
(Portage version: 2.1.2.11)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/boswars/ChangeLog8
-rw-r--r--games-strategy/boswars/boswars-2.4.ebuild55
-rw-r--r--games-strategy/boswars/files/boswars-2.4-gentoo.patch29
-rw-r--r--games-strategy/boswars/files/digest-boswars-2.46
4 files changed, 97 insertions, 1 deletions
diff --git a/games-strategy/boswars/ChangeLog b/games-strategy/boswars/ChangeLog
index 1bd01456d17f..5766a7036e4a 100644
--- a/games-strategy/boswars/ChangeLog
+++ b/games-strategy/boswars/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/boswars
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/boswars/ChangeLog,v 1.2 2007/08/10 23:45:10 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/boswars/ChangeLog,v 1.3 2007/08/11 00:44:32 mr_bones_ Exp $
+
+*boswars-2.4 (11 Aug 2007)
+
+ 11 Aug 2007; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/boswars-2.4-gentoo.patch, +boswars-2.4.ebuild:
+ version bump
10 Aug 2007; Michael Sterrett <mr_bones_@gentoo.org> boswars-2.3.ebuild:
match keywords to games-strategy/bos for package move
diff --git a/games-strategy/boswars/boswars-2.4.ebuild b/games-strategy/boswars/boswars-2.4.ebuild
new file mode 100644
index 000000000000..ed8805982f93
--- /dev/null
+++ b/games-strategy/boswars/boswars-2.4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/boswars/boswars-2.4.ebuild,v 1.1 2007/08/11 00:44:32 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="Futuristic real-time strategy game"
+HOMEPAGE="http://www.boswars.org/"
+SRC_URI="http://www.boswars.org/dist/releases/${P}-src.tar.gz
+ mirror://gentoo/bos.png"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/lua
+ media-libs/libsdl
+ media-libs/libpng
+ media-libs/libvorbis
+ media-libs/libtheora
+ media-libs/libogg
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ dev-util/scons"
+
+S=${WORKDIR}/${P}-src
+
+src_unpack() {
+ unpack ${A/bos.png}
+ cd "${S}"
+ rm doc/README-SDL.txt
+ rm doc/guichan-copyright.txt
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ sed -i -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
+ engine/include/stratagus.h || die "sed failed"
+}
+
+src_compile() {
+ scons || die "scons failed"
+}
+
+src_install() {
+ dogamesbin ${PN} || die "dogamesbin failed"
+ dodoc CHANGELOG COPYRIGHT.txt README.txt
+ dohtml -r doc/*
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r campaigns graphics languages maps scripts sounds units video \
+ || die "doins failed"
+
+ doicon "${DISTDIR}"/bos.png
+ make_desktop_entry ${PN} "Bos Wars" bos.png
+
+ prepgamesdirs
+}
diff --git a/games-strategy/boswars/files/boswars-2.4-gentoo.patch b/games-strategy/boswars/files/boswars-2.4-gentoo.patch
new file mode 100644
index 000000000000..1c7f35da0760
--- /dev/null
+++ b/games-strategy/boswars/files/boswars-2.4-gentoo.patch
@@ -0,0 +1,29 @@
+--- engine/include/stratagus.h.old 2007-08-04 21:54:17.000000000 +0200
++++ engine/include/stratagus.h 2007-08-04 21:55:20.000000000 +0200
+@@ -188,7 +188,7 @@
+ extern char NameLine[];
+
+ #ifndef STRATAGUS_LIB_PATH
+-#define STRATAGUS_LIB_PATH "." /// Where to find the data files
++#define STRATAGUS_LIB_PATH "@GENTOO_DATADIR@" /// Where to find the data files
+ #endif
+
+ #ifndef STRATAGUS_HOME_PATH
+--- SConstruct.orig 2007-08-10 20:00:53.000000000 -0400
++++ SConstruct 2007-08-10 20:11:07.000000000 -0400
+@@ -183,14 +183,8 @@
+ return 0
+
+ lualibfound = 0
+- if conf.CheckFunc('luaopen_base'):
++ if conf.CheckLibWithHeader('lua', 'lualib.h', 'c'):
+ return 1
+- if conf.CheckLibWithHeader('lualib', 'lualib.h', 'c'):
+- lualibfound = 1
+- elif conf.CheckLibWithHeader('lualib50', 'lualib.h', 'c'):
+- lualibfound = 1
+- elif conf.CheckLibWithHeader('lualib5.0', 'lualib.h', 'c'):
+- lualibfound = 1
+ # the lua library should be after lualib
+ env["LIBS"].remove(found)
+ env.Append(LIBS = found)
diff --git a/games-strategy/boswars/files/digest-boswars-2.4 b/games-strategy/boswars/files/digest-boswars-2.4
new file mode 100644
index 000000000000..6139325b7502
--- /dev/null
+++ b/games-strategy/boswars/files/digest-boswars-2.4
@@ -0,0 +1,6 @@
+MD5 ac9b93116c88d575ba8ec3b7559da27e bos.png 620
+RMD160 19822ea636b7a7995a348332dffb40e302c61a6e bos.png 620
+SHA256 fe1d24bc722093bd3882ecab15c15f61b6b0edee263bfd58af662825e76d8b0a bos.png 620
+MD5 ffe382779ace57c52c816c74f06dbf27 boswars-2.4-src.tar.gz 48856425
+RMD160 1235bc79115c21150eeb6501636cbb6030894d35 boswars-2.4-src.tar.gz 48856425
+SHA256 838ae9836b9dad5ad06ee4164ad9af170ae91ed06f4df5fdf2e61e1219786039 boswars-2.4-src.tar.gz 48856425