summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-01-06 00:05:30 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-01-06 00:05:30 +0000
commit1889430d564b441ec534ff3b4d6ee8577477c440 (patch)
tree97593c0bc11848d82088ff2d4d57eab472210f69 /games-strategy
parentAdded pkgconfig dep to gajim-0.10.1 ebuild wrt bug #152529 (diff)
downloadgentoo-2-1889430d564b441ec534ff3b4d6ee8577477c440.tar.gz
gentoo-2-1889430d564b441ec534ff3b4d6ee8577477c440.tar.bz2
gentoo-2-1889430d564b441ec534ff3b4d6ee8577477c440.zip
more quoting
(Portage version: 2.1.2_rc4-r5)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/outerspace/files/outerspace16
-rw-r--r--games-strategy/outerspace/outerspace-0.5.59.ebuild19
2 files changed, 15 insertions, 20 deletions
diff --git a/games-strategy/outerspace/files/outerspace b/games-strategy/outerspace/files/outerspace
index abcadba78142..2a6bbe26dafb 100644
--- a/games-strategy/outerspace/files/outerspace
+++ b/games-strategy/outerspace/files/outerspace
@@ -1,11 +1,9 @@
-#! /bin/sh
+#!/bin/bash
+
+mkdir -p ~/.outerspace
+cd ~/.outerspace || exit 1
+
+ln -sf "@GENTOO_LIBDIR@"/{osc.py,lib,libsrvr} .
+ln -sf "@GENTOO_DATADIR@"/res .
-if [ ! -e $HOME/.outerspace ]
-then
- echo "First run - copying files to $HOME/.outerspace"
- mkdir $HOME/.outerspace
- ln -s @GENTOO_LIBDIR@/{osc.py,lib,libsrvr} $HOME/.outerspace/
- ln -s @GENTOO_DATADIR@/res $HOME/.outerspace/
-fi
-cd $HOME/.outerspace
exec python osc.py "$@"
diff --git a/games-strategy/outerspace/outerspace-0.5.59.ebuild b/games-strategy/outerspace/outerspace-0.5.59.ebuild
index 4ff48f87016e..456d03019d6d 100644
--- a/games-strategy/outerspace/outerspace-0.5.59.ebuild
+++ b/games-strategy/outerspace/outerspace-0.5.59.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/outerspace/outerspace-0.5.59.ebuild,v 1.2 2007/01/02 00:45:05 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/outerspace/outerspace-0.5.59.ebuild,v 1.3 2007/01/06 00:05:30 nyhm Exp $
inherit eutils games
@@ -8,7 +8,7 @@ MY_PN=${PN/outerspace/OuterSpace}
MY_P=${MY_PN}-$PV
DESCRIPTION="on-line strategy game taking place in the dangerous universe"
-HOMEPAGE="http://www.ospace.net"
+HOMEPAGE="http://www.ospace.net/"
SRC_URI="mirror://sourceforge/ospace/${MY_P}.tar.gz"
LICENSE="GPL-2"
@@ -24,22 +24,19 @@ S=${WORKDIR}/${MY_P}
src_unpack() {
unpack ${A}
cd "${S}"
- cp ${FILESDIR}/${PN} . || die "cp of wrapper failed"
- sed -i \
- -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
+ sed -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
-e "s:@GENTOO_LIBDIR@:${GAMES_LIBDIR}/${PN}:" \
- ${PN} || die "sed, updating path, failed"
+ "${FILESDIR}"/${PN} > ${PN} \
+ || die "sed failed"
}
src_install() {
- insinto ${GAMES_LIBDIR}/${PN}
+ insinto "${GAMES_LIBDIR}"/${PN}
doins -r osc.py lib libsrvr || die "doins of libraries failed"
- insinto ${GAMES_DATADIR}/${PN}
+ insinto "${GAMES_DATADIR}"/${PN}
doins -r res || die "doins of data failed"
dogamesbin ${PN} || die "dogamesbin failed"
-
newicon res/icon32.png ${PN}.png
-
- make_desktop_entry ${PN} ${MY_PN} ${PN}.png
+ make_desktop_entry ${PN} ${MY_PN}
prepgamesdirs
}