summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2006-10-03 09:03:57 +0000
committerTristan Heaven <nyhm@gentoo.org>2006-10-03 09:03:57 +0000
commit0642918b3c54166bf92bc0814d13b238caec127e (patch)
treecb6340355089666dccac0bba75ebddc2dd6aea84 /games-strategy
parentBump to 3.5.5 (pre-release). (diff)
downloadgentoo-2-0642918b3c54166bf92bc0814d13b238caec127e.tar.gz
gentoo-2-0642918b3c54166bf92bc0814d13b238caec127e.tar.bz2
gentoo-2-0642918b3c54166bf92bc0814d13b238caec127e.zip
Version bump
(Portage version: 2.1.2_pre2-r2)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/boson/ChangeLog7
-rw-r--r--games-strategy/boson/boson-0.13.ebuild55
-rw-r--r--games-strategy/boson/files/digest-boson-0.133
3 files changed, 64 insertions, 1 deletions
diff --git a/games-strategy/boson/ChangeLog b/games-strategy/boson/ChangeLog
index d8a2de91cc49..0ff482477fd1 100644
--- a/games-strategy/boson/ChangeLog
+++ b/games-strategy/boson/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/boson
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/boson/ChangeLog,v 1.25 2006/08/09 17:08:06 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/boson/ChangeLog,v 1.26 2006/10/03 09:03:57 nyhm Exp $
+
+*boson-0.13 (03 Oct 2006)
+
+ 03 Oct 2006; Tristan Heaven <nyhm@gentoo.org> +boson-0.13.ebuild:
+ Version bump
09 Aug 2006; Chris Gianelloni <wolf31o2@gentoo.org> -boson-0.11.ebuild:
Removing older revision.
diff --git a/games-strategy/boson/boson-0.13.ebuild b/games-strategy/boson/boson-0.13.ebuild
new file mode 100644
index 000000000000..ce6c0f9836cf
--- /dev/null
+++ b/games-strategy/boson/boson-0.13.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2006 Gentoo Foundation and Thomas Capricelli <orzel@kde.org>
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/boson/boson-0.13.ebuild,v 1.1 2006/10/03 09:03:57 nyhm Exp $
+
+inherit eutils kde-functions toolchain-funcs
+
+MY_P=${PN}-all-${PV}
+DESCRIPTION="real-time strategy game, with the feeling of Command&Conquer(tm)"
+HOMEPAGE="http://boson.sourceforge.net/"
+SRC_URI="mirror://sourceforge/boson/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-amd64 ~ppc -sparc ~x86"
+IUSE=""
+
+RDEPEND="virtual/opengl
+ virtual/glu
+ media-libs/openal"
+DEPEND="${RDEPEND}
+ >=dev-util/cmake-2.4.2"
+need-kde 3
+
+S=${WORKDIR}/${MY_P}/build
+
+src_unpack() {
+ unpack ${A}
+ cd ${MY_P}
+ mkdir build
+
+ # Sandbox fix
+ sed -i '/^kde3_install_icons/d' \
+ code/boson/data/CMakeLists.txt \
+ || die "sed failed"
+}
+
+src_compile() {
+ cmake \
+ -DCMAKE_C_COMPILER=$(which $(tc-getCC)) \
+ -DCMAKE_CXX_COMPILER=$(which $(tc-getCXX)) \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DKDEDIR=$(kde-config --prefix) \
+ .. || die "cmake failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ dodoc ../code/{AUTHORS,ChangeLog,README}
+
+ newicon ../code/boson/data/hi48-app-boson.png ${PN}.png
+
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
diff --git a/games-strategy/boson/files/digest-boson-0.13 b/games-strategy/boson/files/digest-boson-0.13
new file mode 100644
index 000000000000..f2178808cee5
--- /dev/null
+++ b/games-strategy/boson/files/digest-boson-0.13
@@ -0,0 +1,3 @@
+MD5 1b91bbdda1ff81d4d60f80c8175d974b boson-all-0.13.tar.bz2 37044878
+RMD160 ea5cb6faa7cb057292535743e78e6b214926626d boson-all-0.13.tar.bz2 37044878
+SHA256 d58fc2b4be93abb29300bcf68e26e383be0734269ecc16a425cca9e55809b8d1 boson-all-0.13.tar.bz2 37044878