summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-07-04 09:49:35 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-07-04 09:49:35 +0000
commita2b7c6da881bc96eb975e5e63c6b64ec8e274d70 (patch)
tree98ba715b79f60d63c4217c1fe145470ec71a9392 /games-strategy/wesnoth
parent~sparc added (Manifest recommit) (diff)
downloadgentoo-2-a2b7c6da881bc96eb975e5e63c6b64ec8e274d70.tar.gz
gentoo-2-a2b7c6da881bc96eb975e5e63c6b64ec8e274d70.tar.bz2
gentoo-2-a2b7c6da881bc96eb975e5e63c6b64ec8e274d70.zip
version bump
Diffstat (limited to 'games-strategy/wesnoth')
-rw-r--r--games-strategy/wesnoth/ChangeLog7
-rw-r--r--games-strategy/wesnoth/Manifest2
-rw-r--r--games-strategy/wesnoth/files/digest-wesnoth-0.81
-rw-r--r--games-strategy/wesnoth/wesnoth-0.8.ebuild41
4 files changed, 50 insertions, 1 deletions
diff --git a/games-strategy/wesnoth/ChangeLog b/games-strategy/wesnoth/ChangeLog
index 27710e247f41..9957ca1b7d81 100644
--- a/games-strategy/wesnoth/ChangeLog
+++ b/games-strategy/wesnoth/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/wesnoth
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.31 2004/06/28 20:40:27 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.32 2004/07/04 09:49:35 mr_bones_ Exp $
+
+*wesnoth-0.8 (04 Jul 2004)
+
+ 04 Jul 2004; Michael Sterrett <mr_bones_@gentoo.org> +wesnoth-0.8.ebuild:
+ version bump
*wesnoth-0.7.11 (28 Jun 2004)
diff --git a/games-strategy/wesnoth/Manifest b/games-strategy/wesnoth/Manifest
index d8917e20a972..7b35d65e2668 100644
--- a/games-strategy/wesnoth/Manifest
+++ b/games-strategy/wesnoth/Manifest
@@ -1,6 +1,8 @@
+MD5 8f636b82b8244db2276ddc6b236e12df wesnoth-0.8.ebuild 1118
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 63ad8befaa526cb255c579cc4872287a ChangeLog 4265
MD5 47e46af1d44b08c673f97459ddbeb781 wesnoth-0.7.10.ebuild 1117
MD5 8f636b82b8244db2276ddc6b236e12df wesnoth-0.7.11.ebuild 1118
+MD5 c62eaa95b5f21678b071c39ae5b60f0c files/digest-wesnoth-0.8 65
MD5 8caf74723a1c656cc112cdd5d41dc196 files/digest-wesnoth-0.7.10 68
MD5 92b397687e822d731d31d5a8371891ad files/digest-wesnoth-0.7.11 68
diff --git a/games-strategy/wesnoth/files/digest-wesnoth-0.8 b/games-strategy/wesnoth/files/digest-wesnoth-0.8
new file mode 100644
index 000000000000..4dfa162382d8
--- /dev/null
+++ b/games-strategy/wesnoth/files/digest-wesnoth-0.8
@@ -0,0 +1 @@
+MD5 c6258d08645a97c311c9538128f5af6e wesnoth-0.8.tar.gz 22171378
diff --git a/games-strategy/wesnoth/wesnoth-0.8.ebuild b/games-strategy/wesnoth/wesnoth-0.8.ebuild
new file mode 100644
index 000000000000..c502d021cabb
--- /dev/null
+++ b/games-strategy/wesnoth/wesnoth-0.8.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-0.8.ebuild,v 1.1 2004/07/04 09:49:35 mr_bones_ Exp $
+
+inherit flag-o-matic gcc games
+
+DESCRIPTION="A fantasy turn-based strategy game"
+HOMEPAGE="http://www.wesnoth.org/"
+SRC_URI="http://www.wesnoth.org/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc sparc amd64"
+IUSE="server editor tools gnome kde"
+
+DEPEND=">=media-libs/libsdl-1.2.7
+ >=media-libs/sdl-image-1.2
+ >=media-libs/sdl-mixer-1.2
+ >=media-libs/sdl-ttf-2.0
+ media-libs/sdl-net
+ virtual/x11"
+
+src_compile() {
+ [ "$(gcc-fullversion)" == "3.4.0" ] && filter-flags -ftracer
+ egamesconf \
+ --disable-dependency-tracking \
+ $(use_enable server) \
+ $(use_enable editor) \
+ $(use_enable tools) \
+ $(use_enable gnome) \
+ $(use_enable kde) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ mv "${D}${GAMES_DATADIR}/icons" "${D}/usr/share/"
+ dodoc MANUAL changelog || die "dodoc failed"
+ prepgamesdirs
+}