summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-04-07 19:44:58 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-04-07 19:44:58 +0000
commit9bb55bbad668954b94249c56b7d45c69bdc576e2 (patch)
tree99a6cf7e44db1fd1c18598f71103f0449d35b322 /games-strategy/wesnoth
parentFix package names in message in pkg_postinst(). (diff)
downloadgentoo-2-9bb55bbad668954b94249c56b7d45c69bdc576e2.tar.gz
gentoo-2-9bb55bbad668954b94249c56b7d45c69bdc576e2.tar.bz2
gentoo-2-9bb55bbad668954b94249c56b7d45c69bdc576e2.zip
another attempt at sane boost handling
(Portage version: 2.1.7.17/cvs/Linux i686)
Diffstat (limited to 'games-strategy/wesnoth')
-rw-r--r--games-strategy/wesnoth/ChangeLog5
-rw-r--r--games-strategy/wesnoth/wesnoth-1.8.ebuild22
2 files changed, 15 insertions, 12 deletions
diff --git a/games-strategy/wesnoth/ChangeLog b/games-strategy/wesnoth/ChangeLog
index 4733bb190575..7a5b812e1fe2 100644
--- a/games-strategy/wesnoth/ChangeLog
+++ b/games-strategy/wesnoth/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-strategy/wesnoth
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.176 2010/04/07 03:13:41 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.177 2010/04/07 19:44:58 mr_bones_ Exp $
+
+ 07 Apr 2010; Michael Sterrett <mr_bones_@gentoo.org> wesnoth-1.8.ebuild:
+ another attempt at sane boost handling
07 Apr 2010; Michael Sterrett <mr_bones_@gentoo.org> wesnoth-1.8.ebuild:
Expose the actual build commands to confirm proper behavior
diff --git a/games-strategy/wesnoth/wesnoth-1.8.ebuild b/games-strategy/wesnoth/wesnoth-1.8.ebuild
index 024b17152107..7b6308be59fe 100644
--- a/games-strategy/wesnoth/wesnoth-1.8.ebuild
+++ b/games-strategy/wesnoth/wesnoth-1.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-1.8.ebuild,v 1.7 2010/04/07 03:13:41 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-1.8.ebuild,v 1.8 2010/04/07 19:44:58 mr_bones_ Exp $
EAPI=2
inherit cmake-utils eutils multilib toolchain-funcs flag-o-matic games
@@ -22,8 +22,7 @@ RDEPEND=">=media-libs/libsdl-1.2.7[video,X]
!dedicated? (
dbus? ( sys-apps/dbus )
)
- amd64? ( >=dev-libs/boost-1.35:0 )
- !amd64? ( || ( dev-libs/boost:1.42 dev-libs/boost:1.41 >=dev-libs/boost-1.35:0 ) )
+ >=dev-libs/boost-1.35:0
sys-libs/zlib
x11-libs/pango
dev-lang/lua
@@ -58,18 +57,19 @@ src_prepare() {
|| die "sed failed"
fi
# how do I hate boost? Let me count the ways...
- local boost_ver
- if use amd64 ; then
- boost_ver=1_35
- else
- has_version dev-libs/boost:0 && boost_ver=1_35
- has_version dev-libs/boost:1.41 && boost_ver=1_41
- has_version dev-libs/boost:1.42 && boost_ver=1_42
- fi
+ local boost_ver=$(best_version ">=dev-libs/boost-1.35")
+
+ boost_ver=${boost_ver/*boost-/}
+ boost_ver=${boost_ver%.*}
+ boost_ver=${boost_ver/./_}
+
+ einfo "Using boost version ${boost_ver}"
append-cxxflags \
-I/usr/include/boost-${boost_ver}
append-ldflags \
-L/usr/$(get_libdir)/boost-${boost_ver}
+ export BOOST_INCLUDEDIR="/usr/include/boost-${boost_ver}"
+ export BOOST_LIBRARYDIR="/usr/$(get_libdir)/boost-${boost_ver}"
}
src_configure() {