summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-02-26 20:08:39 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-02-26 20:08:39 +0000
commit00606c0a5f97b9a3291d7919f8f57fc6b6c25ed4 (patch)
treedbd9966023d1b832c1c10d832a24b6daf44520a9 /games-strategy/freeciv
parentMasking samba-3.4.6 as it is the first unsplit 3.4-series ebuild (diff)
downloadgentoo-2-00606c0a5f97b9a3291d7919f8f57fc6b6c25ed4.tar.gz
gentoo-2-00606c0a5f97b9a3291d7919f8f57fc6b6c25ed4.tar.bz2
gentoo-2-00606c0a5f97b9a3291d7919f8f57fc6b6c25ed4.zip
version bump
(Portage version: 2.1.7.16/cvs/Linux i686)
Diffstat (limited to 'games-strategy/freeciv')
-rw-r--r--games-strategy/freeciv/ChangeLog8
-rw-r--r--games-strategy/freeciv/files/freeciv-2.2.0-clean-man.patch22
-rw-r--r--games-strategy/freeciv/freeciv-2.2.0.ebuild112
3 files changed, 141 insertions, 1 deletions
diff --git a/games-strategy/freeciv/ChangeLog b/games-strategy/freeciv/ChangeLog
index 1e45191ff3e0..bf6660b69d1d 100644
--- a/games-strategy/freeciv/ChangeLog
+++ b/games-strategy/freeciv/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/freeciv
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/freeciv/ChangeLog,v 1.98 2010/02/09 05:51:43 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freeciv/ChangeLog,v 1.99 2010/02/26 20:08:38 mr_bones_ Exp $
+
+*freeciv-2.2.0 (26 Feb 2010)
+
+ 26 Feb 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ +freeciv-2.2.0.ebuild, +files/freeciv-2.2.0-clean-man.patch:
+ version bump
09 Feb 2010; Michael Sterrett <mr_bones_@gentoo.org>
freeciv-2.1.11.ebuild:
diff --git a/games-strategy/freeciv/files/freeciv-2.2.0-clean-man.patch b/games-strategy/freeciv/files/freeciv-2.2.0-clean-man.patch
new file mode 100644
index 000000000000..b5c4d2337360
--- /dev/null
+++ b/games-strategy/freeciv/files/freeciv-2.2.0-clean-man.patch
@@ -0,0 +1,22 @@
+diff -ru freeciv-2.2.0.orig/doc/man/Makefile.in freeciv-2.2.0/doc/man/Makefile.in
+--- freeciv-2.2.0.orig/doc/man/Makefile.in 2010-02-21 13:52:28.000000000 -0500
++++ freeciv-2.2.0/doc/man/Makefile.in 2010-02-26 04:00:07.713504939 -0500
+@@ -347,8 +347,7 @@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+ MAN_PAGES = \
+- freeciv-server.6 \
+- freeciv-client.6
++ freeciv-server.6
+
+ MAN_LINKS = \
+ freeciv-gtk2.6 \
+@@ -357,7 +356,7 @@
+ freeciv-win32.6 \
+ freeciv-ftwl.6
+
+-man_MANS = $(MAN_PAGES) $(MAN_LINKS)
++man_MANS = $(MAN_PAGES)
+ EXTRA_DIST = $(man_MANS)
+ all: all-am
+
diff --git a/games-strategy/freeciv/freeciv-2.2.0.ebuild b/games-strategy/freeciv/freeciv-2.2.0.ebuild
new file mode 100644
index 000000000000..c675d2ac5383
--- /dev/null
+++ b/games-strategy/freeciv/freeciv-2.2.0.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freeciv/freeciv-2.2.0.ebuild,v 1.1 2010/02/26 20:08:38 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils gnome2-utils games
+
+DESCRIPTION="multiplayer strategy game (Civilization Clone)"
+HOMEPAGE="http://www.freeciv.org/"
+SRC_URI="mirror://sourceforge/freeciv/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="auth dedicated ggz gtk nls readline sdl"
+
+RDEPEND="readline? ( sys-libs/readline )
+ sys-libs/zlib
+ app-arch/bzip2
+ !dedicated? (
+ nls? ( virtual/libintl )
+ gtk? ( x11-libs/gtk+:2 )
+ sdl? (
+ media-libs/libsdl[audio,video]
+ media-libs/sdl-image[png]
+ media-libs/freetype
+ media-libs/sdl-mixer
+ )
+ !gtk? ( !sdl? ( x11-libs/gtk+:2 ) )
+ ggz? ( dev-games/ggz-client-libs )
+ media-libs/libpng
+ auth? ( virtual/mysql )
+ )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ !dedicated? (
+ nls? ( sys-devel/gettext )
+ x11-proto/xextproto
+ )"
+
+src_prepare() {
+ # install the .desktop in /usr/share/applications
+ # install the icons in /usr/share/pixmaps
+ sed -i \
+ -e 's:^\(desktopfiledir = \).*:\1/usr/share/applications:' \
+ -e 's:^\(icon[0-9]*dir = \)$(prefix)\(.*\):\1/usr\2:' \
+ -e 's:^\(icon[0-9]*dir = \)$(datadir)\(.*\):\1/usr/share\2:' \
+ client/Makefile.in \
+ server/Makefile.in \
+ data/Makefile.in \
+ data/icons/Makefile.in \
+ || die "sed failed"
+
+ # remove civclient manpage if dedicated server
+ if use dedicated ; then
+ epatch "${FILESDIR}"/${P}-clean-man.patch
+ fi
+}
+
+src_configure() {
+ local myclient="gtk" # default to gtk if none specified
+
+ if use dedicated ; then
+ myclient="no"
+ else
+ use sdl && myclient="${myclient} sdl"
+ fi
+
+ egamesconf \
+ --disable-dependency-tracking \
+ --localedir=/usr/share/locale \
+ $(use_enable auth) \
+ $(use_enable nls) \
+ $(use_with readline) \
+ $(use_enable sdl sdl-mixer) \
+ $(use_with ggz ggz-client) \
+ --enable-client="${myclient}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ if ! use dedicated ; then
+ # Create and install the html manual. It can't be done for dedicated
+ # servers, because the 'civmanual' tool is then not built. Also
+ # delete civmanual from the GAMES_BINDIR, because it's then useless.
+ # Note: to have it localized, it should be ran from _postinst, or
+ # something like that, but then it's a PITA to avoid orphan files...
+ ./manual/civmanual || die "civmanual failed"
+ dohtml manual*.html || die "dohtml failed"
+ rm -f "${D}/${GAMES_BINDIR}"/civmanual
+ use sdl && make_desktop_entry freeciv-sdl "Freeciv (SDL)" freeciv-client
+ fi
+
+ dodoc ChangeLog NEWS doc/{BUGS,CodingStyle,HACKING,HOWTOPLAY,README*,TODO}
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}