summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-10-13 15:44:09 +0000
committerMike Frysinger <vapier@gentoo.org>2003-10-13 15:44:09 +0000
commitdd3f67d596846d272adf19f15d473241bd7c32f5 (patch)
treeabc079f3cecbab626bf4f01954774be43a07279a /games-strategy/crimson/crimson-0.3.7.ebuild
parentstable on alpha (diff)
downloadgentoo-2-dd3f67d596846d272adf19f15d473241bd7c32f5.tar.gz
gentoo-2-dd3f67d596846d272adf19f15d473241bd7c32f5.tar.bz2
gentoo-2-dd3f67d596846d272adf19f15d473241bd7c32f5.zip
ver bump
Diffstat (limited to 'games-strategy/crimson/crimson-0.3.7.ebuild')
-rw-r--r--games-strategy/crimson/crimson-0.3.7.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/games-strategy/crimson/crimson-0.3.7.ebuild b/games-strategy/crimson/crimson-0.3.7.ebuild
new file mode 100644
index 000000000000..0da0ef58677e
--- /dev/null
+++ b/games-strategy/crimson/crimson-0.3.7.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/crimson/crimson-0.3.7.ebuild,v 1.1 2003/10/13 15:44:09 vapier Exp $
+
+inherit games
+
+DESCRIPTION="tactical war game in the tradition of Battle Isle"
+HOMEPAGE="http://crimson.seul.org/"
+SRC_URI="http://crimson.seul.org/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="zlib"
+
+DEPEND=">=libsdl-1.1.5
+ >=sdl-mixer-1.2.4
+ dev-libs/libxslt
+ zlib? ( sys-libs/zlib )"
+
+src_compile() {
+ egamesconf \
+ `use_enable zlib` \
+ --enable-cfed \
+ --enable-bi2cf \
+ --enable-comet \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "make install failed"
+ dodoc NEWS README* THANKS TODO
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ ewarn "Crimson Fields ${PV} is not save-game compatible with previous versions."
+ echo
+ einfo "If you have older save files and you wish to continue those games,"
+ einfo "you'll need to remerge the version with which you started"
+ einfo "those save-games."
+}