summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2006-07-29 23:05:57 +0000
committerAlfredo Tupone <tupone@gentoo.org>2006-07-29 23:05:57 +0000
commit54c5e8cb005736a1a3d03fb7264ae34100222b35 (patch)
treec41d95af10244cc44d1a057b3f4f8bae76adcfaa /games-strategy/castle-combat/castle-combat-0.8.1.ebuild
parentFixed JDK dependencies, so Java 1.5 won't be used. (diff)
downloadgentoo-2-54c5e8cb005736a1a3d03fb7264ae34100222b35.tar.gz
gentoo-2-54c5e8cb005736a1a3d03fb7264ae34100222b35.tar.bz2
gentoo-2-54c5e8cb005736a1a3d03fb7264ae34100222b35.zip
Version bump, bug #111305
(Portage version: 2.1-r1)
Diffstat (limited to 'games-strategy/castle-combat/castle-combat-0.8.1.ebuild')
-rw-r--r--games-strategy/castle-combat/castle-combat-0.8.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/games-strategy/castle-combat/castle-combat-0.8.1.ebuild b/games-strategy/castle-combat/castle-combat-0.8.1.ebuild
new file mode 100644
index 000000000000..4b6e972a150a
--- /dev/null
+++ b/games-strategy/castle-combat/castle-combat-0.8.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/castle-combat/castle-combat-0.8.1.ebuild,v 1.1 2006/07/29 23:05:56 tupone Exp $
+
+inherit games
+
+DESCRIPTION="A clone of the old arcade game Rampart"
+HOMEPAGE="http://www.linux-games.com/castle-combat/"
+SRC_URI="mirror://sourceforge/castle-combat/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="dev-python/twisted
+ dev-python/pygame"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -e "s:src:${GAMES_LIBDIR}/${PN}:" \
+ castle-combat.py
+ sed -i -e "/data_path =/s:\"data:\"${GAMES_DATADIR}/${PN}:" \
+ src/common.py
+}
+
+src_install() {
+ newgamesbin castle-combat.py castle-combat
+ insinto ${GAMES_LIBDIR}/${PN}
+ doins src/*
+ insinto ${GAMES_DATADIR}/${PN}
+ doins -r data/{colourba.ttf,gfx,sound}
+ dohtml -r data/font_read_me.html data/doc
+ dodoc TODO
+ prepgamesdirs
+}