summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2007-09-15 21:24:09 +0000
committerAlfredo Tupone <tupone@gentoo.org>2007-09-15 21:24:09 +0000
commit1d4d375b738f3ade6f0e96e15427f533de168778 (patch)
treec440107c98a3b52674f2402defadeb1f6830399c /games-strategy/castle-combat/castle-combat-0.8.1.ebuild
parentfixed syntax error (diff)
downloadgentoo-2-1d4d375b738f3ade6f0e96e15427f533de168778.tar.gz
gentoo-2-1d4d375b738f3ade6f0e96e15427f533de168778.tar.bz2
gentoo-2-1d4d375b738f3ade6f0e96e15427f533de168778.zip
Check for mikmod use flag in media-libs/sdl-mixer. Fixes bug #188877
(Portage version: 2.1.2.12)
Diffstat (limited to 'games-strategy/castle-combat/castle-combat-0.8.1.ebuild')
-rw-r--r--games-strategy/castle-combat/castle-combat-0.8.1.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/games-strategy/castle-combat/castle-combat-0.8.1.ebuild b/games-strategy/castle-combat/castle-combat-0.8.1.ebuild
index 4c6fcd0d979c..9f6839a3e48a 100644
--- a/games-strategy/castle-combat/castle-combat-0.8.1.ebuild
+++ b/games-strategy/castle-combat/castle-combat-0.8.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/castle-combat/castle-combat-0.8.1.ebuild,v 1.3 2007/04/04 20:53:17 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/castle-combat/castle-combat-0.8.1.ebuild,v 1.4 2007/09/15 21:24:09 tupone Exp $
inherit eutils games
@@ -16,6 +16,13 @@ IUSE=""
RDEPEND="dev-python/twisted
dev-python/pygame"
+pkg_setup() {
+ games_pkg_setup
+ if ! built_with_use media-libs/sdl-mixer mikmod; then
+ die "Please emerge media-libs/sdl-mixer with USE=mikmod"
+ fi
+}
+
src_unpack() {
unpack ${A}
cd "${S}"