summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-06-09 01:55:51 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-06-09 01:55:51 +0000
commit43879d631aff35703db4349bff73f84b73e12c5d (patch)
treedb7094fbec2258294912ed810376fd5fb79cb2fd /games-strategy/boson
parentAdded sys-devel/bc to DEPEND and closing bug #135762. (diff)
downloadgentoo-2-43879d631aff35703db4349bff73f84b73e12c5d.tar.gz
gentoo-2-43879d631aff35703db4349bff73f84b73e12c5d.tar.bz2
gentoo-2-43879d631aff35703db4349bff73f84b73e12c5d.zip
Version bump. Thanks to Tristan Heaven <tristanheaven@gmail.com> for the updated ebuild. Closing bug #134701.
(Portage version: 2.1_rc4-r5)
Diffstat (limited to 'games-strategy/boson')
-rw-r--r--games-strategy/boson/ChangeLog10
-rw-r--r--games-strategy/boson/boson-0.12.ebuild57
-rw-r--r--games-strategy/boson/files/boson-0.11-openal.patch23
-rw-r--r--games-strategy/boson/files/boson-0.12-gcc41.patch28
-rw-r--r--games-strategy/boson/files/digest-boson-0.123
5 files changed, 120 insertions, 1 deletions
diff --git a/games-strategy/boson/ChangeLog b/games-strategy/boson/ChangeLog
index 11f313131b5d..292dd5010898 100644
--- a/games-strategy/boson/ChangeLog
+++ b/games-strategy/boson/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for games-strategy/boson
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/boson/ChangeLog,v 1.18 2006/06/03 15:29:40 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/boson/ChangeLog,v 1.19 2006/06/09 01:55:51 wolf31o2 Exp $
+
+*boson-0.12 (09 Jun 2006)
+
+ 09 Jun 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+ +files/boson-0.11-openal.patch, +files/boson-0.12-gcc41.patch,
+ +boson-0.12.ebuild:
+ Version bump. Thanks to Tristan Heaven <tristanheaven@gmail.com> for the
+ updated ebuild. Closing bug #134701.
03 Jun 2006; <Tupone@gentoo.org> boson-0.11.ebuild:
Dependency on arts is optional, bug #134241 by Andrei Slavoiu
diff --git a/games-strategy/boson/boson-0.12.ebuild b/games-strategy/boson/boson-0.12.ebuild
new file mode 100644
index 000000000000..8dc9d14aaa0d
--- /dev/null
+++ b/games-strategy/boson/boson-0.12.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2006 Gentoo Foundation and Thomas Capricelli <orzel@kde.org>
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/boson/boson-0.12.ebuild,v 1.1 2006/06/09 01:55:51 wolf31o2 Exp $
+
+inherit eutils kde-functions toolchain-funcs
+
+DESCRIPTION="real-time strategy game, with the feeling of Command&Conquer(tm)"
+HOMEPAGE="http://boson.sourceforge.net/"
+SRC_URI="mirror://sourceforge/boson/boson-all-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc -sparc ~x86"
+IUSE=""
+
+RDEPEND="virtual/opengl
+ virtual/glu
+ media-libs/openal"
+DEPEND="${RDEPEND}
+ >=dev-util/cmake-2.4.2"
+need-kde 3
+
+S=${WORKDIR}/${PN}-all-${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ mkdir build
+
+ epatch "${FILESDIR}"/${P}-gcc41.patch
+
+ # Sandbox fix
+ sed -i 's/^kde/#kde/' code/boson/data/CMakeLists.txt || die "sed failed"
+}
+
+src_compile() {
+ cd build
+ cmake \
+ -DCMAKE_C_COMPILER=$(which $(tc-getCC)) \
+ -DCMAKE_CXX_COMPILER=$(which $(tc-getCXX)) \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_VERBOSE_MAKEFILE=1 \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DKDEDIR=$(kde-config --prefix) \
+ .. || die "cmake failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ dodoc code/{AUTHORS,ChangeLog,README}
+
+ newicon code/boson/data/hi48-app-boson.png ${PN}.png
+
+ cd build
+ make DESTDIR="${D}" install || die "make install failed"
+}
diff --git a/games-strategy/boson/files/boson-0.11-openal.patch b/games-strategy/boson/files/boson-0.11-openal.patch
new file mode 100644
index 000000000000..78f7a91497c5
--- /dev/null
+++ b/games-strategy/boson/files/boson-0.11-openal.patch
@@ -0,0 +1,23 @@
+--- bosound/openal/bosonaudioal.h
++++ bosound/openal/bosonaudioal.h
+@@ -21,7 +21,7 @@
+
+ #include "../bosonaudio.h"
+
+-#include <AL/altypes.h>
++#include <AL/al.h>
+
+ class QString;
+ class BosonMusic;
+
+--- bosound/openal/bosonsound.h
++++ bosound/openal/bosonsound.h
+@@ -24,7 +24,7 @@
+ #include <qptrlist.h>
+ #include <qmap.h>
+
+-#include <AL/altypes.h>
++#include <AL/al.h>
+
+ class BoPlayObject;
+ class BosonAudioAL;
diff --git a/games-strategy/boson/files/boson-0.12-gcc41.patch b/games-strategy/boson/files/boson-0.12-gcc41.patch
new file mode 100644
index 000000000000..f9021e20ce2a
--- /dev/null
+++ b/games-strategy/boson/files/boson-0.12-gcc41.patch
@@ -0,0 +1,28 @@
+--- code/boson/bosonufoglwidget.cpp 2006/05/28 20:06:45 7549
++++ code/boson/bosonufoglwidget.cpp 2006/05/29 12:50:14 7550
+@@ -35,11 +35,11 @@
+ BoUfoRealProfiling()
+ {
+ }
+- void BoUfoRealProfiling::push(const QString& name)
++ void push(const QString& name)
+ {
+ boProfiling->push(name);
+ }
+- void BoUfoRealProfiling::pop()
++ void pop()
+ {
+ boProfiling->pop();
+ }
+
+--- code/boson/qlistviewitemnumber.cpp 2006/05/28 20:06:45 7549
++++ code/boson/qlistviewitemnumber.cpp 2006/05/29 12:50:14 7550
+@@ -51,7 +51,7 @@
+ QString QListViewItemNumberPrefix::key(int column, bool ascending) const
+ {
+ QString k = QListViewItemNumber::key(column, ascending);
+- QRegExp r("^[0-9]+(\.[0-9]+)?");
++ QRegExp r("^[0-9]+(\\.[0-9]+)?");
+ if (r.search(k) >= 0) {
+ return r.cap(0);
+ }
diff --git a/games-strategy/boson/files/digest-boson-0.12 b/games-strategy/boson/files/digest-boson-0.12
new file mode 100644
index 000000000000..0cf67d1abf0f
--- /dev/null
+++ b/games-strategy/boson/files/digest-boson-0.12
@@ -0,0 +1,3 @@
+MD5 61a9f7270ebc20643df9c0fe534d0744 boson-all-0.12.tar.bz2 36823025
+RMD160 480432f090679af6dc4a5d52ed69be1ca3b5892c boson-all-0.12.tar.bz2 36823025
+SHA256 a887bf248ceb7f09f0aa01592f84a3bd3be52c3b10a94bc19d581076581cf1fa boson-all-0.12.tar.bz2 36823025