summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-02-19 01:28:22 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-02-19 01:28:22 +0000
commitd66c5b9fad3b6dc889ae7a0037751cd215d0a8b5 (patch)
treefbad9bd2476c588efdd79cdc0ef044a20cbdfd57 /games-sports
parentold (diff)
downloadgentoo-2-d66c5b9fad3b6dc889ae7a0037751cd215d0a8b5.tar.gz
gentoo-2-d66c5b9fad3b6dc889ae7a0037751cd215d0a8b5.tar.bz2
gentoo-2-d66c5b9fad3b6dc889ae7a0037751cd215d0a8b5.zip
old
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-sports')
-rw-r--r--games-sports/vdrift/ChangeLog7
-rw-r--r--games-sports/vdrift/files/vdrift-20111022-build.patch27
-rw-r--r--games-sports/vdrift/files/vdrift-20111022-bullet282.patch11
-rw-r--r--games-sports/vdrift/vdrift-20111022.ebuild65
4 files changed, 6 insertions, 104 deletions
diff --git a/games-sports/vdrift/ChangeLog b/games-sports/vdrift/ChangeLog
index ffb100d11fce..0c043cff5887 100644
--- a/games-sports/vdrift/ChangeLog
+++ b/games-sports/vdrift/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-sports/vdrift
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/vdrift/ChangeLog,v 1.27 2015/02/10 10:11:32 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/vdrift/ChangeLog,v 1.28 2015/02/19 01:28:22 mr_bones_ Exp $
+
+ 19 Feb 2015; Michael Sterrett <mr_bones_@gentoo.org>
+ -files/vdrift-20111022-build.patch, -files/vdrift-20111022-bullet282.patch,
+ -vdrift-20111022.ebuild:
+ old
10 Feb 2015; Agostino Sarubbo <ago@gentoo.org> vdrift-20120722.ebuild:
Stable for x86, wrt bug #539192
diff --git a/games-sports/vdrift/files/vdrift-20111022-build.patch b/games-sports/vdrift/files/vdrift-20111022-build.patch
deleted file mode 100644
index 6384910faadd..000000000000
--- a/games-sports/vdrift/files/vdrift-20111022-build.patch
+++ /dev/null
@@ -1,27 +0,0 @@
---- SConstruct
-+++ SConstruct
-@@ -138,6 +139,7 @@
- LINKFLAGS = ['-pthread'],
- CC = 'gcc', CXX = 'g++',
- options = opts)
-+ env['LINKFLAGS'] += SCons.Util.CLVar(os.environ['LDFLAGS'])
- check_headers = ['asio.hpp', 'boost/bind.hpp', 'GL/gl.h', 'GL/glu.h', 'SDL/SDL.h', 'SDL/SDL_image.h', 'SDL/SDL_rotozoom.h', 'vorbis/vorbisfile.h', 'GL/glew.h', 'curl/curl.h', 'bullet/btBulletCollisionCommon.h', 'archive.h']
- check_libs = [ ['GLEW', 'GL/glew.h', 'glDeleteSamplers(0, NULL);', 'Your GLEW library is out of date.'] ]
-
-@@ -390,7 +392,7 @@
- if env['release']:
- # release build, debugging off, optimizations on
- if (sys.platform != 'freebsd6') and (sys.platform != 'freebsd7') and (sys.platform != 'freebsd8') and (sys.platform != 'freebsd9') and (sys.platform != 'win32') and (sys.platform != 'cygwin'):
-- env.Append(CCFLAGS = ['-O1', '-pipe'])
-+ env.Append(CCFLAGS = ['-pipe'])
- else:
- # debug build, lots of debugging, no optimizations
- env.Append(CCFLAGS = ['-g3'])
-@@ -409,7 +411,6 @@
- env.Append(CCFLAGS = ['-pg'])
- env.Append(LINKFLAGS = ['-pg'])
- env.Append(CCFLAGS = ['-g3'])
-- env.Append(CCFLAGS = ['-O1'])
-
- #------------------------------------#
- # compile-time efficiency assessment #
diff --git a/games-sports/vdrift/files/vdrift-20111022-bullet282.patch b/games-sports/vdrift/files/vdrift-20111022-bullet282.patch
deleted file mode 100644
index a16dd42f8365..000000000000
--- a/games-sports/vdrift/files/vdrift-20111022-bullet282.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/dynamicsworld.cpp.old 2014-05-15 13:23:06.584092773 +0200
-+++ src/dynamicsworld.cpp 2014-05-15 13:23:13.748948512 +0200
-@@ -101,7 +101,7 @@
- int patch_id = -1;
- const BEZIER * b = 0;
- const TRACKSURFACE * s = TRACKSURFACE::None();
-- btCollisionObject * c = 0;
-+ const btCollisionObject * c = 0;
-
- MyRayResultCallback ray(origin, p, caster);
- rayTest(origin, p, ray);
diff --git a/games-sports/vdrift/vdrift-20111022.ebuild b/games-sports/vdrift/vdrift-20111022.ebuild
deleted file mode 100644
index 0e320dca0f50..000000000000
--- a/games-sports/vdrift/vdrift-20111022.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/vdrift/vdrift-20111022.ebuild,v 1.6 2014/05/15 11:46:29 tupone Exp $
-
-EAPI=2
-inherit eutils scons-utils games
-
-MY_P=${PN}-${PV:0:4}-${PV:4:2}-${PV:6:2}
-DESCRIPTION="A driving simulation made with drift racing in mind"
-HOMEPAGE="http://vdrift.net/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
-
-LICENSE="GPL-3 ZLIB"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-RDEPEND="app-arch/libarchive
- media-libs/glew
- media-libs/libsdl[opengl,video]
- media-libs/sdl-gfx
- media-libs/sdl-image[png]
- media-libs/libvorbis
- net-misc/curl
- sci-physics/bullet[-double-precision]
- virtual/opengl
- virtual/glu"
-DEPEND="${RDEPEND}
- dev-cpp/asio
- dev-libs/boost
- virtual/pkgconfig"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-build.patch \
- "${FILESDIR}"/${P}-bullet282.patch
-}
-
-src_compile() {
- escons \
- force_feedback=1 \
- destdir="${D}" \
- bindir="${GAMES_BINDIR}" \
- datadir="${GAMES_DATADIR}"/${PN} \
- prefix= \
- use_binreloc=0 \
- release=1 \
- os_cc=1 \
- os_cxx=1 \
- os_cxxflags=1 \
- || die
-}
-
-src_install() {
- dogamesbin build/vdrift || die
- insinto "${GAMES_DATADIR}/${PN}"
- doins -r data/* || die
- newicon data/textures/icons/vdrift-64x64.png ${PN}.png
- make_desktop_entry ${PN} VDrift
- find "${D}" -name "SCon*" -exec rm \{\} +
- cd "${D}"
- keepdir $(find "${GAMES_DATADIR/\//}/${PN}" -type d -empty)
- prepgamesdirs
-}