summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-07-24 01:33:22 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-07-24 01:33:22 +0000
commit7d3e14ca04e9d80fb5e99fe59d78893a44cc462a (patch)
tree24f6c58800e72598b18382b1b0eaca60ea80fcef /games-sports
parentVersion bump, fixes bug 277664 (diff)
downloadgentoo-2-7d3e14ca04e9d80fb5e99fe59d78893a44cc462a.tar.gz
gentoo-2-7d3e14ca04e9d80fb5e99fe59d78893a44cc462a.tar.bz2
gentoo-2-7d3e14ca04e9d80fb5e99fe59d78893a44cc462a.zip
EAPI=2
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-sports')
-rw-r--r--games-sports/torcs/ChangeLog7
-rw-r--r--games-sports/torcs/torcs-1.3.1.ebuild15
2 files changed, 13 insertions, 9 deletions
diff --git a/games-sports/torcs/ChangeLog b/games-sports/torcs/ChangeLog
index e83769e23541..7a8716e04e26 100644
--- a/games-sports/torcs/ChangeLog
+++ b/games-sports/torcs/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-sports/torcs
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/torcs/ChangeLog,v 1.27 2009/01/08 22:52:51 mr_bones_ Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-sports/torcs/ChangeLog,v 1.28 2009/07/24 01:33:22 mr_bones_ Exp $
+
+ 24 Jul 2009; Michael Sterrett <mr_bones_@gentoo.org> torcs-1.3.1.ebuild:
+ EAPI=2
08 Jan 2009; Michael Sterrett <mr_bones_@gentoo.org> torcs-1.3.1.ebuild:
parallel make doesn't work with install either (bug #251797)
diff --git a/games-sports/torcs/torcs-1.3.1.ebuild b/games-sports/torcs/torcs-1.3.1.ebuild
index 046aa809bbbd..fbd2fb619e42 100644
--- a/games-sports/torcs/torcs-1.3.1.ebuild
+++ b/games-sports/torcs/torcs-1.3.1.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/torcs/torcs-1.3.1.ebuild,v 1.2 2009/01/08 22:52:51 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/torcs/torcs-1.3.1.ebuild,v 1.3 2009/07/24 01:33:22 mr_bones_ Exp $
+EAPI=2
inherit autotools eutils multilib games
DESCRIPTION="The Open Racing Car Simulator"
@@ -25,22 +26,22 @@ RDEPEND=">=media-libs/plib-1.8.4
DEPEND="${RDEPEND}
x11-proto/xf86vidmodeproto"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch \
"${FILESDIR}"/${P}-as-needed.patch
eautoreconf
ecvs_clean
}
-src_compile() {
+src_configure() {
egamesconf \
--disable-dependency-tracking \
--datadir="${GAMES_DATADIR_BASE}" \
--x-libraries=/usr/$(get_libdir) \
- --enable-xrandr \
- || die
+ --enable-xrandr
+}
+
+src_compile() {
emake -j1 || die "emake failed"
}