summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2007-10-21 21:30:43 +0000
committerStefan Schweizer <genstef@gentoo.org>2007-10-21 21:30:43 +0000
commit3b8f6e8f1801c18b91e2931a0f09cb86b97aac94 (patch)
tree458a1fc86f9f81111cd4d684960a62c9b3f9e22f /games-sports
parentVersion bump, fix some quoting (diff)
downloadgentoo-2-3b8f6e8f1801c18b91e2931a0f09cb86b97aac94.tar.gz
gentoo-2-3b8f6e8f1801c18b91e2931a0f09cb86b97aac94.tar.bz2
gentoo-2-3b8f6e8f1801c18b91e2931a0f09cb86b97aac94.zip
version bump
(Portage version: 2.1.3.15)
Diffstat (limited to 'games-sports')
-rw-r--r--games-sports/xmoto/ChangeLog7
-rw-r--r--games-sports/xmoto/files/digest-xmoto-0.3.46
-rw-r--r--games-sports/xmoto/xmoto-0.3.4.ebuild76
3 files changed, 88 insertions, 1 deletions
diff --git a/games-sports/xmoto/ChangeLog b/games-sports/xmoto/ChangeLog
index 3a448976ec30..8473a37a82a0 100644
--- a/games-sports/xmoto/ChangeLog
+++ b/games-sports/xmoto/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-sports/xmoto
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/xmoto/ChangeLog,v 1.19 2007/09/02 18:53:51 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/xmoto/ChangeLog,v 1.20 2007/10/21 21:30:42 genstef Exp $
+
+*xmoto-0.3.4 (21 Oct 2007)
+
+ 21 Oct 2007; Stefan Schweizer <genstef@gentoo.org> +xmoto-0.3.4.ebuild:
+ version bump
*xmoto-0.3.3 (02 Sep 2007)
diff --git a/games-sports/xmoto/files/digest-xmoto-0.3.4 b/games-sports/xmoto/files/digest-xmoto-0.3.4
new file mode 100644
index 000000000000..c94d9ee48333
--- /dev/null
+++ b/games-sports/xmoto/files/digest-xmoto-0.3.4
@@ -0,0 +1,6 @@
+MD5 1509555c6cfd71f5775ab1b997d4c8a3 svg2lvl-0.4.0.tar.gz 48766
+RMD160 84244cd82fc1ba0737207dfd64fd865dd9fcf032 svg2lvl-0.4.0.tar.gz 48766
+SHA256 ffda6cf46ba2fb2a280c1229bbc5b458b3ac72595cdfee0a269c0fcd099a9f13 svg2lvl-0.4.0.tar.gz 48766
+MD5 cd2041652586119f68655c789c0ce7b3 xmoto-0.3.4-src.tar.gz 17017466
+RMD160 d0433acc49480980f6505b795c3f3a547cdce14c xmoto-0.3.4-src.tar.gz 17017466
+SHA256 79d80562e051cce58da357d9d31308aeda8bffb668c8d3ff49fe4d27e3c9b243 xmoto-0.3.4-src.tar.gz 17017466
diff --git a/games-sports/xmoto/xmoto-0.3.4.ebuild b/games-sports/xmoto/xmoto-0.3.4.ebuild
new file mode 100644
index 000000000000..cc49b8b9b0f2
--- /dev/null
+++ b/games-sports/xmoto/xmoto-0.3.4.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-sports/xmoto/xmoto-0.3.4.ebuild,v 1.1 2007/10/21 21:30:42 genstef Exp $
+
+inherit eutils games
+
+LVL="svg2lvl-0.4.0"
+DESCRIPTION="A challenging 2D motocross platform game"
+HOMEPAGE="http://xmoto.tuxfamily.org"
+SRC_URI="http://download.tuxfamily.org/${PN}/${PN}/${PV}/${P}-src.tar.gz
+ editor? ( http://download.tuxfamily.org/xmoto/svg2lvl/${LVL/*-}/${LVL}.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls editor"
+
+RDEPEND="media-libs/jpeg
+ media-libs/libpng
+ media-libs/libsdl
+ media-libs/sdl-mixer
+ media-libs/sdl-ttf
+ net-misc/curl
+ dev-lang/lua
+ dev-games/ode
+ virtual/opengl
+ virtual/glu
+ nls? ( virtual/libintl )
+ editor? ( >=media-gfx/inkscape-0.45 )"
+DEPEND="${RDEPEND}
+ >=dev-db/sqlite-3
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i 's:$(localedir):/usr/share/locale:' po/Makefile.in.in \
+ || die "sed Makefile.in.in failed"
+ use editor && rm -f "${WORKDIR}"/${LVL}/{bezmisc,inkex}.py
+}
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --with-enable-zoom=1 \
+ --with-localesdir=/usr/share/locale \
+ $(use_enable nls) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc README TODO ChangeLog
+
+ doicon extra/xmoto.xpm
+ domenu extra/xmoto.desktop
+
+ prepgamesdirs
+
+ if use editor; then
+ insinto /usr/share/inkscape/extensions
+ doins "${WORKDIR}"/${LVL}/*.{inx,py,xml} || die "doins failed"
+ fi
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ if use editor; then
+ elog "If you want to know how to create Xmoto levels"
+ elog "have a look at this Tutorial:"
+ elog "http://wiki.xmoto.free.fr/index.php?title=Inkscape-0.3.0#Tutorial"
+ elog "You can share your levels on the Xmoto homepage."
+ fi
+}