summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-05-04 23:19:02 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-05-04 23:19:02 +0000
commit64eb4cdee99709c4ab2ed2ba07e297a1a6c308b7 (patch)
tree68498d6d72708f8abeec24dc3c89996a7dc58824 /games-sports/trophy
parentVersion bump (diff)
downloadgentoo-2-64eb4cdee99709c4ab2ed2ba07e297a1a6c308b7.tar.gz
gentoo-2-64eb4cdee99709c4ab2ed2ba07e297a1a6c308b7.tar.bz2
gentoo-2-64eb4cdee99709c4ab2ed2ba07e297a1a6c308b7.zip
add patch for --as-needed support submitted by Kacper Kowalik (Xarthisius) via bug #318139
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-sports/trophy')
-rw-r--r--games-sports/trophy/ChangeLog9
-rw-r--r--games-sports/trophy/files/trophy-1.1.5-asneeded.patch25
-rw-r--r--games-sports/trophy/trophy-1.1.5.ebuild13
3 files changed, 42 insertions, 5 deletions
diff --git a/games-sports/trophy/ChangeLog b/games-sports/trophy/ChangeLog
index 10cea9372972..4213fdef3830 100644
--- a/games-sports/trophy/ChangeLog
+++ b/games-sports/trophy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-sports/trophy
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/trophy/ChangeLog,v 1.8 2009/01/05 01:26:13 mr_bones_ Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-sports/trophy/ChangeLog,v 1.9 2010/05/04 23:19:01 mr_bones_ Exp $
+
+ 04 May 2010; Michael Sterrett <mr_bones_@gentoo.org> trophy-1.1.5.ebuild,
+ +files/trophy-1.1.5-asneeded.patch:
+ add patch for --as-needed support submitted by Kacper Kowalik (Xarthisius)
+ via bug #318139
05 Jan 2009; Michael Sterrett <mr_bones_@gentoo.org> trophy-1.1.5.ebuild:
add use-based dep for dev-games/clanlib (bug #247476)
diff --git a/games-sports/trophy/files/trophy-1.1.5-asneeded.patch b/games-sports/trophy/files/trophy-1.1.5-asneeded.patch
new file mode 100644
index 000000000000..2bd7e5f669f6
--- /dev/null
+++ b/games-sports/trophy/files/trophy-1.1.5-asneeded.patch
@@ -0,0 +1,25 @@
+Fixing as-needed issues
+
+http://bugs.gentoo.org/show_bug.cgi?id=318139
+
+--- configure.ac
++++ configure.ac
+@@ -15,5 +15,6 @@
+ # We try to link to clanSignals because this is the only library file that
+ # doesn't need another one to be linked with.
+ AC_CHECK_LIB(clanSignals, main, , echo "Trophy requires ClanLib to run."; exit 1)
++PKG_CHECK_MODULES([CLAN], [clanSignals-0.8 clanGL-0.8 clanCore-0.8 clanSound-0.8 clanDisplay-0.8 clanApp-0.8])
+
+ AC_OUTPUT(Makefile src/Makefile resources/Makefile)
+--- src/Makefile.am
++++ src/Makefile.am
+@@ -12,7 +12,6 @@
+ caslotselectiondialog.cpp cafogbomb.h caimageview.h camenu.cpp canetclient.h capositiontable.cpp \
+ caslotselectiondialog.h
+
+-CLANLIB_MODULES = clanSignals-0.8 clanGL-0.8 clanCore-0.8 clanSound-0.8 clanDisplay-0.8 clanApp-0.8
+-AM_LDFLAGS = `pkg-config --libs $(CLANLIB_MODULES)`
+-INCLUDES = `pkg-config --cflags $(CLANLIB_MODULES)`
+ AM_CPPFLAGS = -DPKGDATADIR=\"$(pkgdatadir)\"
++trophy_CXXFLAGS = @CLAN_CFLAGS@
++trophy_LDADD = @CLAN_LIBS@
diff --git a/games-sports/trophy/trophy-1.1.5.ebuild b/games-sports/trophy/trophy-1.1.5.ebuild
index b6c82cbc99a6..2357a109efa5 100644
--- a/games-sports/trophy/trophy-1.1.5.ebuild
+++ b/games-sports/trophy/trophy-1.1.5.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/trophy/trophy-1.1.5.ebuild,v 1.3 2009/01/05 01:26:13 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/trophy/trophy-1.1.5.ebuild,v 1.4 2010/05/04 23:19:01 mr_bones_ Exp $
EAPI=2
-inherit games
+inherit autotools eutils games
DESCRIPTION="2D Racing Game"
HOMEPAGE="http://trophy.sourceforge.net/"
@@ -20,6 +20,13 @@ DEPEND="${RDEPEND}
PATCHES=( "${FILESDIR}"/${P}-display-segv.patch )
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-display-segv.patch \
+ "${FILESDIR}"/${P}-asneeded.patch
+ eautoreconf
+}
+
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS ChangeLog README TODO