summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-06-24 17:46:35 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-06-24 17:46:35 +0000
commit699255f62e89367159d1673dd814fd60031d34f1 (patch)
tree4d67beed212612edda20e7d0a8f7726a083675e7 /games-simulation
parentStable on amd64 wrt bug #305031 (diff)
downloadgentoo-2-699255f62e89367159d1673dd814fd60031d34f1.tar.gz
gentoo-2-699255f62e89367159d1673dd814fd60031d34f1.tar.bz2
gentoo-2-699255f62e89367159d1673dd814fd60031d34f1.zip
Add libsdl use dep; honor CXX; allow parallel make
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/dangerdeep/ChangeLog6
-rw-r--r--games-simulation/dangerdeep/dangerdeep-0.3.0.ebuild6
-rw-r--r--games-simulation/dangerdeep/files/dangerdeep-0.3.0-build.patch4
3 files changed, 12 insertions, 4 deletions
diff --git a/games-simulation/dangerdeep/ChangeLog b/games-simulation/dangerdeep/ChangeLog
index f55993b5a810..7f0ef7ae59a0 100644
--- a/games-simulation/dangerdeep/ChangeLog
+++ b/games-simulation/dangerdeep/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-simulation/dangerdeep
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/dangerdeep/ChangeLog,v 1.11 2010/05/24 18:53:30 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/dangerdeep/ChangeLog,v 1.12 2010/06/24 17:46:35 mr_bones_ Exp $
+
+ 24 Jun 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ dangerdeep-0.3.0.ebuild, files/dangerdeep-0.3.0-build.patch:
+ Add libsdl use dep; honor CXX; allow parallel make
24 May 2010; Pacho Ramos <pacho@gentoo.org> dangerdeep-0.3.0.ebuild:
stable amd64, bug 317241
diff --git a/games-simulation/dangerdeep/dangerdeep-0.3.0.ebuild b/games-simulation/dangerdeep/dangerdeep-0.3.0.ebuild
index 47e26e7ade4c..c79c9881d005 100644
--- a/games-simulation/dangerdeep/dangerdeep-0.3.0.ebuild
+++ b/games-simulation/dangerdeep/dangerdeep-0.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/dangerdeep/dangerdeep-0.3.0.ebuild,v 1.7 2010/05/24 18:53:30 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/dangerdeep/dangerdeep-0.3.0.ebuild,v 1.8 2010/06/24 17:46:35 mr_bones_ Exp $
EAPI=2
inherit eutils games
@@ -18,7 +18,7 @@ IUSE="sse debug"
RDEPEND="virtual/opengl
virtual/glu
sci-libs/fftw:3.0
- media-libs/libsdl
+ media-libs/libsdl[video]
media-libs/sdl-mixer[vorbis]
media-libs/sdl-image[jpeg,png]
media-libs/sdl-net"
@@ -39,12 +39,14 @@ src_prepare() {
src_compile() {
local sse=-1
+ local sconsopts=$(echo "${MAKEOPTS}" | sed -ne "/-j/ { s/.*\(-j[:space:]*[0-9]\+\).*/\1/; p }")
if use sse ; then
use amd64 && sse=3 || sse=1
fi
scons \
+ ${sconsopts} \
usex86sse=${sse} \
datadir="${GAMES_DATADIR}"/${PN} \
$(use debug && echo debug=1) \
diff --git a/games-simulation/dangerdeep/files/dangerdeep-0.3.0-build.patch b/games-simulation/dangerdeep/files/dangerdeep-0.3.0-build.patch
index 1f3c4a47ce6d..367db1cfbb96 100644
--- a/games-simulation/dangerdeep/files/dangerdeep-0.3.0-build.patch
+++ b/games-simulation/dangerdeep/files/dangerdeep-0.3.0-build.patch
@@ -8,10 +8,12 @@
env = Environment(ENV = os.environ)
env.Append(CPPPATH = ['/usr/include/SDL', '/usr/include/GL'])
libpath = ['/usr/X11R6/lib']
-@@ -126,13 +127,16 @@
+@@ -126,13 +127,18 @@
sdllibs = ['SDL', 'SDL_image']
ccflags = '-Wall `sdl-config --cflags` `pkg-config --cflags x11`'
env.Append(LINKFLAGS = '`pkg-config --libs-only-L x11`')
++ if os.environ.has_key('CXX'):
++ env['CXX'] = os.environ['CXX']
+ if os.environ.has_key('CXXFLAGS'):
+ ccflags += os.environ['CXXFLAGS']
+ if os.environ.has_key('LDFLAGS'):