summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2014-10-30 15:31:43 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2014-10-30 15:31:43 +0000
commit1e0987aee4477dded78051ea25d301f7b6844303 (patch)
treec376c39d5dd9470e25a692b6ace2159943009501 /games-simulation/senken
parentUpdate HOMEPAGE/SRC_URI. (diff)
downloadgentoo-2-1e0987aee4477dded78051ea25d301f7b6844303.tar.gz
gentoo-2-1e0987aee4477dded78051ea25d301f7b6844303.tar.bz2
gentoo-2-1e0987aee4477dded78051ea25d301f7b6844303.zip
EAPI=5; tidy; fix underlinking again (bug #527462)
(Portage version: 2.2.8-r2/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-simulation/senken')
-rw-r--r--games-simulation/senken/ChangeLog9
-rw-r--r--games-simulation/senken/files/senken-0.3.0-as-needed.patch17
-rw-r--r--games-simulation/senken/files/senken-0.3.0-warnings.patch31
-rw-r--r--games-simulation/senken/senken-0.3.0.ebuild29
4 files changed, 67 insertions, 19 deletions
diff --git a/games-simulation/senken/ChangeLog b/games-simulation/senken/ChangeLog
index 6a9db83279d4..9c8044ec0065 100644
--- a/games-simulation/senken/ChangeLog
+++ b/games-simulation/senken/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-simulation/senken
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/senken/ChangeLog,v 1.10 2009/02/11 13:05:34 tupone Exp $
+# Copyright 2000-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/senken/ChangeLog,v 1.11 2014/10/30 15:31:43 mr_bones_ Exp $
+
+ 30 Oct 2014; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/senken-0.3.0-warnings.patch, files/senken-0.3.0-as-needed.patch,
+ senken-0.3.0.ebuild:
+ EAPI=5; tidy; fix underlinking again (bug #527462)
11 Feb 2009; Alfredo Tupone <tupone@gentoo.org>
+files/senken-0.3.0-as-needed.patch, senken-0.3.0.ebuild:
diff --git a/games-simulation/senken/files/senken-0.3.0-as-needed.patch b/games-simulation/senken/files/senken-0.3.0-as-needed.patch
index 6cb3417ce8a6..428cbc9ee4c6 100644
--- a/games-simulation/senken/files/senken-0.3.0-as-needed.patch
+++ b/games-simulation/senken/files/senken-0.3.0-as-needed.patch
@@ -1,5 +1,6 @@
---- server/Makefile.in.old 2009-02-11 12:45:10.000000000 +0100
-+++ server/Makefile.in 2009-02-11 12:45:18.000000000 +0100
+diff -ru senken-0.3.0.orig/server/Makefile.in senken-0.3.0/server/Makefile.in
+--- senken-0.3.0.orig/server/Makefile.in 2003-11-20 02:30:15.000000000 -0500
++++ senken-0.3.0/server/Makefile.in 2014-10-30 10:58:51.202157036 -0400
@@ -10,7 +10,7 @@
DEFS = @DEFS@
@@ -9,3 +10,15 @@
prefix = @prefix@
exec_prefix = @exec_prefix@
+diff -ru senken-0.3.0.orig/src/Makefile.in senken-0.3.0/src/Makefile.in
+--- senken-0.3.0.orig/src/Makefile.in 2003-11-20 02:30:16.000000000 -0500
++++ senken-0.3.0/src/Makefile.in 2014-10-30 10:59:05.154704393 -0400
+@@ -8,7 +8,7 @@
+
+ DEFS = @DEFS@
+ CPPFLAGS = -I$(srcdir)/../lib -I$(srcdir) -I$(srcdir)/.. @CPPFLAGS@ @GTK_CFLAGS@
+-LIBS = ../lib/libsenken.a @LIBS@ @GTK_LIBS@
++LIBS = ../lib/libsenken.a @LIBS@ @GTK_LIBS@ -lm
+
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
diff --git a/games-simulation/senken/files/senken-0.3.0-warnings.patch b/games-simulation/senken/files/senken-0.3.0-warnings.patch
new file mode 100644
index 000000000000..b15565ad0a90
--- /dev/null
+++ b/games-simulation/senken/files/senken-0.3.0-warnings.patch
@@ -0,0 +1,31 @@
+diff -ru senken-0.3.0.orig/server/protocol.c senken-0.3.0/server/protocol.c
+--- senken-0.3.0.orig/server/protocol.c 2003-11-20 02:30:15.000000000 -0500
++++ senken-0.3.0/server/protocol.c 2014-10-30 11:04:39.831848871 -0400
+@@ -294,7 +294,7 @@
+ /*
+ * If transaction active just save this for later
+ */
+- if (connection_txn_active) {
++ if (connection_txn_active(conn)) {
+ set_op_t *op = calloc(1, sizeof(set_op_t));
+ int r;
+
+diff -ru senken-0.3.0.orig/src/gtkhelp_reports.c senken-0.3.0/src/gtkhelp_reports.c
+--- senken-0.3.0.orig/src/gtkhelp_reports.c 2003-11-20 02:30:16.000000000 -0500
++++ senken-0.3.0/src/gtkhelp_reports.c 2014-10-30 11:06:43.795828908 -0400
+@@ -1,3 +1,4 @@
++#include <string.h>
+ #include <gtk/gtk.h>
+ #include <gdk/gdk.h>
+
+diff -ru senken-0.3.0.orig/src/main.c senken-0.3.0/src/main.c
+--- senken-0.3.0.orig/src/main.c 2003-11-20 02:30:16.000000000 -0500
++++ senken-0.3.0/src/main.c 2014-10-30 11:06:28.147336339 -0400
+@@ -25,6 +25,7 @@
+ # include <config.h>
+ #endif
+
++#include <string.h>
+ #include <unistd.h>
+ #include <signal.h>
+ #include <gtk/gtk.h>
diff --git a/games-simulation/senken/senken-0.3.0.ebuild b/games-simulation/senken/senken-0.3.0.ebuild
index 4b019cfe961d..e1f67ed24c4a 100644
--- a/games-simulation/senken/senken-0.3.0.ebuild
+++ b/games-simulation/senken/senken-0.3.0.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/senken/senken-0.3.0.ebuild,v 1.10 2011/03/01 07:20:13 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/senken/senken-0.3.0.ebuild,v 1.11 2014/10/30 15:31:43 mr_bones_ Exp $
-EAPI=2
+EAPI=5
inherit eutils games
DESCRIPTION="city simulation game"
HOMEPAGE="http://www.contrib.andrew.cmu.edu/~tmartin/senken/"
-SRC_URI="http://www.contrib.andrew.cmu.edu/~tmartin/senken/download/${P}.tar.gz"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -24,28 +24,27 @@ DEPEND="${RDEPEND}
src_prepare() {
sed -i \
-e "s:/usr/local/share:${GAMES_DATADIR}:" \
- lib/utils.h \
- || die "sed lib/utils.h failed"
- epatch "${FILESDIR}"/${P}-as-needed.patch
+ lib/utils.h || die
+ epatch \
+ "${FILESDIR}"/${P}-as-needed.patch \
+ "${FILESDIR}"/${P}-warnings.patch
}
src_configure() {
- egamesconf $(use_enable nls) || die
+ egamesconf $(use_enable nls)
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS README TODO
+ default
dodir "${GAMES_DATADIR}"
- mv "${D}/${GAMES_PREFIX}/share/senken" "${D}/${GAMES_DATADIR}/" \
- || die "mv failed"
- rm -rf "${D}/${GAMES_PREFIX}"/{include,lib,man,share}
+ mv "${D}/${GAMES_PREFIX}/share/senken" "${D}/${GAMES_DATADIR}/" || die
+ rm -rf "${D}/${GAMES_PREFIX}"/{include,lib,man,share} || die
insinto "${GAMES_DATADIR}/senken/img"
doins img/*.png
- find "${D}/${GAMES_DATADIR}/" -type f -exec chmod a-x \{\} \;
- find "${D}/${GAMES_DATADIR}/" -name "Makefile.*" -exec rm -f \{\} \;
+ find "${D}/${GAMES_DATADIR}/" -type f -exec chmod a-x \{\} +
+ find "${D}/${GAMES_DATADIR}/" -name "Makefile.*" -exec rm -f \{\} +
prepgamesdirs
}