summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2009-10-28 15:28:05 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2009-10-28 15:28:05 +0000
commit7ff1f93d94853a2a124e6b5bd44ec367caff881a (patch)
tree0889155cf0146344914df06c9380fa012bdc90b4 /games-simulation/fgrun
parentVersion bump. (diff)
downloadgentoo-2-7ff1f93d94853a2a124e6b5bd44ec367caff881a.tar.gz
gentoo-2-7ff1f93d94853a2a124e6b5bd44ec367caff881a.tar.bz2
gentoo-2-7ff1f93d94853a2a124e6b5bd44ec367caff881a.zip
Version bump, closes bug #255094
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'games-simulation/fgrun')
-rw-r--r--games-simulation/fgrun/ChangeLog8
-rw-r--r--games-simulation/fgrun/fgrun-1.5.1.ebuild43
-rw-r--r--games-simulation/fgrun/files/fgrun-1.5.1-fltk.patch13
3 files changed, 63 insertions, 1 deletions
diff --git a/games-simulation/fgrun/ChangeLog b/games-simulation/fgrun/ChangeLog
index 239b0076962e..de061bf5654c 100644
--- a/games-simulation/fgrun/ChangeLog
+++ b/games-simulation/fgrun/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-simulation/fgrun
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/fgrun/ChangeLog,v 1.7 2009/10/17 17:34:40 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/fgrun/ChangeLog,v 1.8 2009/10/28 15:28:05 voyageur Exp $
+
+*fgrun-1.5.1 (28 Oct 2009)
+
+ 28 Oct 2009; Bernard Cafarelli <voyageur@gentoo.org> +fgrun-1.5.1.ebuild,
+ +files/fgrun-1.5.1-fltk.patch:
+ Version bump, closes bug #255094
17 Oct 2009; Tupone Alfredo <tupone@gentoo.org> fgrun-1.0.0.ebuild:
Fix typo on src_configure. Bug #258405 by Steven Parker
diff --git a/games-simulation/fgrun/fgrun-1.5.1.ebuild b/games-simulation/fgrun/fgrun-1.5.1.ebuild
new file mode 100644
index 000000000000..24f7f1e5c167
--- /dev/null
+++ b/games-simulation/fgrun/fgrun-1.5.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/fgrun/fgrun-1.5.1.ebuild,v 1.1 2009/10/28 15:28:05 voyageur Exp $
+
+EAPI=2
+inherit autotools eutils multilib games
+
+DESCRIPTION="A graphical frontend for the FlightGear Flight Simulator"
+HOMEPAGE="http://sourceforge.net/projects/fgrun"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-games/simgear
+ || (
+ <x11-libs/fltk-1.1.9:1.1[opengl]
+ >=x11-libs/fltk-1.1.9:1.1[opengl,threads]
+ )
+ x11-libs/libXi
+ x11-libs/libXmu"
+RDEPEND="${DEPEND}
+ >=games-simulation/flightgear-1.9.0"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}"-fltk.patch
+ AT_M4DIR=. eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --with-plib-libraries=/usr/$(get_libdir) \
+ --with-plib-includes=/usr/include \
+ || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS NEWS
+ prepgamesdirs
+}
diff --git a/games-simulation/fgrun/files/fgrun-1.5.1-fltk.patch b/games-simulation/fgrun/files/fgrun-1.5.1-fltk.patch
new file mode 100644
index 000000000000..dc00c9a6cfd5
--- /dev/null
+++ b/games-simulation/fgrun/files/fgrun-1.5.1-fltk.patch
@@ -0,0 +1,13 @@
+--- configure.ac.old 2007-04-25 22:26:19.000000000 +0200
++++ configure.ac 2007-04-25 22:27:41.000000000 +0200
+***************
+*** 138,143 ****
+--- 138,146 ----
+ FLUID="$with_fltk/bin/fluid"
+ CPPFLAGS="-I$with_fltk/include $CPPFLAGS"
+ EXTRA_DIRS="${EXTRA_DIRS} $with_fltk"
++ else
++ CPPFLAGS="$(fltk-config --cxxflags) $CPPFLAGS"
++ LDFLAGS="$(fltk-config --ldflags) $LDFLAGS"
+ fi
+ AC_SUBST(FLUID)