summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-01-16 20:33:23 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-01-16 20:33:23 +0000
commite8f0d5e02d1f1bb5a96db9cd2be165098c5f110c (patch)
tree28588663a687f4263a92d8351cf4f44dadcdd3e1 /games-rpg
parentBump to 3.5.6 (prerelease). (diff)
downloadgentoo-2-e8f0d5e02d1f1bb5a96db9cd2be165098c5f110c.tar.gz
gentoo-2-e8f0d5e02d1f1bb5a96db9cd2be165098c5f110c.tar.bz2
gentoo-2-e8f0d5e02d1f1bb5a96db9cd2be165098c5f110c.zip
version bump
(Portage version: 2.1.1-r2)
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/tmw/ChangeLog9
-rw-r--r--games-rpg/tmw/files/digest-tmw-0.0.22.16
-rw-r--r--games-rpg/tmw/tmw-0.0.22.1.ebuild58
3 files changed, 71 insertions, 2 deletions
diff --git a/games-rpg/tmw/ChangeLog b/games-rpg/tmw/ChangeLog
index fc0ff8510fd4..844382514922 100644
--- a/games-rpg/tmw/ChangeLog
+++ b/games-rpg/tmw/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-rpg/tmw
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/tmw/ChangeLog,v 1.21 2006/12/29 04:57:34 mr_bones_ Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/tmw/ChangeLog,v 1.22 2007/01/16 20:33:22 mr_bones_ Exp $
+
+*tmw-0.0.22.1 (16 Jan 2007)
+
+ 16 Jan 2007; Michael Sterrett <mr_bones_@gentoo.org> +tmw-0.0.22.1.ebuild:
+ version bump
29 Dec 2006; Michael Sterrett <mr_bones_@gentoo.org> tmw-0.0.22.ebuild:
add vorbis use flag check and updated music file (reported by Wai Ling in bug
diff --git a/games-rpg/tmw/files/digest-tmw-0.0.22.1 b/games-rpg/tmw/files/digest-tmw-0.0.22.1
new file mode 100644
index 000000000000..ace8ee8fdf3b
--- /dev/null
+++ b/games-rpg/tmw/files/digest-tmw-0.0.22.1
@@ -0,0 +1,6 @@
+MD5 0ebcd26b40eddd1e5acf4b59009a604b tmw-0.0.22.1.tar.gz 3563351
+RMD160 ff971d53bf6b9069c5f0b50a7f9cbd5d6d1c576e tmw-0.0.22.1.tar.gz 3563351
+SHA256 ecf1f85738187dfb191572af0978467bf7d1f311fcec9eb4b0b98fee740d3604 tmw-0.0.22.1.tar.gz 3563351
+MD5 eec5e7d6c8ddb8938209815dbf5da812 tmwmusic-0.0.20.tar.gz 9259802
+RMD160 a7212f90b40f864d0670905fe037564eba48ab30 tmwmusic-0.0.20.tar.gz 9259802
+SHA256 964bb27235cdc3199c392f6ddf25ce293c6f32e013abe85592b96221a5896939 tmwmusic-0.0.20.tar.gz 9259802
diff --git a/games-rpg/tmw/tmw-0.0.22.1.ebuild b/games-rpg/tmw/tmw-0.0.22.1.ebuild
new file mode 100644
index 000000000000..991007abc09e
--- /dev/null
+++ b/games-rpg/tmw/tmw-0.0.22.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/tmw/tmw-0.0.22.1.ebuild,v 1.1 2007/01/16 20:33:22 mr_bones_ Exp $
+
+inherit eutils games
+
+MUSIC=tmwmusic-0.0.20
+DESCRIPTION="A fully free and open source MMORPG game with the looks of \"old-fashioned\" 2D RPG"
+HOMEPAGE="http://themanaworld.org/"
+SRC_URI="mirror://sourceforge/themanaworld/${P}.tar.gz
+ mirror://sourceforge/themanaworld/${MUSIC}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="opengl"
+
+DEPEND=">=dev-games/physfs-1.0.0
+ opengl? ( virtual/opengl )
+ dev-libs/libxml2
+ media-libs/sdl-mixer
+ media-libs/sdl-image
+ media-libs/sdl-net
+ net-misc/curl
+ >=dev-games/guichan-0.6.0"
+
+pkg_setup() {
+ games_pkg_setup
+ if ! built_with_use dev-games/guichan sdl ; then
+ eerror "dev-games/guichan needs to be built with USE=sdl"
+ die "please re-emerge dev-games/guichan with USE=sdl"
+ fi
+ if ! built_with_use media-libs/sdl-mixer vorbis ; then
+ eerror "media-libs/sdl-mixer needs to be built with USE=vorbis"
+ die "please re-emerge media-libs/sdl-mixer with USE=vorbis"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.0.12-desktop.patch
+}
+
+src_compile() {
+ egamesconf $(use_with opengl) || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README
+ cd ${WORKDIR}
+ insinto "${GAMES_DATADIR}"/${PN}/data/music
+ doins ${MUSIC}/data/music/*.ogg || die
+ newdoc ${MUSIC}/README README.music
+ prepgamesdirs
+}