summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2009-05-27 12:07:55 +0000
committerTristan Heaven <nyhm@gentoo.org>2009-05-27 12:07:55 +0000
commita8a7934ac7bf81a1e62836c60294babceb0daf0e (patch)
tree1e3cc61cca9e3d0014051db0b721b73b047b8d7c /games-rpg
parentFix. Correct bug number is 257714. (diff)
downloadgentoo-2-a8a7934ac7bf81a1e62836c60294babceb0daf0e.tar.gz
gentoo-2-a8a7934ac7bf81a1e62836c60294babceb0daf0e.tar.bz2
gentoo-2-a8a7934ac7bf81a1e62836c60294babceb0daf0e.zip
Use system lua and sdl-gfx instead of the bundled versions, bug #252469
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/freedroidrpg/ChangeLog8
-rw-r--r--games-rpg/freedroidrpg/files/freedroidrpg-0.12.1-syslibs.patch99
-rw-r--r--games-rpg/freedroidrpg/freedroidrpg-0.12.1-r1.ebuild55
3 files changed, 161 insertions, 1 deletions
diff --git a/games-rpg/freedroidrpg/ChangeLog b/games-rpg/freedroidrpg/ChangeLog
index 04d358b75284..026318f54127 100644
--- a/games-rpg/freedroidrpg/ChangeLog
+++ b/games-rpg/freedroidrpg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-rpg/freedroidrpg
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/freedroidrpg/ChangeLog,v 1.19 2009/04/24 23:29:10 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/freedroidrpg/ChangeLog,v 1.20 2009/05/27 12:07:55 nyhm Exp $
+
+*freedroidrpg-0.12.1-r1 (27 May 2009)
+
+ 27 May 2009; Tristan Heaven <nyhm@gentoo.org>
+ +freedroidrpg-0.12.1-r1.ebuild, +files/freedroidrpg-0.12.1-syslibs.patch:
+ Use system lua and sdl-gfx instead of the bundled versions, bug #252469
*freedroidrpg-0.12.1 (24 Apr 2009)
diff --git a/games-rpg/freedroidrpg/files/freedroidrpg-0.12.1-syslibs.patch b/games-rpg/freedroidrpg/files/freedroidrpg-0.12.1-syslibs.patch
new file mode 100644
index 000000000000..4bd8e8c049e9
--- /dev/null
+++ b/games-rpg/freedroidrpg/files/freedroidrpg-0.12.1-syslibs.patch
@@ -0,0 +1,99 @@
+--- configure.ac
++++ configure.ac
+@@ -111,6 +111,14 @@
+ AC_MSG_ERROR([SDL_image library needed for FreedroidRPG!
+ see http://www.libsdl.org/]))
+
++AC_CHECK_LIB([SDL_gfx], [rotozoomSurface],,
++ AC_MSG_ERROR([SDL_gfx library needed to run FreedroidRPG
++see http://www.ferzkopp.net/Software/SDL_gfx-2.0/]))
++
++AC_CHECK_LIB([lua], [luaL_openlibs],,
++ AC_MSG_ERROR([lua library needed to run FreedroidRPG
++see http://www.lua.org/]))
++
+ AC_MSG_NOTICE([[Checking for optional SDL libraries:]])
+ AC_CHECK_LIB([SDL_mixer], [Mix_ChannelFinished],, AC_MSG_WARN([
+ --------------------------------------------------
+--- src/lua.c
++++ src/lua.c
+@@ -37,9 +37,9 @@
+ #include "lvledit/lvledit_actions.h"
+ #include "lvledit/lvledit_map.h"
+
+-#include "../lua/lua.h"
+-#include "../lua/lauxlib.h"
+-#include "../lua/lualib.h"
++#include <lua.h>
++#include <lauxlib.h>
++#include <lualib.h>
+
+
+ /* Our Lua state for event execution */
+--- src/Makefile.am
++++ src/Makefile.am
+@@ -1,9 +1,7 @@
+ ## Process this file with automake to produce Makefile.in
+
+-freedroidRPG_LDADD = ../lua/liblua.a
+-
+ if WIN32
+-freedroidRPG_LDADD += ../win32/freedroidRPG.coff
++freedroidRPG_LDADD = ../win32/freedroidRPG.coff
+ endif
+
+ bin_PROGRAMS = freedroidRPG
+@@ -18,7 +16,7 @@
+ enemy.c input.c keyboard.c main.c hud.c view.c automap.c BFont.c \
+ defs.h map.h vars.h takeover.h global.h \
+ proto.h struct.h system.h BFont.h \
+- SDL_rotozoom.c SDL_rotozoom.h open_gl.c open_gl_atlas.c mission.c chat.c light.c \
++ open_gl.c open_gl_atlas.c mission.c chat.c light.c \
+ getopt.c getopt1.c getopt.h scandir.c scandir.h sound.h sound_effects.c \
+ lang.h lists.c lists.h gen_savestruct.py savestruct.c savestruct.h pathfinder.c \
+ lvledit/lvledit.c lvledit/lvledit.h \
+@@ -41,13 +39,4 @@
+ lvledit/lvledit_widgets.c lvledit/lvledit_widgets.h
+
+ savestruct.c savestruct.h: struct.h
+- python2.5 gen_savestruct.py struct.h savestruct
+-
+-clean-local:
+- cd ../lua; make clean
+-
+-../lua/liblua.a:
+- cd ../lua; make CC=${CC} AR="${AR} rcu" liblua.a
+-if WIN32
+- i686-pc-mingw32-ranlib ../lua/liblua.a
+-endif
++ python gen_savestruct.py struct.h savestruct
+--- src/struct.h
++++ src/struct.h
+@@ -30,16 +30,7 @@
+ #include "system.h"
+ #include "defs.h"
+
+-typedef struct tColorRGBA {
+- Uint8 r;
+- Uint8 g;
+- Uint8 b;
+- Uint8 a;
+-} tColorRGBA, myColor;
+-
+-typedef struct tColorY {
+- Uint8 y;
+-} tColorY;
++typedef tColorRGBA myColor;
+
+ /**
+ * Simple doubly linked list implementation.
+--- src/system.h
++++ src/system.h
+@@ -112,6 +112,7 @@
+
+ #include "SDL.h"
+ #include "SDL_image.h"
++#include "SDL_rotozoom.h"
+
+ #ifdef HAVE_LIBSDL_MIXER
+ #include "SDL_mixer.h"
diff --git a/games-rpg/freedroidrpg/freedroidrpg-0.12.1-r1.ebuild b/games-rpg/freedroidrpg/freedroidrpg-0.12.1-r1.ebuild
new file mode 100644
index 000000000000..3840be6f2836
--- /dev/null
+++ b/games-rpg/freedroidrpg/freedroidrpg-0.12.1-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/freedroidrpg/freedroidrpg-0.12.1-r1.ebuild,v 1.1 2009/05/27 12:07:55 nyhm Exp $
+
+EAPI=2
+inherit autotools eutils games
+
+DESCRIPTION="A modification of the classical Freedroid engine into an RPG"
+HOMEPAGE="http://freedroid.sourceforge.net/"
+SRC_URI="mirror://sourceforge/freedroid/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="opengl"
+
+RDEPEND="media-libs/libsdl
+ dev-lang/lua
+ media-libs/jpeg
+ media-libs/libpng
+ media-libs/sdl-image[jpeg,png]
+ media-libs/sdl-net
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-gfx
+ media-libs/libogg
+ media-libs/libvorbis
+ x11-libs/libX11
+ opengl? ( virtual/opengl )"
+DEPEND="${RDEPEND}
+ x11-libs/libXt
+ dev-lang/python"
+
+src_prepare() {
+ rm -rf lua src/SDL_rotozoom*
+ epatch "${FILESDIR}"/${P}-syslibs.patch
+
+ # No need for executable game resources
+ find sound graphics -type f -exec chmod -c a-x '{}' +
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --disable-fastmath \
+ $(use_enable opengl)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ rm -f "${D}/${GAMES_BINDIR}/"{croppy,pngtoico,gluem}
+ newicon win32/w32icon2_64x64.png ${PN}.png
+ make_desktop_entry freedroidRPG "Freedroid RPG"
+ prepgamesdirs
+}