summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-12-29 04:57:34 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-12-29 04:57:34 +0000
commit5f33c2be5001704ec02f2a0f2d42b7070e148ead (patch)
treef4787ff8f60558433d1da667f06a57f5d448a675 /games-rpg
parent2.1.2_rc4-r2 revbump. This fixes bugs #148603, #158931, #158983, #159161, #1... (diff)
downloadgentoo-2-5f33c2be5001704ec02f2a0f2d42b7070e148ead.tar.gz
gentoo-2-5f33c2be5001704ec02f2a0f2d42b7070e148ead.tar.bz2
gentoo-2-5f33c2be5001704ec02f2a0f2d42b7070e148ead.zip
add vorbis use flag check and updated music file (reported by Wai Ling in bug
(Portage version: 2.1.1-r2)
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/tmw/ChangeLog6
-rw-r--r--games-rpg/tmw/files/digest-tmw-0.0.226
-rw-r--r--games-rpg/tmw/tmw-0.0.22.ebuild23
3 files changed, 22 insertions, 13 deletions
diff --git a/games-rpg/tmw/ChangeLog b/games-rpg/tmw/ChangeLog
index ae7e279e8f18..fc0ff8510fd4 100644
--- a/games-rpg/tmw/ChangeLog
+++ b/games-rpg/tmw/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-rpg/tmw
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/tmw/ChangeLog,v 1.20 2006/12/28 22:46:59 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/tmw/ChangeLog,v 1.21 2006/12/29 04:57:34 mr_bones_ Exp $
+
+ 29 Dec 2006; Michael Sterrett <mr_bones_@gentoo.org> tmw-0.0.22.ebuild:
+ add vorbis use flag check and updated music file (reported by Wai Ling in bug
+ #154570)
*tmw-0.0.22 (28 Dec 2006)
diff --git a/games-rpg/tmw/files/digest-tmw-0.0.22 b/games-rpg/tmw/files/digest-tmw-0.0.22
index cec85161aa7e..2bf647781aea 100644
--- a/games-rpg/tmw/files/digest-tmw-0.0.22
+++ b/games-rpg/tmw/files/digest-tmw-0.0.22
@@ -1,6 +1,6 @@
MD5 f2028ac0aa4ebd325ddef119ba7f1051 tmw-0.0.22.tar.gz 3571205
RMD160 e6f583491a5f15458ac03b95367da10a342f33fa tmw-0.0.22.tar.gz 3571205
SHA256 3af8ce85f11f192077143b82c3e5f71bfe34834b18033637746cfed08c89cb7b tmw-0.0.22.tar.gz 3571205
-MD5 54ccc5d114eeb70d2bcb866e1e686c25 tmw-Magick-Real.ogg 840811
-RMD160 d293aff31cc3f2b57bbb9a91c7b444c4fda5c375 tmw-Magick-Real.ogg 840811
-SHA256 9cd8ffc59689fadb35884309cab14cc1c23ed1061fadec26b875688d2bbff13b tmw-Magick-Real.ogg 840811
+MD5 eec5e7d6c8ddb8938209815dbf5da812 tmwmusic-0.0.20.tar.gz 9259802
+RMD160 a7212f90b40f864d0670905fe037564eba48ab30 tmwmusic-0.0.20.tar.gz 9259802
+SHA256 964bb27235cdc3199c392f6ddf25ce293c6f32e013abe85592b96221a5896939 tmwmusic-0.0.20.tar.gz 9259802
diff --git a/games-rpg/tmw/tmw-0.0.22.ebuild b/games-rpg/tmw/tmw-0.0.22.ebuild
index a18d7cc24524..8e029f0f835f 100644
--- a/games-rpg/tmw/tmw-0.0.22.ebuild
+++ b/games-rpg/tmw/tmw-0.0.22.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/tmw/tmw-0.0.22.ebuild,v 1.1 2006/12/28 22:46:59 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/tmw/tmw-0.0.22.ebuild,v 1.2 2006/12/29 04:57:34 mr_bones_ Exp $
inherit eutils games
+MUSIC=tmwmusic-0.0.20
DESCRIPTION="A fully free and open source MMORPG game with the looks of \"old-fashioned\" 2D RPG"
HOMEPAGE="http://themanaworld.org/"
SRC_URI="mirror://sourceforge/themanaworld/${P}.tar.gz
- mirror://gentoo/tmw-Magick-Real.ogg"
-# http://riekale.com/~rotonen/tmw/data/music/Magick%20-%20Real.ogg"
+ mirror://sourceforge/themanaworld/${MUSIC}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -28,13 +28,16 @@ pkg_setup() {
games_pkg_setup
if ! built_with_use dev-games/guichan sdl ; then
eerror "dev-games/guichan needs to be built with USE=sdl"
- die "please re-emerge guichan with USE=sdl"
+ die "please re-emerge dev-games/guichan with USE=sdl"
+ fi
+ if ! built_with_use media-libs/sdl-mixer vorbis ; then
+ eerror "media-libs/sdl-mixer needs to be built with USE=vorbis"
+ die "please re-emerge media-libs/sdl-mixer with USE=vorbis"
fi
}
src_unpack() {
- unpack ${P}.tar.gz
- cp "${DISTDIR}"/tmw-Magick-Real.ogg . || die
+ unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${PN}-0.0.12-desktop.patch
}
@@ -45,9 +48,11 @@ src_compile() {
}
src_install() {
- make DESTDIR="${D}" install || die "install failed"
- insinto "${GAMES_DATADIR}"/${PN}/data/music
- newins "${WORKDIR}"/tmw-Magick-Real.ogg "Magick - Real.ogg" || die
+ emake DESTDIR="${D}" install || die "make install failed"
dodoc AUTHORS ChangeLog NEWS README
+ cd ${WORKDIR}
+ insinto "${GAMES_DATADIR}"/${PN}/data/music
+ doins ${MUSIC}/data/music/*.ogg || die
+ newdoc ${MUSIC}/README README.music
prepgamesdirs
}