summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-10-14 00:14:22 +0000
committerMike Frysinger <vapier@gentoo.org>2003-10-14 00:14:22 +0000
commit157ecf53c46f056a7531b4704c6546aacc5add05 (patch)
treec53b024330cd86461bd8028c3200c76ba3c6dbc3 /games-rpg
parentInitial release (diff)
downloadgentoo-2-157ecf53c46f056a7531b4704c6546aacc5add05.tar.gz
gentoo-2-157ecf53c46f056a7531b4704c6546aacc5add05.tar.bz2
gentoo-2-157ecf53c46f056a7531b4704c6546aacc5add05.zip
ver bump #29316 fix output msg #29505 fix SRC_URI #31073
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/nwn/ChangeLog11
-rw-r--r--games-rpg/nwn/files/digest-nwn-1.323
-rw-r--r--games-rpg/nwn/files/nwn-1.32-fixinstall91
-rw-r--r--games-rpg/nwn/nwn-1.32.ebuild84
4 files changed, 186 insertions, 3 deletions
diff --git a/games-rpg/nwn/ChangeLog b/games-rpg/nwn/ChangeLog
index 0bd1a1214b24..d5a6e31055be 100644
--- a/games-rpg/nwn/ChangeLog
+++ b/games-rpg/nwn/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-rpg/nwn
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/nwn/ChangeLog,v 1.3 2003/10/01 23:12:37 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/nwn/ChangeLog,v 1.4 2003/10/14 00:14:22 vapier Exp $
+
+*nwn-1.32 (13 Oct 2003)
+
+ 13 Oct 2003; Mike Frysinger <vapier@gentoo.org> :
+ Version bump #29316 and add helpful output #29505 and fix SRC_URI #31073.
+
+*nwn-1.30 (26 Jun 2003)
01 Oct 2003; Michael Sterrett <mr_bones_@gentoo.org> nwn-1.30.ebuild:
chown user.group -> chown user:group
@@ -11,8 +18,6 @@
29 Aug 2003; Chris Gianelloni <wolf31o2@gentoo.org> nwn-1.30.ebuild:
Added RESTRICT=fetch. Closing bug #27548.
-*nwn-1.30 (26 Jun 2003)
-
14 Aug 2003; Mike Frysinger <vapier@gentoo.org> :
Add updated ebuild from Daniel Mannarino <thesnark@operamail.com> #25162.
Fixes USE=nowin install.
diff --git a/games-rpg/nwn/files/digest-nwn-1.32 b/games-rpg/nwn/files/digest-nwn-1.32
new file mode 100644
index 000000000000..820e0f7f0dbd
--- /dev/null
+++ b/games-rpg/nwn/files/digest-nwn-1.32
@@ -0,0 +1,3 @@
+MD5 73c6515fd6aa5f860802098a55000ae8 nwclient129.tar.gz 5504342
+MD5 2be2a924284d783c007af0b2d2b4cd1a linuxclientupdate129to132eng.tar.gz 47992382
+MD5 8222401efe25235b56d01b38ae880b5b nwresources129.tar.gz 1212356127
diff --git a/games-rpg/nwn/files/nwn-1.32-fixinstall b/games-rpg/nwn/files/nwn-1.32-fixinstall
new file mode 100644
index 000000000000..44a67423b87b
--- /dev/null
+++ b/games-rpg/nwn/files/nwn-1.32-fixinstall
@@ -0,0 +1,91 @@
+#!/bin/bash
+# Initial version by Bioware
+# Modified to match the gentoo setup
+# 03/27/2003 phoen][x <phoenix@gentoo.org>
+
+FaRequiredDirs=(ambient data music override miles nwm)
+aRequiredFiles=(chitin.key dialog.tlk nwmain patch.key)
+aLCDirs=(ambient data dmvault hak localvault music override portraits)
+aProblemFiles=()
+
+printf "\nFixing case\n\n"
+
+if [ -f dialog.TLK ]
+then
+ mv dialog.TLK dialog.tlk
+fi
+
+if [ -f dialogF.TLK ]
+then
+ mv dialogF.TLK dialogf.tlk
+fi
+
+printf "Checking for required files\n\n"
+
+for d in ${aRequiredDirs[@]}
+do
+ if [ -d $d ]
+ then
+ printf "PASSED: $d directory exists\n"
+ else
+ printf "FAILED: $d directory missing\n"
+ exit
+ fi
+done
+
+for f in ${aRequiredFiles[@]}
+do
+ if [ -f $f ]
+ then
+ printf "PASSED: $f exists\n"
+ else
+ printf "FAILED: $f missing\n"
+ exit
+ fi
+done
+
+printf "\nFixing case\n\n"
+
+for d in ${aLCDirs[@]}
+do
+ if [ -d $d ]
+ then
+ printf "$d\n"
+
+ cd $d
+
+ for f in $(find *.*)
+ do
+ lcf=$(echo $f | tr [:upper:] [:lower:])
+ if [ $f != $lcf ]
+ then
+ if [ -f $f ]
+ then
+ mv $f $(echo $f | tr [:upper:] [:lower:])
+ fi
+ fi
+ printf .
+ done
+
+ cd ..
+
+ printf "\n"
+ fi
+done
+
+printf "\nChecking for problem files\n\n"
+
+for f in ${aProblemFiles[@]}
+do
+ if [ -f $f ]
+ then
+ printf "WARNING: $f exists, deleting this file is recommended\n"
+ fi
+done
+
+printf "\nFixing permissions\n\n"
+
+chown GENTOO_USER:GENTOO_GROUP GENTOO_DIR/nwn/ -R
+chmod g+rwX GENTOO_DIR/nwn/ -R
+
+printf "\nYou are ready to run Neverwinter Nights.\n\n"
diff --git a/games-rpg/nwn/nwn-1.32.ebuild b/games-rpg/nwn/nwn-1.32.ebuild
new file mode 100644
index 000000000000..08908202fcbe
--- /dev/null
+++ b/games-rpg/nwn/nwn-1.32.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/nwn/nwn-1.32.ebuild,v 1.1 2003/10/14 00:14:22 vapier Exp $
+
+inherit games
+
+DESCRIPTION="Never Winter Nights"
+HOMEPAGE="http://nwn.bioware.com/downloads/linuxclient.html"
+SRC_URI="http://nwdownloads.bioware.com/neverwinternights/linux/129/nwclient129.tar.gz
+ nowin? ( ftp://jeuxlinux.com/bioware/Neverwinter_Nights/nwresources129.tar.gz )
+ http://nwdownloads.bioware.com/neverwinternights/linux/132/linuxclientupdate129to132eng.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="nowin"
+RESTRICT="fetch nostrip nomirror"
+
+RDEPEND="virtual/x11
+ opengl? ( virtual/opengl )
+ >=media-libs/libsdl-1.2.5"
+
+S=${WORKDIR}/nwn
+
+src_unpack() {
+ mkdir ${S}
+ cd ${S}
+ unpack nwclient129.tar.gz
+ cd ${WORKDIR}
+ use nowin && unpack nwresources129.tar.gz
+ cd ${S}
+ unpack linuxclientupdate129to132eng.tar.gz
+}
+
+src_install() {
+ dodir ${GAMES_PREFIX_OPT}
+ sed \
+ -e "s:GENTOO_USER:${GAMES_USER}:" \
+ -e "s:GENTOO_GROUP:${GAMES_GROUP}:" \
+ -e "s:GENTOO_DIR:${GAMES_PREFIX_OPT}:" \
+ ${FILESDIR}/${P}-fixinstall > ${WORKDIR}/nwn/fixinstall
+ mv ${WORKDIR}/nwn ${D}/${GAMES_PREFIX_OPT}
+ dogamesbin ${FILESDIR}/nwn
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ if [ ! `use nowin` ] ; then
+ einfo "The NWN linux client is now installed."
+ einfo "Proceed with the following steps in order to get it working:"
+ einfo "1) Copy the following directories/files from your installed and"
+ einfo " patched (${PV}) Never Winter Nights to ${GAMES_PREFIX_OPT}/nwn:"
+ einfo " ambient/"
+ einfo " data/"
+ einfo " dmvault/"
+ einfo " hak/"
+ einfo " localvault/"
+ einfo " modules/"
+ einfo " music/"
+ einfo " nwm/"
+ einfo " override/"
+ einfo " portraits/"
+ einfo " saves/"
+ einfo " servervault/"
+ einfo " texturepacks/"
+ einfo " chitin.key"
+ einfo " patch.key"
+ einfo " dialog.tlk"
+ einfo " dialogF.tlk (French, German, Italian, and Spanish)"
+ einfo "2) Chown and chmod the files with the following commands"
+ einfo " chown -R ${GAMES_USER}:${GAMES_GROUP} ${GAMES_PREFIX_OPT}/nwn"
+ einfo " chmod -R g+rwX ${GAMES_PREFIX_OPT}/nwn"
+ einfo "3) Run ${GAMES_PREFIX_OPT}/nwn/fixinstall as root"
+ einfo "4) Make sure that you are in group ${GAMES_GROUP}"
+ einfo "5) Use ${GAMES_PREFIX_OPT}/nwn/nwn to run the game"
+ echo
+ einfo "Or try emerging with USE=nowin"
+ else
+ einfo "The NWN linux client is now installed."
+ einfo "Proceed with the following step in order to get it working:"
+ einfo "Run ${GAMES_PREFIX_OPT}/nwn/fixinstall as root"
+ fi
+}