summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-06-14 22:50:01 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-06-14 22:50:01 +0000
commit005676c6dc7479ab8d4de45cf454843b139ed3ba (patch)
treef3c1c1260fb6dc7452969ad6e034741cf25f02e6 /games-rpg/manaplus
parentversion bump (diff)
downloadgentoo-2-005676c6dc7479ab8d4de45cf454843b139ed3ba.tar.gz
gentoo-2-005676c6dc7479ab8d4de45cf454843b139ed3ba.tar.bz2
gentoo-2-005676c6dc7479ab8d4de45cf454843b139ed3ba.zip
version bump
(Portage version: 2.2.0_alpha179/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-rpg/manaplus')
-rw-r--r--games-rpg/manaplus/ChangeLog7
-rw-r--r--games-rpg/manaplus/manaplus-1.3.6.9.ebuild69
2 files changed, 75 insertions, 1 deletions
diff --git a/games-rpg/manaplus/ChangeLog b/games-rpg/manaplus/ChangeLog
index f5ff51c72954..7ba5c4cfc0b0 100644
--- a/games-rpg/manaplus/ChangeLog
+++ b/games-rpg/manaplus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-rpg/manaplus
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/manaplus/ChangeLog,v 1.6 2013/05/13 21:17:18 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/manaplus/ChangeLog,v 1.7 2013/06/14 22:50:01 hasufell Exp $
+
+*manaplus-1.3.6.9 (14 Jun 2013)
+
+ 14 Jun 2013; Julian Ospald <hasufell@gentoo.org> +manaplus-1.3.6.9.ebuild:
+ version bump
*manaplus-1.3.5.12 (13 May 2013)
diff --git a/games-rpg/manaplus/manaplus-1.3.6.9.ebuild b/games-rpg/manaplus/manaplus-1.3.6.9.ebuild
new file mode 100644
index 000000000000..7ed24c6ea239
--- /dev/null
+++ b/games-rpg/manaplus/manaplus-1.3.6.9.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/manaplus/manaplus-1.3.6.9.ebuild,v 1.1 2013/06/14 22:50:01 hasufell Exp $
+
+EAPI=5
+
+inherit games
+
+DESCRIPTION="OpenSource 2D MMORPG client for Evol Online and The Mana World"
+HOMEPAGE="http://manaplus.evolonline.org"
+SRC_URI="http://download.evolonline.org/manaplus/download/${PV}/manaplus-${PV}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls opengl"
+
+RDEPEND="
+ >=dev-games/physfs-1.0.0
+ dev-libs/libxml2
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-image[png]
+ media-libs/sdl-net
+ media-libs/sdl-ttf
+ net-misc/curl
+ sys-libs/zlib
+ media-libs/libpng:0
+ media-fonts/dejavu
+ >=dev-games/guichan-0.8.1[sdl]
+ media-libs/libsdl[X,opengl?,video]
+ media-libs/sdl-gfx
+ x11-apps/xmessage
+ x11-libs/libX11
+ x11-misc/xdg-utils
+ x11-misc/xsel
+ nls? ( virtual/libintl )
+ opengl? ( virtual/opengl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ sed -i \
+ -e '/^SUBDIRS/s/fonts//' \
+ data/Makefile.in || die
+
+ rm -r src/guichan || die
+}
+
+src_configure() {
+ egamesconf \
+ --without-internalguichan \
+ --localedir=/usr/share/locale \
+ --disable-manaserv \
+ --disable-eathena \
+ $(use_with opengl) \
+ $(use_enable nls)
+}
+
+src_install() {
+ default
+
+ dosym /usr/share/fonts/dejavu/DejaVuSans-Bold.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/dejavusans-bold.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSans.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/dejavusans.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSansMono.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/dejavusans-mono.ttf
+ insinto "${GAMES_DATADIR}"/${PN}/data
+
+ prepgamesdirs
+}