summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2013-01-08 22:38:51 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2013-01-08 22:38:51 +0000
commit38a67c16c8da6b0773c39fe506ce04a7db093c8e (patch)
tree9da31ed2bef8ae40aedd5e5a4ae695da5a70452b /games-roguelike
parentInitial import of flask-login library. (diff)
downloadgentoo-2-38a67c16c8da6b0773c39fe506ce04a7db093c8e.tar.gz
gentoo-2-38a67c16c8da6b0773c39fe506ce04a7db093c8e.tar.bz2
gentoo-2-38a67c16c8da6b0773c39fe506ce04a7db093c8e.zip
respect AR (bug #450934)
(Portage version: 2.1.11.31/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-roguelike')
-rw-r--r--games-roguelike/crossfire-client/ChangeLog6
-rw-r--r--games-roguelike/crossfire-client/crossfire-client-1.70.0.ebuild10
2 files changed, 10 insertions, 6 deletions
diff --git a/games-roguelike/crossfire-client/ChangeLog b/games-roguelike/crossfire-client/ChangeLog
index c5609487160c..367b751b5677 100644
--- a/games-roguelike/crossfire-client/ChangeLog
+++ b/games-roguelike/crossfire-client/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-roguelike/crossfire-client
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/crossfire-client/ChangeLog,v 1.32 2013/01/08 21:43:30 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/crossfire-client/ChangeLog,v 1.33 2013/01/08 22:38:51 mr_bones_ Exp $
+
+ 08 Jan 2013; Michael Sterrett <mr_bones_@gentoo.org>
+ crossfire-client-1.70.0.ebuild:
+ respect AR (bug #450934)
08 Jan 2013; Michael Sterrett <mr_bones_@gentoo.org>
crossfire-client-1.70.0.ebuild:
diff --git a/games-roguelike/crossfire-client/crossfire-client-1.70.0.ebuild b/games-roguelike/crossfire-client/crossfire-client-1.70.0.ebuild
index 6f83fd27799b..5b5c592766a2 100644
--- a/games-roguelike/crossfire-client/crossfire-client-1.70.0.ebuild
+++ b/games-roguelike/crossfire-client/crossfire-client-1.70.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/crossfire-client/crossfire-client-1.70.0.ebuild,v 1.4 2013/01/08 21:43:30 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/crossfire-client/crossfire-client-1.70.0.ebuild,v 1.5 2013/01/08 22:38:51 mr_bones_ Exp $
EAPI=5
-inherit gnome2-utils games
+inherit toolchain-funcs gnome2-utils games
DESCRIPTION="Client for the nethack-style but more in the line of UO"
HOMEPAGE="http://crossfire.real-time.com/"
@@ -34,7 +34,7 @@ src_prepare() {
src_configure() {
# bugs in configure script so we cant use $(use_enable ...)
- local myconf="--disable-dependency-tracking"
+ local myconf
use sdl || myconf="${myconf} --disable-sdl"
use alsa || myconf="${myconf} --disable-alsa9 --disable-alsa"
@@ -47,9 +47,9 @@ src_configure() {
src_compile() {
# bug 139785
if use alsa || use oss ; then
- emake -j1 -C sound-src
+ emake -j1 -C sound-src AR="$(tc-getAR)"
fi
- emake
+ emake AR="$(tc-getAR)"
}
src_install() {