summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2014-08-07 06:43:50 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2014-08-07 06:43:50 +0000
commitfe3ade4ff0070c43ce8010f379b7a6571b82a802 (patch)
tree26bd0b28561590292d5cdf5ec3210f3ef7f28034 /games-puzzle
parentFix parallel build (bug 513766). Remove old. Thanks patrick (diff)
downloadgentoo-2-fe3ade4ff0070c43ce8010f379b7a6571b82a802.tar.gz
gentoo-2-fe3ade4ff0070c43ce8010f379b7a6571b82a802.tar.bz2
gentoo-2-fe3ade4ff0070c43ce8010f379b7a6571b82a802.zip
version bump (bug #519194)
(Portage version: 2.2.8-r1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/neverball/ChangeLog7
-rw-r--r--games-puzzle/neverball/neverball-1.6.0.ebuild98
2 files changed, 104 insertions, 1 deletions
diff --git a/games-puzzle/neverball/ChangeLog b/games-puzzle/neverball/ChangeLog
index 573d51775e05..8541b6886af6 100644
--- a/games-puzzle/neverball/ChangeLog
+++ b/games-puzzle/neverball/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-puzzle/neverball
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/neverball/ChangeLog,v 1.47 2014/05/15 16:52:55 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/neverball/ChangeLog,v 1.48 2014/08/07 06:43:50 mr_bones_ Exp $
+
+*neverball-1.6.0 (07 Aug 2014)
+
+ 07 Aug 2014; Michael Sterrett <mr_bones_@gentoo.org> +neverball-1.6.0.ebuild:
+ version bump (bug #519194)
15 May 2014; Ulrich Müller <ulm@gentoo.org> neverball-1.5.4.ebuild:
Fix USE dependency on media-libs/libsdl, "audio" USE flag was renamed to
diff --git a/games-puzzle/neverball/neverball-1.6.0.ebuild b/games-puzzle/neverball/neverball-1.6.0.ebuild
new file mode 100644
index 000000000000..1472ab963cd7
--- /dev/null
+++ b/games-puzzle/neverball/neverball-1.6.0.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/neverball/neverball-1.6.0.ebuild,v 1.1 2014/08/07 06:43:50 mr_bones_ Exp $
+
+EAPI=5
+inherit eutils gnome2-utils games
+
+DESCRIPTION="Clone of Super Monkey Ball using SDL/OpenGL"
+HOMEPAGE="http://neverball.org/"
+SRC_URI="http://neverball.org/${P}.tar.gz"
+
+LICENSE="GPL-2+ IJG"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+RESTRICT="test"
+
+RDEPEND="media-libs/libsdl2[sound,joystick,opengl,video]
+ media-libs/sdl2-ttf
+ media-libs/libpng:0
+ virtual/jpeg
+ media-libs/libvorbis
+ virtual/opengl
+ dev-games/physfs
+ media-fonts/dejavu
+ media-fonts/wqy-microhei
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+src_prepare() {
+ sed -i \
+ -e 's:mapc:neverball-mapc:g' \
+ -e 's:MAPC:NEVERBALL-MAPC:g' \
+ -e '1 s/ 1 / 6 /' \
+ dist/mapc.1 || die
+ sed -i \
+ -e '/CFLAGS.*O2/s:-O2:$(E_CFLAGS):' \
+ -e '/CXXFLAGS.*O2/s:-O2:$(E_CXXFLAGS):' \
+ -e "/^MAPC_TARG/s/mapc/${PN}-mapc/" \
+ Makefile || die
+}
+
+src_compile() {
+ emake \
+ ENABLE_NLS=$(use nls && echo 1 || echo 0) \
+ E_CFLAGS="${CFLAGS}" \
+ E_CXXFLAGS="${CXXFLAGS}" \
+ LOCALEDIR=/usr/share/locale \
+ DATADIR="${GAMES_DATADIR}/${PN}"
+}
+
+src_install() {
+ local font
+
+ dogamesbin ${PN}-mapc neverball neverputt
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r data/*
+ for font in DejaVuSans-Bold.ttf wqy-microhei.ttc
+ do
+ rm -f "${D}${GAMES_DATADIR}/${PN}"/ttf/${font}
+ dosym /usr/share/fonts/*/${font} \
+ "${GAMES_DATADIR}/${PN}"/ttf/${font}
+ done
+ if [[ -d locale ]] ; then
+ insinto /usr/share
+ doins -r locale
+ fi
+ dodoc doc/{authors.txt,manual.txt,release-notes.md} README.md
+
+ local res
+ for res in 16 32 64 128 256; do
+ newicon -s ${res} dist/neverball_${res}.png ${P}.png
+ done
+
+ doman dist/*.6
+ newman dist/mapc.1 neverball-mapc.6
+ make_desktop_entry neverball Neverball
+ make_desktop_entry neverputt Neverputt
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ games_pkg_postinst
+ elog "${P} will overwrite existing high-score files, so back them up if"
+ elog "you want to preserve your old scores and progress."
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}