summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-01-19 04:51:43 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-01-19 04:51:43 +0000
commitf6886c0007e377d8aa88dcd797763fef67a20b4d (patch)
tree4e63964cfe45f1862de67cc672bbdfe3a7e781d2 /games-puzzle
parentpackage.use.mask mono on ppc instead of disabling it in the ebuild (bug #202361) (diff)
downloadgentoo-2-f6886c0007e377d8aa88dcd797763fef67a20b4d.tar.gz
gentoo-2-f6886c0007e377d8aa88dcd797763fef67a20b4d.tar.bz2
gentoo-2-f6886c0007e377d8aa88dcd797763fef67a20b4d.zip
Remove sdl USE flag, bug #206404
(Portage version: 2.1.4)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/xwelltris/ChangeLog7
-rw-r--r--games-puzzle/xwelltris/xwelltris-1.0.1.ebuild39
2 files changed, 23 insertions, 23 deletions
diff --git a/games-puzzle/xwelltris/ChangeLog b/games-puzzle/xwelltris/ChangeLog
index e52373c25088..8e0d505d91bf 100644
--- a/games-puzzle/xwelltris/ChangeLog
+++ b/games-puzzle/xwelltris/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-puzzle/xwelltris
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xwelltris/ChangeLog,v 1.11 2007/02/22 01:18:42 peper Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xwelltris/ChangeLog,v 1.12 2008/01/19 04:51:43 nyhm Exp $
+
+ 19 Jan 2008; Tristan Heaven <nyhm@gentoo.org> xwelltris-1.0.1.ebuild:
+ Remove sdl USE flag, bug #206404
22 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/games-puzzle/xwelltris/xwelltris-1.0.1.ebuild b/games-puzzle/xwelltris/xwelltris-1.0.1.ebuild
index e78f83ff4947..a44f6df95659 100644
--- a/games-puzzle/xwelltris/xwelltris-1.0.1.ebuild
+++ b/games-puzzle/xwelltris/xwelltris-1.0.1.ebuild
@@ -1,50 +1,47 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xwelltris/xwelltris-1.0.1.ebuild,v 1.13 2006/12/06 17:23:52 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xwelltris/xwelltris-1.0.1.ebuild,v 1.14 2008/01/19 04:51:43 nyhm Exp $
inherit games
-DESCRIPTION="tetris like popular game"
+DESCRIPTION="2.5D tetris like game"
HOMEPAGE="http://xnc.dubna.su/xwelltris/"
SRC_URI="http://xnc.dubna.su/xwelltris/src/${P}.src.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-IUSE="sdl"
+IUSE=""
-RDEPEND="x11-misc/xbitmaps
- x11-libs/libX11
- x11-libs/libXt
- x11-libs/libXmu
- x11-libs/libXaw
- sdl? ( media-libs/libsdl media-libs/sdl-image )"
-DEPEND="${RDEPEND}
- x11-proto/xproto"
+DEPEND="media-libs/libsdl
+ media-libs/sdl-image"
src_unpack() {
unpack ${A}
cd "${S}"
- sed -i '/INSTALL_PROGRAM/s/-s //' src/Make.common.in || die "sed failed"
+ sed -i \
+ -e '/INSTALL_PROGRAM/s/-s //' \
+ src/Make.common.in \
+ || die "sed Make.common.in failed"
+ sed -i \
+ -e "/GLOBAL_SEARCH/s:\".*\":\"${GAMES_DATADIR}/${PN}\":" \
+ src/include/globals.h.in \
+ || die "sed globals.h.in failed"
}
src_compile() {
# configure/build process is pretty messed up
- egamesconf $(use_with sdl) || die "egamesconf failed"
- sed -i \
- -e "/GLOBAL_SEARCH/s:\".*\":\"${GAMES_DATADIR}/${PN}\":" \
- src/include/globals.h \
- || die "sed src/include/globals.h failed"
- emake || die "emake failed"
+ egamesconf --with-sdl || die
+ emake -C src || die "emake failed"
}
src_install() {
dodir "${GAMES_BINDIR}" "${GAMES_DATADIR}/${PN}" /usr/share/man
- make install \
+ emake install \
INSTDIR="${D}/${GAMES_BINDIR}" \
INSTLIB="${D}/${GAMES_DATADIR}/${PN}" \
INSTMAN=/usr/share/man \
- || die "make install failed"
+ || die "emake install failed"
dodoc AUTHORS Changelog README*
prepgamesdirs
}