summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-10-08 06:27:55 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-10-08 06:27:55 +0000
commitdf4379971972a3329746dfaf4339a9b2e977c7bc (patch)
tree9caaa02ef3d28c8f4458ff3ea6a97bc6e56dcd9b /games-puzzle
parentFixed encoding in ChangeLog (diff)
downloadgentoo-2-df4379971972a3329746dfaf4339a9b2e977c7bc.tar.gz
gentoo-2-df4379971972a3329746dfaf4339a9b2e977c7bc.tar.bz2
gentoo-2-df4379971972a3329746dfaf4339a9b2e977c7bc.zip
version bump
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/zaz/ChangeLog8
-rw-r--r--games-puzzle/zaz/files/zaz-0.3.0-build.patch48
-rw-r--r--games-puzzle/zaz/zaz-0.3.0.ebuild46
3 files changed, 101 insertions, 1 deletions
diff --git a/games-puzzle/zaz/ChangeLog b/games-puzzle/zaz/ChangeLog
index 6a79be5983da..5f883be433bd 100644
--- a/games-puzzle/zaz/ChangeLog
+++ b/games-puzzle/zaz/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-puzzle/zaz
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/zaz/ChangeLog,v 1.3 2009/09/03 23:25:04 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/zaz/ChangeLog,v 1.4 2009/10/08 06:27:55 mr_bones_ Exp $
+
+*zaz-0.3.0 (08 Oct 2009)
+
+ 08 Oct 2009; Michael Sterrett <mr_bones_@gentoo.org> +zaz-0.3.0.ebuild,
+ +files/zaz-0.3.0-build.patch:
+ version bump
*zaz-0.2.9 (03 Sep 2009)
diff --git a/games-puzzle/zaz/files/zaz-0.3.0-build.patch b/games-puzzle/zaz/files/zaz-0.3.0-build.patch
new file mode 100644
index 000000000000..232c4bafc926
--- /dev/null
+++ b/games-puzzle/zaz/files/zaz-0.3.0-build.patch
@@ -0,0 +1,48 @@
+diff -ru zaz-0.2.9-orig/Makefile.am zaz-0.2.9/Makefile.am
+--- zaz-0.2.9-orig/Makefile.am 2009-08-25 18:54:22.000000000 -0400
++++ zaz-0.2.9/Makefile.am 2009-09-03 17:31:50.712703375 -0400
+@@ -4,22 +4,7 @@
+
+ SUBDIRS = po src data extra
+
+-zazdocdir = ${prefix}/doc/zaz
+-zazdoc_DATA = \
+- README\
+- COPYING\
+- AUTHORS\
+- ChangeLog\
+- INSTALL\
+- NEWS
+-
+-
+ EXTRA_DIST = config.rpath m4/ChangeLog $(zazdoc_DATA) \
+ $(shared_data_DATA) \
+ zaz.anjuta\
+ win32.zip
+-
+-# Remove doc directory on uninstall
+-uninstall-local:
+- -rm -r $(zazdocdir)
+-
+diff -ru zaz-0.2.9-orig/src/Makefile.am zaz-0.2.9/src/Makefile.am
+--- zaz-0.2.9-orig/src/Makefile.am 2009-08-25 18:57:27.000000000 -0400
++++ zaz-0.2.9/src/Makefile.am 2009-09-03 17:31:50.713702277 -0400
+@@ -3,8 +3,7 @@
+ ## Created by Anjuta
+
+ AM_CPPFLAGS = \
+- -DPACKAGE_LOCALE_DIR=\""$(prefix)/$(DATADIRNAME)/locale"\" \
+- -DPACKAGE_SRC_DIR=\""$(srcdir)"\" \
++ -DPACKAGE_LOCALE_DIR=\""/usr/share/locale"\" \
+ -DPACKAGE_DATA_DIR=\""$(datadir)"\"\
+ -I/usr/include/freetype2
+
+@@ -14,7 +13,7 @@
+
+
+ datadir = @datadir@
+-localedir = $(datadir)/locale
++localedir = /usr/share/locale
+ DEFS = -DLOCALEDIR=\"$(localedir)\" @DEFS@
+
+ bin_PROGRAMS = zaz
diff --git a/games-puzzle/zaz/zaz-0.3.0.ebuild b/games-puzzle/zaz/zaz-0.3.0.ebuild
new file mode 100644
index 000000000000..b7456a90787e
--- /dev/null
+++ b/games-puzzle/zaz/zaz-0.3.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/zaz/zaz-0.3.0.ebuild,v 1.1 2009/10/08 06:27:55 mr_bones_ Exp $
+
+EAPI=2
+inherit autotools eutils games
+
+DESCRIPTION="A puzzle game where the player has to arrange balls in triplets"
+HOMEPAGE="http://sourceforge.net/projects/zaz/"
+SRC_URI="mirror://sourceforge/zaz/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="virtual/opengl
+ virtual/glu
+ media-libs/libsdl[X,audio,video]
+ media-libs/sdl-image[png]
+ media-libs/libvorbis
+ media-libs/libtheora
+ media-libs/ftgl
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --with-applicationdir=/usr/share/applications \
+ --with-icondir=/usr/share/pixmaps \
+ --localedir=/usr/share/locale \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake failed"
+ dodoc AUTHORS ChangeLog
+ prepgamesdirs
+}