summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-12-05 17:32:44 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-12-05 17:32:44 +0000
commitda4869e4452f44ab62030730b0a869c7cef66c63 (patch)
tree74896429b2b30a59bcf1fd12459ebbe316c70c98 /games-puzzle
parentRemoved unused icon that would collide with vmware-workstation (diff)
downloadgentoo-2-da4869e4452f44ab62030730b0a869c7cef66c63.tar.gz
gentoo-2-da4869e4452f44ab62030730b0a869c7cef66c63.tar.bz2
gentoo-2-da4869e4452f44ab62030730b0a869c7cef66c63.zip
Respect CC and LDFLAGS, bug #244100
(Portage version: 2.2_rc17/cvs/Linux 2.6.27.7 i686)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/mirrormagic/ChangeLog7
-rw-r--r--games-puzzle/mirrormagic/mirrormagic-2.0.2.ebuild34
2 files changed, 25 insertions, 16 deletions
diff --git a/games-puzzle/mirrormagic/ChangeLog b/games-puzzle/mirrormagic/ChangeLog
index 6c6ad38f0bff..ded0498f86e7 100644
--- a/games-puzzle/mirrormagic/ChangeLog
+++ b/games-puzzle/mirrormagic/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-puzzle/mirrormagic
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/mirrormagic/ChangeLog,v 1.11 2007/02/22 01:14:19 peper Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/mirrormagic/ChangeLog,v 1.12 2008/12/05 17:32:44 nyhm Exp $
+
+ 05 Dec 2008; Tristan Heaven <nyhm@gentoo.org> mirrormagic-2.0.2.ebuild:
+ Respect CC and LDFLAGS, bug #244100
22 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/games-puzzle/mirrormagic/mirrormagic-2.0.2.ebuild b/games-puzzle/mirrormagic/mirrormagic-2.0.2.ebuild
index 883f5f122ecd..3a78f5a1a122 100644
--- a/games-puzzle/mirrormagic/mirrormagic-2.0.2.ebuild
+++ b/games-puzzle/mirrormagic/mirrormagic-2.0.2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/mirrormagic/mirrormagic-2.0.2.ebuild,v 1.18 2007/02/25 15:39:21 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/mirrormagic/mirrormagic-2.0.2.ebuild,v 1.19 2008/12/05 17:32:44 nyhm Exp $
-inherit eutils games
+inherit eutils toolchain-funcs games
DESCRIPTION="a game like Deflektor (C 64) or Mindbender (Amiga)"
HOMEPAGE="http://www.artsoft.org/mirrormagic/"
@@ -15,26 +15,32 @@ IUSE="sdl"
RDEPEND="!sdl? ( x11-libs/libX11 )
sdl? (
- >=media-libs/libsdl-1.1
- >=media-libs/sdl-mixer-1.2.4
- >=media-libs/sdl-image-1.2.2 )"
+ media-libs/libsdl
+ media-libs/sdl-mixer
+ media-libs/sdl-image
+ )"
DEPEND="${RDEPEND}
!sdl? ( x11-libs/libXt )"
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}/${P}"-gcc41.patch
+ epatch "${FILESDIR}"/${P}-gcc41.patch
+ rm -f ${PN}
}
src_compile() {
- local makeopts="X11_PATH=/usr/X11R6 RO_GAME_DIR=${GAMES_DATADIR}/${PN} RW_GAME_DIR=${GAMES_STATEDIR}/${PN}"
- emake clean || die
- if use sdl ; then
- emake ${makeopts} OPTIONS="${CFLAGS}" sdl || die
- else
- emake ${makeopts} OPTIONS="${CFLAGS}" x11 || die
- fi
+ emake \
+ -C src \
+ CC="$(tc-getCC)" \
+ AR="$(tc-getAR)" \
+ RANLIB="$(tc-getRANLIB)" \
+ OPTIONS="${CFLAGS}" \
+ EXTRA_LDFLAGS="${LDFLAGS}" \
+ RO_GAME_DIR="${GAMES_DATADIR}"/${PN} \
+ RW_GAME_DIR="${GAMES_STATEDIR}"/${PN} \
+ TARGET=$(use sdl && echo sdl || echo x11) \
+ || die "emake failed"
}
src_install() {