summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2011-06-20 19:23:48 +0000
committerAlfredo Tupone <tupone@gentoo.org>2011-06-20 19:23:48 +0000
commit90a37cf6c357a9d4e6b1836c4f82d7c501f6206a (patch)
tree1dd28658913660a7cd2eec5c6cf204b12202f9f1 /games-puzzle
parentFix underlink. Bug #369773 (diff)
downloadgentoo-2-90a37cf6c357a9d4e6b1836c4f82d7c501f6206a.tar.gz
gentoo-2-90a37cf6c357a9d4e6b1836c4f82d7c501f6206a.tar.bz2
gentoo-2-90a37cf6c357a9d4e6b1836c4f82d7c501f6206a.zip
Fix underlink. Bug #370093
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/gnurobbo/ChangeLog6
-rw-r--r--games-puzzle/gnurobbo/files/gnurobbo-0.66-underlink.patch18
-rw-r--r--games-puzzle/gnurobbo/gnurobbo-0.66.ebuild6
3 files changed, 25 insertions, 5 deletions
diff --git a/games-puzzle/gnurobbo/ChangeLog b/games-puzzle/gnurobbo/ChangeLog
index 81469675353f..79a369a86529 100644
--- a/games-puzzle/gnurobbo/ChangeLog
+++ b/games-puzzle/gnurobbo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-puzzle/gnurobbo
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/gnurobbo/ChangeLog,v 1.22 2011/01/11 22:10:05 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/gnurobbo/ChangeLog,v 1.23 2011/06/20 19:23:48 tupone Exp $
+
+ 20 Jun 2011; Tupone Alfredo <tupone@gentoo.org> gnurobbo-0.66.ebuild,
+ +files/gnurobbo-0.66-underlink.patch:
+ Fix underlink. Bug #370093 by Diego Elio Pettenò
11 Jan 2011; Brent Baude <ranger@gentoo.org> gnurobbo-0.66.ebuild:
Marking gnurobbo-0.66 ppc for bug 350416
diff --git a/games-puzzle/gnurobbo/files/gnurobbo-0.66-underlink.patch b/games-puzzle/gnurobbo/files/gnurobbo-0.66-underlink.patch
new file mode 100644
index 000000000000..9034a6fac0e2
--- /dev/null
+++ b/games-puzzle/gnurobbo/files/gnurobbo-0.66-underlink.patch
@@ -0,0 +1,18 @@
+--- Makefile.old 2011-06-20 21:19:49.578922392 +0200
++++ Makefile 2011-06-20 21:20:28.535421648 +0200
+@@ -39,14 +39,13 @@
+ CFLAGS?=-O3 -pipe
+ CFLAGS+=-Wall `$(SDL_CONFIG) --cflags` -DPLATFORM_PC -DVERSION=\"$(VERSION)\" \
+ -DPACKAGE_DATA_DIR=\"$(PACKAGE_DATA_DIR)\" $(FONT_USE_PIXMAP) $(MUSIC) $(DESIGNER)
+-LDFLAGS=
+ # Use these instead for debugging and/or profiling (mainly intended for GNU Robbo developers)
+ #CFLAGS?=-O0 -pipe -g -pg
+ #CFLAGS+=-Wall `$(SDL_CONFIG) --cflags` -DPLATFORM_PC -DVERSION=\"$(VERSION)\" \
+ # -DPACKAGE_DATA_DIR=\"$(PACKAGE_DATA_DIR)\" $(FONT_USE_PIXMAP) $(MUSIC) $(DESIGNER)
+ #LDFLAGS=-pg
+ LINK=$(CC)
+-LIBS=`$(SDL_CONFIG) --libs` -lSDL_image -lSDL_mixer $(FONT_USE_SDL_TTF)
++LIBS=`$(SDL_CONFIG) --libs` -lSDL_image -lSDL_mixer $(FONT_USE_SDL_TTF) -lm
+
+ # You won't need to alter anything below
+ all: $(SOURCES) $(TARGET)
diff --git a/games-puzzle/gnurobbo/gnurobbo-0.66.ebuild b/games-puzzle/gnurobbo/gnurobbo-0.66.ebuild
index 00cde197958f..9986d6ea1789 100644
--- a/games-puzzle/gnurobbo/gnurobbo-0.66.ebuild
+++ b/games-puzzle/gnurobbo/gnurobbo-0.66.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/gnurobbo/gnurobbo-0.66.ebuild,v 1.4 2011/01/11 22:10:05 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/gnurobbo/gnurobbo-0.66.ebuild,v 1.5 2011/06/20 19:23:48 tupone Exp $
EAPI=2
inherit eutils games
@@ -19,9 +19,7 @@ DEPEND="media-libs/libsdl[audio,video,joystick]
media-libs/sdl-mixer[vorbis]
media-libs/sdl-ttf"
-src_prepare() {
- sed -i -e '/^LDFLAGS/d' Makefile || die
-}
+PATCHES=( "${FILESDIR}"/${P}-underlink.patch )
src_compile() {
emake \