summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2009-02-11 08:39:43 +0000
committerAlfredo Tupone <tupone@gentoo.org>2009-02-11 08:39:43 +0000
commit4f3323f106ef29a22abe4d1b1c0457817d0008eb (patch)
treef4bf2de26b7d1b03f6a9ca61b313e343cfb24905 /games-puzzle
parentEAPI=2; make it work with newer devil (diff)
downloadgentoo-2-4f3323f106ef29a22abe4d1b1c0457817d0008eb.tar.gz
gentoo-2-4f3323f106ef29a22abe4d1b1c0457817d0008eb.tar.bz2
gentoo-2-4f3323f106ef29a22abe4d1b1c0457817d0008eb.zip
Fix --as-needed bug #247452
(Portage version: 2.1.6.4/cvs/Linux 2.6.27-gentoo-r8 x86_64)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/xpuyopuyo/ChangeLog8
-rw-r--r--games-puzzle/xpuyopuyo/files/xpuyopuyo-0.9.8-as-needed.patch11
-rw-r--r--games-puzzle/xpuyopuyo/xpuyopuyo-0.9.8.ebuild12
3 files changed, 25 insertions, 6 deletions
diff --git a/games-puzzle/xpuyopuyo/ChangeLog b/games-puzzle/xpuyopuyo/ChangeLog
index 039d8827c525..2691571e63c5 100644
--- a/games-puzzle/xpuyopuyo/ChangeLog
+++ b/games-puzzle/xpuyopuyo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-puzzle/xpuyopuyo
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xpuyopuyo/ChangeLog,v 1.3 2008/06/26 08:43:21 opfer Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xpuyopuyo/ChangeLog,v 1.4 2009/02/11 08:39:43 tupone Exp $
+
+ 11 Feb 2009; Alfredo Tupone <tupone@gentoo.org>
+ +files/xpuyopuyo-0.9.8-as-needed.patch, xpuyopuyo-0.9.8.ebuild:
+ Fix --as-needed bug #247452 by flameeyes@gentoo.org
26 Jun 2008; Christian Faulhammer <opfer@gentoo.org>
xpuyopuyo-0.9.8.ebuild:
diff --git a/games-puzzle/xpuyopuyo/files/xpuyopuyo-0.9.8-as-needed.patch b/games-puzzle/xpuyopuyo/files/xpuyopuyo-0.9.8-as-needed.patch
new file mode 100644
index 000000000000..3df49a433dbf
--- /dev/null
+++ b/games-puzzle/xpuyopuyo/files/xpuyopuyo-0.9.8-as-needed.patch
@@ -0,0 +1,11 @@
+--- Makefile.in.old 2009-02-11 09:30:12.000000000 +0100
++++ Makefile.in 2009-02-11 09:30:28.000000000 +0100
+@@ -120,7 +120,7 @@
+
+ XPP_LIBS = $(NET_LIBS) pgame/libxpp_game.a pai/libxpp_ai.a
+ XPP_NET_LIBS = pnet/libxpp_net.a # This must be after interface
+-XPP_SOUND_LIBS = $(LIBMIKMOD_LIBS) psound/libxpp_sound.a
++XPP_SOUND_LIBS = psound/libxpp_sound.a $(LIBMIKMOD_LIBS)
+
+ @GTK_TRUE@xpuyopuyo_LDADD = $(XPP_LIBS) pgtk/libxpp_interface.a $(XPP_NET_LIBS) $(XPP_SOUND_LIBS) $(GTK_LIBS) pgame/libxpp_game.a putil/libxpp_util.a
+ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
diff --git a/games-puzzle/xpuyopuyo/xpuyopuyo-0.9.8.ebuild b/games-puzzle/xpuyopuyo/xpuyopuyo-0.9.8.ebuild
index f12f56b4c40f..e9f4026a0618 100644
--- a/games-puzzle/xpuyopuyo/xpuyopuyo-0.9.8.ebuild
+++ b/games-puzzle/xpuyopuyo/xpuyopuyo-0.9.8.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xpuyopuyo/xpuyopuyo-0.9.8.ebuild,v 1.4 2008/06/26 08:43:21 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xpuyopuyo/xpuyopuyo-0.9.8.ebuild,v 1.5 2009/02/11 08:39:43 tupone Exp $
+EAPI=2
inherit eutils games
DESCRIPTION="A Tetris-like game with opponent"
@@ -17,13 +18,16 @@ DEPEND="=x11-libs/gtk+-1.2*
x11-libs/libXpm
media-libs/libmikmod"
-src_compile() {
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+}
+
+src_configure() {
egamesconf \
--with-gnome \
--enable-aibreed \
--enable-network \
|| die
- emake || die "make failed"
}
src_install() {