summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-03-29 01:56:17 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-03-29 01:56:17 +0000
commite89be22c9413754c0832fa8e4ab171da5efbf568 (patch)
tree1f8711ad07d573ad846370c4036e385a538ff229 /games-puzzle/triptych-demo
parentInitial import. (diff)
downloadgentoo-2-e89be22c9413754c0832fa8e4ab171da5efbf568.tar.gz
gentoo-2-e89be22c9413754c0832fa8e4ab171da5efbf568.tar.bz2
gentoo-2-e89be22c9413754c0832fa8e4ab171da5efbf568.zip
EAPI=5
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-puzzle/triptych-demo')
-rw-r--r--games-puzzle/triptych-demo/ChangeLog7
-rw-r--r--games-puzzle/triptych-demo/triptych-demo-0.ebuild22
2 files changed, 18 insertions, 11 deletions
diff --git a/games-puzzle/triptych-demo/ChangeLog b/games-puzzle/triptych-demo/ChangeLog
index 42554ad97aa3..876c5752c81d 100644
--- a/games-puzzle/triptych-demo/ChangeLog
+++ b/games-puzzle/triptych-demo/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-puzzle/triptych-demo
-# Copyright 2000-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/triptych-demo/ChangeLog,v 1.10 2014/04/17 16:21:16 ulm Exp $
+# Copyright 2000-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/triptych-demo/ChangeLog,v 1.11 2015/03/29 01:56:17 mr_bones_ Exp $
+
+ 29 Mar 2015; Michael Sterrett <mr_bones_@gentoo.org> triptych-demo-0.ebuild:
+ EAPI=5
17 Apr 2014; Ulrich Müller <ulm@gentoo.org> triptych-demo-0.ebuild:
Fix LICENSE, add mirror and bindist restrictions, update SRC_URI, bug 505728.
diff --git a/games-puzzle/triptych-demo/triptych-demo-0.ebuild b/games-puzzle/triptych-demo/triptych-demo-0.ebuild
index c0d252aa0163..ff5a365eeb1d 100644
--- a/games-puzzle/triptych-demo/triptych-demo-0.ebuild
+++ b/games-puzzle/triptych-demo/triptych-demo-0.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/triptych-demo/triptych-demo-0.ebuild,v 1.10 2014/04/17 16:21:16 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/triptych-demo/triptych-demo-0.ebuild,v 1.11 2015/03/29 01:56:17 mr_bones_ Exp $
+EAPI=5
inherit eutils games
DESCRIPTION="fast-paced tetris-like puzzler"
@@ -15,17 +16,19 @@ IUSE=""
RESTRICT="mirror bindist strip"
DEPEND="x11-libs/libXext
- media-libs/libsdl
+ media-libs/libsdl[opengl,sound,video]
virtual/opengl"
-RDEPEND=""
+RDEPEND=${DEPEND}
+
+QA_PREBUILT="${GAMES_PREFIX_OPT}/${PN}/triptych ${GAMES_PREFIX_OPT}/${PN}/setup"
S=${WORKDIR}/triptych
src_install() {
local dir=${GAMES_PREFIX_OPT}/${PN}
- dodir "${dir}" "${GAMES_BINDIR}"
+ dodir "${dir}"
- cp -pPR * "${D}"/${dir}/
+ cp -pPR * "${D}"/${dir}/ || die
games_make_wrapper triptych ./triptych "${dir}"
prepgamesdirs
@@ -38,9 +41,10 @@ pkg_postinst() {
for f in triptych.{clr,cnt,scr} ; do
f="${ROOT}/${GAMES_PREFIX_OPT}/${PN}/${f}"
if [[ ! -e ${f} ]] ; then
- touch "${f}"
- chmod 660 "${f}"
- chown ${GAMES_USER}:${GAMES_GROUP} "${f}"
+ touch "${f}" \
+ && chmod 660 "${f}" \
+ && chown ${GAMES_USER}:${GAMES_GROUP} "${f}" \
+ || die
fi
done
}