summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2014-06-16 06:16:17 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2014-06-16 06:16:17 +0000
commit986261e5522275c66f1e20cc35fdf1f6ca0dd9df (patch)
treedd5bd86e0ae5073eed5d7da85c65f76e1c6fd608 /games-puzzle/scramble
parentVersion bump. (diff)
downloadgentoo-2-986261e5522275c66f1e20cc35fdf1f6ca0dd9df.tar.gz
gentoo-2-986261e5522275c66f1e20cc35fdf1f6ca0dd9df.tar.bz2
gentoo-2-986261e5522275c66f1e20cc35fdf1f6ca0dd9df.zip
EAPI=5; fix build (bug #513412)
(Portage version: 2.2.8-r1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-puzzle/scramble')
-rw-r--r--games-puzzle/scramble/ChangeLog8
-rw-r--r--games-puzzle/scramble/scramble-0.9.5.ebuild20
2 files changed, 18 insertions, 10 deletions
diff --git a/games-puzzle/scramble/ChangeLog b/games-puzzle/scramble/ChangeLog
index 82419b9ae641..10195df0aed6 100644
--- a/games-puzzle/scramble/ChangeLog
+++ b/games-puzzle/scramble/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-puzzle/scramble
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/scramble/ChangeLog,v 1.9 2007/02/08 21:19:10 wolf31o2 Exp $
+# Copyright 2000-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/scramble/ChangeLog,v 1.10 2014/06/16 06:16:17 mr_bones_ Exp $
+
+ 16 Jun 2014; Michael Sterrett <mr_bones_@gentoo.org> scramble-0.9.5.ebuild:
+ EAPI=5; fix build (bug #513412)
08 Feb 2007; Chris Gianelloni <wolf31o2@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
@@ -36,4 +39,3 @@
05 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org> metadata.xml,
scramble-0.7.ebuild:
initial commit
-
diff --git a/games-puzzle/scramble/scramble-0.9.5.ebuild b/games-puzzle/scramble/scramble-0.9.5.ebuild
index f55f4c6a981b..e42c15e54625 100644
--- a/games-puzzle/scramble/scramble-0.9.5.ebuild
+++ b/games-puzzle/scramble/scramble-0.9.5.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/scramble/scramble-0.9.5.ebuild,v 1.2 2007/04/26 07:20:11 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/scramble/scramble-0.9.5.ebuild,v 1.3 2014/06/16 06:16:17 mr_bones_ Exp $
-inherit games
+EAPI=5
+inherit autotools flag-o-matic games
DESCRIPTION="Create as many words as you can before the time runs out"
HOMEPAGE="http://www.shiftygames.com/scramble/scramble.html"
@@ -13,14 +14,19 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc x86"
IUSE=""
-DEPEND=">=media-libs/libsdl-1.2
- >=media-libs/sdl-mixer-1.2
- >=media-libs/sdl-image-1.2
+DEPEND=">=media-libs/libsdl-1.2[sound,video]
+ >=media-libs/sdl-mixer-1.2[vorbis]
+ >=media-libs/sdl-image-1.2[png]
media-libs/sdl-ttf"
RDEPEND="${DEPEND}
sys-apps/miscfiles"
+src_prepare() {
+ append-cflags $(sdl-config --cflags)
+ eautoreconf
+}
+
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
+ default
prepgamesdirs
}