summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-02-19 09:09:06 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-02-19 09:09:06 +0000
commitb2fba65ca6c65c117bbfba6716180f7adeaf1cb5 (patch)
treee80b92a9ce54d93fb43ae8a8103ccbd4999632e9 /games-puzzle/picpuz/picpuz-2.1.1.ebuild
parentVersion bump. Remove non-functional opengl useflag. Disable HDF and 3D modules (diff)
downloadgentoo-2-b2fba65ca6c65c117bbfba6716180f7adeaf1cb5.tar.gz
gentoo-2-b2fba65ca6c65c117bbfba6716180f7adeaf1cb5.tar.bz2
gentoo-2-b2fba65ca6c65c117bbfba6716180f7adeaf1cb5.zip
version bump
(Portage version: 2.1.7.16/cvs/Linux i686)
Diffstat (limited to 'games-puzzle/picpuz/picpuz-2.1.1.ebuild')
-rw-r--r--games-puzzle/picpuz/picpuz-2.1.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/games-puzzle/picpuz/picpuz-2.1.1.ebuild b/games-puzzle/picpuz/picpuz-2.1.1.ebuild
new file mode 100644
index 000000000000..17cd4d94bad0
--- /dev/null
+++ b/games-puzzle/picpuz/picpuz-2.1.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/picpuz/picpuz-2.1.1.ebuild,v 1.1 2010/02/19 09:09:05 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils games
+
+DESCRIPTION="a jigsaw puzzle program"
+HOMEPAGE="http://kornelix.squarespace.com/picpuz/"
+SRC_URI="http://kornelix.squarespace.com/storage/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-build.patch )
+
+src_compile() {
+ emake \
+ BINDIR="${GAMES_BINDIR}" \
+ DATADIR="${GAMES_DATADIR}"/${PN} \
+ DOCDIR=/usr/share/doc/${PF}/html \
+ || die "emake failed"
+}
+
+src_install() {
+ dogamesbin ${PN} || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r icons locales || die "doins failed"
+ doicon icons/${PN}.png
+ make_desktop_entry ${PN} Picpuz
+ dohtml -r doc/{userguide-en.html,images}
+ dodoc doc/{CHANGES,README,TRANSLATIONS}
+ prepgamesdirs
+}