summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-02-25 03:29:32 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-02-25 03:29:32 +0000
commitd34d8a46ad11597371fef3f91c5a420fcbcecbf7 (patch)
tree07880e519d5e61ace7375fa4657f6d6b688b43f7 /games-puzzle/londonlaw/londonlaw-0.2.1.ebuild
parentStable on x86; bug #123646 (diff)
downloadgentoo-2-d34d8a46ad11597371fef3f91c5a420fcbcecbf7.tar.gz
gentoo-2-d34d8a46ad11597371fef3f91c5a420fcbcecbf7.tar.bz2
gentoo-2-d34d8a46ad11597371fef3f91c5a420fcbcecbf7.zip
version bump
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'games-puzzle/londonlaw/londonlaw-0.2.1.ebuild')
-rw-r--r--games-puzzle/londonlaw/londonlaw-0.2.1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/games-puzzle/londonlaw/londonlaw-0.2.1.ebuild b/games-puzzle/londonlaw/londonlaw-0.2.1.ebuild
new file mode 100644
index 000000000000..d13a0e5f618e
--- /dev/null
+++ b/games-puzzle/londonlaw/londonlaw-0.2.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/londonlaw/londonlaw-0.2.1.ebuild,v 1.1 2006/02/25 03:29:32 mr_bones_ Exp $
+
+inherit eutils python games
+
+DESCRIPTION="Clone of the famous Scotland Yard board game"
+HOMEPAGE="http://www.eecs.umich.edu/~pelzlpj/londonlaw/"
+SRC_URI="http://www.eecs.umich.edu/~pelzlpj/londonlaw/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.3
+ >=dev-python/wxpython-2.4
+ dev-python/twisted"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-setup.py.patch"
+}
+
+src_install() {
+ python_version
+ python setup.py install \
+ --root="${D}" \
+ --prefix="${GAMES_PREFIX}" \
+ --install-lib=/usr/lib/python${PYVER}/site-packages \
+ --install-data="${GAMES_DATADIR}" \
+ || die "install failed"
+ dodoc ChangeLog README
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ einfo "To play, first start the server (london-server), then connect"
+ einfo "with the client (london-client). At least two players are"
+ einfo "needed to play."
+ echo
+}