summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-01-08 14:42:49 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-01-08 14:42:49 +0000
commitfb5aa85d4aae1283bb615cc6e1b04f77dbfc3ac7 (patch)
tree03d76ef50919453877cb5e1a8a24864c8f9e78fe /games-puzzle/fbg
parentStable on Alpha + IA64, bug 160463. (diff)
downloadgentoo-2-fb5aa85d4aae1283bb615cc6e1b04f77dbfc3ac7.tar.gz
gentoo-2-fb5aa85d4aae1283bb615cc6e1b04f77dbfc3ac7.tar.bz2
gentoo-2-fb5aa85d4aae1283bb615cc6e1b04f77dbfc3ac7.zip
HOMEPAGE update and install menu entry, bug #160209
(Portage version: 2.1.2_rc4-r6)
Diffstat (limited to 'games-puzzle/fbg')
-rw-r--r--games-puzzle/fbg/ChangeLog7
-rw-r--r--games-puzzle/fbg/fbg-0.9-r1.ebuild44
2 files changed, 23 insertions, 28 deletions
diff --git a/games-puzzle/fbg/ChangeLog b/games-puzzle/fbg/ChangeLog
index a237ce613a67..2acd4afcfd73 100644
--- a/games-puzzle/fbg/ChangeLog
+++ b/games-puzzle/fbg/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-puzzle/fbg
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/fbg/ChangeLog,v 1.7 2006/12/06 17:03:10 wolf31o2 Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/fbg/ChangeLog,v 1.8 2007/01/08 14:42:49 nyhm Exp $
+
+ 08 Jan 2007; Tristan Heaven <nyhm@gentoo.org> fbg-0.9-r1.ebuild:
+ HOMEPAGE update and install menu entry, bug #160209
06 Dec 2006; Chris Gianelloni <wolf31o2@gentoo.org> fbg-0.9-r1.ebuild:
Remove old virtual/x11 dependency.
diff --git a/games-puzzle/fbg/fbg-0.9-r1.ebuild b/games-puzzle/fbg/fbg-0.9-r1.ebuild
index 87eb4f1634f9..f4f14120e31c 100644
--- a/games-puzzle/fbg/fbg-0.9-r1.ebuild
+++ b/games-puzzle/fbg/fbg-0.9-r1.ebuild
@@ -1,32 +1,33 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/fbg/fbg-0.9-r1.ebuild,v 1.8 2006/12/06 17:03:10 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/fbg/fbg-0.9-r1.ebuild,v 1.9 2007/01/08 14:42:49 nyhm Exp $
-inherit games
+inherit eutils games
-DESCRIPTION="A tetris-clone written in OpenGL"
-HOMEPAGE="http://home.attbi.com/~furiousjay/code/fbg.html"
+DESCRIPTION="A Tetris clone written in OpenGL"
+HOMEPAGE="http://fbg.sourceforge.net/"
SRC_URI="mirror://sourceforge/fbg/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ppc amd64"
+KEYWORDS="amd64 ppc x86"
IUSE=""
-RDEPEND="virtual/opengl
+DEPEND="virtual/opengl
virtual/glu
- >=dev-games/physfs-0.1.7
- >=media-libs/libsdl-1.2.0
- >=media-libs/libmikmod-3.1.10"
-DEPEND="${RDEPEND}
+ dev-games/physfs
+ media-libs/libsdl
+ media-libs/libmikmod
x11-libs/libXt"
src_unpack() {
unpack ${A}
cd "${S}"
sed -i \
- -e "/FBGDATADIR=/s:\".*\":\"${GAMES_DATADIR}/${PN}\":" configure \
- || die "sed configure failed"
+ -e "/FBGDATADIR=/s:\".*\":\"${GAMES_DATADIR}/${PN}\":" \
+ -e '/^datadir=/d' \
+ configure \
+ || die "sed failed"
}
src_compile() {
@@ -35,18 +36,9 @@ src_compile() {
}
src_install() {
- make DESTDIR=${D} install || die "make install failed"
- dodoc README TODO AUTHORS
-
- # now clean up the install
- cd ${D}/${GAMES_PREFIX}
- rm -rf doc
- mv games ../share/
-
+ emake DESTDIR="${D}" install || die "emake install failed"
+ newicon startfbg/icon.xpm ${PN}.xpm
+ make_desktop_entry ${PN} "Falling Block Game" ${PN}.xpm
+ dodoc AUTHORS ChangeLog README TODO
prepgamesdirs
}
-
-pkg_postinst() {
- games_pkg_postinst
- einfo "less /usr/share/doc/${PF}/README.gz for play-instructions"
-}