summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-02-14 21:21:15 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-02-14 21:21:15 +0000
commit15f2d5356eced3fc040772c6177dca0d38ce0eb9 (patch)
treea111553f374d6a75fe52829ed547a223ed1dd707 /games-puzzle/candycrisis/candycrisis-1.0-r1.ebuild
parentVersion bump. (diff)
downloadgentoo-2-15f2d5356eced3fc040772c6177dca0d38ce0eb9.tar.gz
gentoo-2-15f2d5356eced3fc040772c6177dca0d38ce0eb9.tar.bz2
gentoo-2-15f2d5356eced3fc040772c6177dca0d38ce0eb9.zip
Respect CXXFLAGS; Save prefs to HOME
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-puzzle/candycrisis/candycrisis-1.0-r1.ebuild')
-rw-r--r--games-puzzle/candycrisis/candycrisis-1.0-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/games-puzzle/candycrisis/candycrisis-1.0-r1.ebuild b/games-puzzle/candycrisis/candycrisis-1.0-r1.ebuild
new file mode 100644
index 000000000000..907895ee0c33
--- /dev/null
+++ b/games-puzzle/candycrisis/candycrisis-1.0-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/candycrisis/candycrisis-1.0-r1.ebuild,v 1.1 2008/02/14 21:21:15 nyhm Exp $
+
+inherit eutils games
+
+DESCRIPTION="An exciting combination of pure action and puzzle gaming"
+HOMEPAGE="http://candycrisis.sourceforge.net/"
+SRC_URI="mirror://gentoo/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND="=media-libs/fmod-3*
+ media-libs/libsdl
+ media-libs/sdl-image"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/CandyCrisis/Source
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ sed -i \
+ -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}/:g" \
+ main.cpp \
+ || die "sed failed"
+}
+
+src_install() {
+ dogamesbin ${PN} || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins ../CandyCrisisResources/* || die "doins failed"
+ newicon ../CandyCrisisResources/PICT_10000.png ${PN}.png
+ make_desktop_entry ${PN} CandyCrisis
+ dodoc ../CandyCrisisReadMe.rtf
+ prepgamesdirs
+}