summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-10 04:51:18 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-10 04:51:18 +0000
commit24c1a9a6dc8872813b197a1376ec8c5c92452d43 (patch)
treea87738aaa631c0e250846872a612749aa9d2ef29 /games-kids/gcompris
parentrepoman: fix leading whitespace (diff)
downloadgentoo-2-24c1a9a6dc8872813b197a1376ec8c5c92452d43.tar.gz
gentoo-2-24c1a9a6dc8872813b197a1376ec8c5c92452d43.tar.bz2
gentoo-2-24c1a9a6dc8872813b197a1376ec8c5c92452d43.zip
hello kiddies
Diffstat (limited to 'games-kids/gcompris')
-rw-r--r--games-kids/gcompris/ChangeLog24
-rw-r--r--games-kids/gcompris/Manifest5
-rw-r--r--games-kids/gcompris/files/digest-gcompris-3.11
-rw-r--r--games-kids/gcompris/files/digest-gcompris-3.21
-rw-r--r--games-kids/gcompris/gcompris-3.1.ebuild60
-rw-r--r--games-kids/gcompris/gcompris-3.2.ebuild60
6 files changed, 151 insertions, 0 deletions
diff --git a/games-kids/gcompris/ChangeLog b/games-kids/gcompris/ChangeLog
new file mode 100644
index 000000000000..49ddd311ef1b
--- /dev/null
+++ b/games-kids/gcompris/ChangeLog
@@ -0,0 +1,24 @@
+# ChangeLog for app-games/gcompris
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-kids/gcompris/ChangeLog,v 1.1 2003/09/10 04:51:18 vapier Exp $
+
+*gcompris-3.2 (18 Aug 2003)
+
+ 18 Aug 2003; Michael Sterrett <msterret@gentoo.org> gcompris-3.2.ebuild:
+ version bump (bug 26611)
+
+ 01 Jul 2003; Michael Sterrett <msterret@gentoo.org> gcompris-3.1.ebuild:
+ use sed -i
+
+*gcompris-3.1 (21 Jun 2003)
+
+ 23 Jun 2003; Mike Frysinger <vapier@gentoo.org> :
+ Version bumped + games.eclass support. Closes #14911 #15716 #21355.
+
+*gcompris-1.1.0.ebuild (31 julio 2002)
+
+ 18 Oct 2002; Daniel Ahlberg <aliz@gentoo.org> gcompris-1.1.0.ebuild :
+ Updated to mirror://sourceforge in SRC_URI.
+
+ 31 Jul 2002; J. Alberto Suárez L. <bass@gentoo.org> gcompris-1.1.0.ebuild :
+ First relase.
diff --git a/games-kids/gcompris/Manifest b/games-kids/gcompris/Manifest
new file mode 100644
index 000000000000..85b0446fa0fe
--- /dev/null
+++ b/games-kids/gcompris/Manifest
@@ -0,0 +1,5 @@
+MD5 0346bcf761b5cad47d9ce1289da0305a files/digest-gcompris-3.2 63
+MD5 ce34833a98967ab510f2b14908536746 files/digest-gcompris-3.1 66
+MD5 0e2dfadb4de246304d0751e44c64d652 ChangeLog 847
+MD5 d9011ac118b57cec458073383db0f14a gcompris-3.1.ebuild 1647
+MD5 4b04da717813935ea8fb66b4cf5910b2 gcompris-3.2.ebuild 1681
diff --git a/games-kids/gcompris/files/digest-gcompris-3.1 b/games-kids/gcompris/files/digest-gcompris-3.1
new file mode 100644
index 000000000000..bf5e6ed2acb2
--- /dev/null
+++ b/games-kids/gcompris/files/digest-gcompris-3.1
@@ -0,0 +1 @@
+MD5 9eb8f594a19e5c3f54ec8df84aacb146 gcompris-3.1.tar.gz 23354644
diff --git a/games-kids/gcompris/files/digest-gcompris-3.2 b/games-kids/gcompris/files/digest-gcompris-3.2
new file mode 100644
index 000000000000..5076b2fe0582
--- /dev/null
+++ b/games-kids/gcompris/files/digest-gcompris-3.2
@@ -0,0 +1 @@
+MD5 3c7d52560b930a00c4f1e097e908cfb4 gcompris-3.2.tgz 23412118
diff --git a/games-kids/gcompris/gcompris-3.1.ebuild b/games-kids/gcompris/gcompris-3.1.ebuild
new file mode 100644
index 000000000000..00806adb109a
--- /dev/null
+++ b/games-kids/gcompris/gcompris-3.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: initial version by Ron Simpkin doobedoobedo@quake3world.com
+
+inherit games
+
+DESCRIPTION="full featured educational application for children from 3 to 10"
+HOMEPAGE="http://ofset.sourceforge.net/gcompris/"
+SRC_URI="mirror://sourceforge/gcompris/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="oggvorbis nls python"
+
+DEPEND="virtual/x11
+ >=sys-apps/sed-4
+ >=gnome-base/libgnome-1.96.0
+ >=gnome-base/libgnomeui-1.96.0
+ >=gnome-base/libgnomecanvas-2.0.2
+ >=dev-libs/glib-2.0
+ =x11-libs/gtk+-2*
+ dev-libs/libxml2
+ app-games/gnuchess
+ sys-apps/texinfo
+ app-text/texi2html
+ python? ( dev-lang/python )
+ oggvorbis? ( media-libs/libogg
+ media-libs/libvorbis
+ media-libs/libao )"
+
+src_compile() {
+ export GNUCHESS="${GAMES_BINDIR}/gnuchess"
+
+ local myconf=""
+ use oggvorbis && myconf="${myconf} --with-ogg=/usr --with-vorbis=/usr --with-ao=/usr"
+ use python && myconf="${myconf} --with-python=`which python`"
+ egamesconf ${myconf} || die
+
+ for f in `grep -Rl /usr/games/share *` ; do
+ sed -i \
+ -e "s:${GAMES_PREFIX}/share/gnome:/usr/share/gnome:g" \
+ -e "s:${GAMES_PREFIX}/share:${GAMES_DATADIR}:g" \
+ ${f} || die "sed ${f} failed"
+ done
+
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR=${D} || die
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+ mv ${D}/${GAMES_DATADIR}/{locale,gnome,pixmaps} ${D}/usr/share/
+ if [ ! `use nls` ] ; then
+ rm -rf ${D}/usr/share/locale
+ cd ${D}/${GAMES_DATADIR}/gcompris/boards/sounds
+ rm -rf `find -type d -maxdepth 1 -mindepth 1 ! -name en`
+ fi
+ prepgamesdirs
+}
diff --git a/games-kids/gcompris/gcompris-3.2.ebuild b/games-kids/gcompris/gcompris-3.2.ebuild
new file mode 100644
index 000000000000..c2a15798d495
--- /dev/null
+++ b/games-kids/gcompris/gcompris-3.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: initial version by Ron Simpkin doobedoobedo@quake3world.com
+
+inherit games
+
+DESCRIPTION="full featured educational application for children from 3 to 10"
+HOMEPAGE="http://ofset.sourceforge.net/gcompris/"
+SRC_URI="mirror://sourceforge/gcompris/${P}.tgz"
+
+LICENSE="GPL-2"
+KEYWORDS="x86"
+SLOT="0"
+IUSE="oggvorbis nls python"
+
+DEPEND="virtual/x11
+ >=sys-apps/sed-4
+ >=gnome-base/libgnome-1.96.0
+ >=gnome-base/libgnomeui-1.96.0
+ >=gnome-base/libgnomecanvas-2.0.2
+ >=dev-libs/glib-2.0
+ =x11-libs/gtk+-2*
+ dev-libs/libxml2
+ app-games/gnuchess
+ sys-apps/texinfo
+ app-text/texi2html
+ python? ( dev-lang/python )
+ oggvorbis? ( media-libs/libogg
+ media-libs/libvorbis
+ media-libs/libao )"
+
+src_compile() {
+ export GNUCHESS="${GAMES_BINDIR}/gnuchess"
+
+ local myconf=""
+ use oggvorbis && myconf="${myconf} --with-ogg=/usr --with-vorbis=/usr --with-ao=/usr"
+ use python && myconf="${myconf} --with-python=`which python`"
+ egamesconf ${myconf} || die
+
+ for f in `grep -Rl /usr/games/share *` ; do
+ sed -i \
+ -e "s:${GAMES_PREFIX}/share/gnome:/usr/share/gnome:g" \
+ -e "s:${GAMES_PREFIX}/share:${GAMES_DATADIR}:g" \
+ ${f} || die "sed ${f} failed"
+ done
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+ mv ${D}/${GAMES_DATADIR}/{locale,gnome,pixmaps} ${D}/usr/share/
+ if [ ! `use nls` ] ; then
+ rm -rf ${D}/usr/share/locale
+ cd ${D}/${GAMES_DATADIR}/gcompris/boards/sounds
+ rm -rf `find -type d -maxdepth 1 -mindepth 1 ! -name en`
+ fi
+ prepgamesdirs
+}