summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-07-02 17:28:03 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-07-02 17:28:03 +0000
commitfc2a715ebc850d71c302b638a3200f6e8f87cdde (patch)
tree49278c901cef3a48f468961d214fdcb9cf7055f4 /games-fps
parentUse.mask gnokii as nobody has the hardware (diff)
downloadgentoo-2-fc2a715ebc850d71c302b638a3200f6e8f87cdde.tar.gz
gentoo-2-fc2a715ebc850d71c302b638a3200f6e8f87cdde.tar.bz2
gentoo-2-fc2a715ebc850d71c302b638a3200f6e8f87cdde.zip
remove need for an executable stack
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/industri/ChangeLog6
-rw-r--r--games-fps/industri/files/industri-1.01-exec-stack.patch36
-rw-r--r--games-fps/industri/industri-1.01.ebuild9
3 files changed, 46 insertions, 5 deletions
diff --git a/games-fps/industri/ChangeLog b/games-fps/industri/ChangeLog
index 61a4d853bdb9..cdce4cf29978 100644
--- a/games-fps/industri/ChangeLog
+++ b/games-fps/industri/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-fps/industri
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/industri/ChangeLog,v 1.8 2007/02/21 23:40:37 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/industri/ChangeLog,v 1.9 2007/07/02 17:28:03 nyhm Exp $
+
+ 02 Jul 2007; Tristan Heaven <nyhm@gentoo.org>
+ +files/industri-1.01-exec-stack.patch, industri-1.01.ebuild:
+ remove need for an executable stack
21 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/games-fps/industri/files/industri-1.01-exec-stack.patch b/games-fps/industri/files/industri-1.01-exec-stack.patch
new file mode 100644
index 000000000000..bc74e951fe6a
--- /dev/null
+++ b/games-fps/industri/files/industri-1.01-exec-stack.patch
@@ -0,0 +1,36 @@
+--- math.s
++++ math.s
+@@ -416,3 +416,6 @@
+ call C(BOPS_Error)
+
+ #endif // id386
++#if defined(__linux__) && defined(__ELF__)
++.section .note.GNU-stack,"",%progbits
++#endif
+--- snd_mixa.s
++++ snd_mixa.s
+@@ -216,3 +216,6 @@
+
+ #endif // id386
+
++#if defined(__linux__) && defined(__ELF__)
++.section .note.GNU-stack,"",%progbits
++#endif
+--- sys_dosa.s
++++ sys_dosa.s
+@@ -93,3 +93,6 @@
+
+ ret
+
++#if defined(__linux__) && defined(__ELF__)
++.section .note.GNU-stack,"",%progbits
++#endif
+--- worlda.s
++++ worlda.s
+@@ -142,3 +142,6 @@
+
+ #endif // id386
+
++#if defined(__linux__) && defined(__ELF__)
++.section .note.GNU-stack,"",%progbits
++#endif
diff --git a/games-fps/industri/industri-1.01.ebuild b/games-fps/industri/industri-1.01.ebuild
index 03d6dcb7dcfb..83201d84e508 100644
--- a/games-fps/industri/industri-1.01.ebuild
+++ b/games-fps/industri/industri-1.01.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/industri/industri-1.01.ebuild,v 1.13 2007/01/11 21:43:06 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/industri/industri-1.01.ebuild,v 1.14 2007/07/02 17:28:03 nyhm Exp $
-inherit toolchain-funcs games
+inherit eutils toolchain-funcs games
DESCRIPTION="Quake/Tenebrae based, single player game"
HOMEPAGE="http://industri.sourceforge.net/"
@@ -21,8 +21,7 @@ RDEPEND="virtual/opengl
x11-libs/libX11
x11-libs/libXxf86vm
media-libs/libpng
- cdinstall? ( games-fps/quake1-data )
- sys-libs/zlib"
+ cdinstall? ( games-fps/quake1-data )"
DEPEND="${RDEPEND}
x11-proto/xf86dgaproto
x11-proto/xextproto
@@ -49,6 +48,8 @@ src_unpack() {
|| die "sed failed"
fi
done
+
+ epatch "${FILESDIR}"/${P}-exec-stack.patch
}
src_compile() {