summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-10-08 12:55:49 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-10-08 12:55:49 +0000
commitc54631ea354673f6a87e64d33acb86a44ef424c3 (patch)
treef50b84515173559c23c01d0fbf3ee6f50c80bbbb /games-fps
parentVersion bump. (diff)
downloadgentoo-2-c54631ea354673f6a87e64d33acb86a44ef424c3.tar.gz
gentoo-2-c54631ea354673f6a87e64d33acb86a44ef424c3.tar.bz2
gentoo-2-c54631ea354673f6a87e64d33acb86a44ef424c3.zip
Respect LDFLAGS. Bug #336000
(Portage version: 2.1.9.13/cvs/Linux i686)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/duke3d/ChangeLog6
-rw-r--r--games-fps/duke3d/duke3d-20040817-r2.ebuild5
-rw-r--r--games-fps/duke3d/files/duke3d-20040817-ldflags.patch66
3 files changed, 74 insertions, 3 deletions
diff --git a/games-fps/duke3d/ChangeLog b/games-fps/duke3d/ChangeLog
index 9e838732deab..e7e98bd2dc30 100644
--- a/games-fps/duke3d/ChangeLog
+++ b/games-fps/duke3d/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-fps/duke3d
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/duke3d/ChangeLog,v 1.35 2010/01/25 23:38:41 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/duke3d/ChangeLog,v 1.36 2010/10/08 12:55:49 tupone Exp $
+
+ 08 Oct 2010; Tupone Alfredo <tupone@gentoo.org> duke3d-20040817-r2.ebuild,
+ +files/duke3d-20040817-ldflags.patch:
+ Respect LDFLAGS. Bug #336000 by flameeyes@gentoo.org
25 Jan 2010; Jeroen Roovers <jer@gentoo.org> duke3d-20040817-r2.ebuild:
Stable for HPPA (bug #286423).
diff --git a/games-fps/duke3d/duke3d-20040817-r2.ebuild b/games-fps/duke3d/duke3d-20040817-r2.ebuild
index 922fe3207528..998b411dd2a7 100644
--- a/games-fps/duke3d/duke3d-20040817-r2.ebuild
+++ b/games-fps/duke3d/duke3d-20040817-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/duke3d/duke3d-20040817-r2.ebuild,v 1.10 2010/01/25 23:38:41 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/duke3d/duke3d-20040817-r2.ebuild,v 1.11 2010/10/08 12:55:49 tupone Exp $
EAPI=2
fromcvs=0
@@ -79,7 +79,8 @@ src_prepare() {
"${FILESDIR}/${PV}-gcc34.patch" \
"${FILESDIR}"/${P}-gcc4.patch \
"${FILESDIR}"/${P}-noinline.patch \
- "${FILESDIR}"/${P}-as-needed.patch
+ "${FILESDIR}"/${P}-as-needed.patch \
+ "${FILESDIR}"/${P}-ldflags.patch
sed -i \
-e "/^use_opengl := / s:=.*:= $(use_tf opengl):" \
-e "/^use_physfs := / s:=.*:= false:" \
diff --git a/games-fps/duke3d/files/duke3d-20040817-ldflags.patch b/games-fps/duke3d/files/duke3d-20040817-ldflags.patch
new file mode 100644
index 000000000000..79179e663805
--- /dev/null
+++ b/games-fps/duke3d/files/duke3d-20040817-ldflags.patch
@@ -0,0 +1,66 @@
+--- source/buildengine/Makefile.old 2010-10-08 14:32:05.000000000 +0200
++++ source/buildengine/Makefile 2010-10-08 14:35:10.000000000 +0200
+@@ -73,7 +73,7 @@
+ endif
+
+ ifeq ($(strip $(solaris)),true)
+- LDFLAGS += -lsocket -lnsl
++ LIBS += -lsocket -lnsl
+ CFLAGS += -DPLATFORM_SOLARIS
+ endif
+
+@@ -129,7 +129,7 @@
+
+ ifeq ($(strip $(macosx)),true)
+ CFLAGS += -DPLATFORM_MACOSX=1 -faltivec -falign-loops=32 -falign-functions=32
+- LDFLAGS += -framework AppKit -lSDL -lSDLmain
++ LIBS += -framework AppKit -lSDL -lSDLmain
+ endif
+
+ ifeq ($(strip $(useopengl)),true)
+@@ -146,7 +146,7 @@
+
+ ifeq ($(strip $(usephysfs)),true)
+ CFLAGS += -DUSE_PHYSICSFS
+- LDFLAGS += -lphysfs
++ LIBS += -lphysfs
+ endif
+
+ ifeq ($(strip $(usedlls)),true)
+@@ -236,17 +236,17 @@
+
+ ifeq ($(strip $(usedlls)),true)
+ $(ENGINEDLL) : $(ENGINEOBJS)
+- $(LINKER) -shared -o $(ENGINEDLL) $(LDFLAGS) $(ENGINEOBJS) $(LDLIBS)
++ $(LINKER) -shared -o $(ENGINEDLL) $(LIBS) $(ENGINEOBJS) $(LDLIBS)
+
+ $(NETDLL) : $(NETOBJS)
+- $(LINKER) -shared -o $(NETDLL) $(LDFLAGS) $(NETOBJS) $(LDLIBS)
++ $(LINKER) -shared -o $(NETDLL) $(LIBS) $(NETOBJS) $(LDLIBS)
+ endif
+
+ $(GAMEEXE) : $(ENGINEDLL) $(NETDLL) $(GAMEOBJS) $(PERLOBJS)
+- $(LINKER) -o $(GAMEEXE) $(LDFLAGS) $(PERLOBJS) $(GAMEOBJS) $(LDPERL) $(LDLIBS) $(ENGINEDLL) $(NETDLL)
++ $(LINKER) $(LDFLAGS) -o $(GAMEEXE) $(LIBS) $(PERLOBJS) $(GAMEOBJS) $(LDPERL) $(LDLIBS) $(ENGINEDLL) $(NETDLL)
+
+ $(BUILDEXE) : $(ENGINEDLL) $(BUILDOBJS)
+- $(LINKER) -o $(BUILDEXE) $(LDFLAGS) $(BUILDOBJS) $(LDLIBS) $(ENGINEDLL)
++ $(LINKER) $(LDFLAGS) -o $(BUILDEXE) $(LIBS) $(BUILDOBJS) $(LDLIBS) $(ENGINEDLL)
+
+ listclean:
+ @echo "A 'make clean' would remove" $(CLEANUP)
+--- source/Makefile.old 2010-10-08 14:35:54.000000000 +0200
++++ source/Makefile 2010-10-08 14:37:34.000000000 +0200
+@@ -152,10 +152,10 @@
+ sounds.o \
+ dukemusc.o \
+ audiolib/audiolib.a
+- $(CC) $^ $(BUILDOBJS) $(LDLIBS) -o $@
++ $(CC) $(LDFLAGS) $^ $(BUILDOBJS) $(LDLIBS) -o $@
+
+ build: astub.o
+- $(CC) $^ $(BUILDOBJS) buildengine/build.o $(LDLIBS) -o $@
++ $(CC) $(LDFLAGS) $^ $(BUILDOBJS) buildengine/build.o $(LDLIBS) -o $@
+
+ clean:
+ $(MAKE) -C audiolib clean