summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2007-07-08 22:36:21 +0000
committerAlfredo Tupone <tupone@gentoo.org>2007-07-08 22:36:21 +0000
commita365784ef7eb9596bc6b13f372f141ac76465870 (patch)
tree105837e59549587a7fda5138a4962b75dcad1d51 /games-fps
parentMake RDEPEND on setuptools-friendly versions of elementree and cheetah for Py... (diff)
downloadgentoo-2-a365784ef7eb9596bc6b13f372f141ac76465870.tar.gz
gentoo-2-a365784ef7eb9596bc6b13f372f141ac76465870.tar.bz2
gentoo-2-a365784ef7eb9596bc6b13f372f141ac76465870.zip
Build for amd64. Bug #165523
(Portage version: 2.1.2.9)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/quakeforge/ChangeLog8
-rw-r--r--games-fps/quakeforge/files/digest-quakeforge-0.5.5-r23
-rw-r--r--games-fps/quakeforge/files/quakeforge-0.5.5-amd64.patch14
-rw-r--r--games-fps/quakeforge/quakeforge-0.5.5-r2.ebuild133
4 files changed, 157 insertions, 1 deletions
diff --git a/games-fps/quakeforge/ChangeLog b/games-fps/quakeforge/ChangeLog
index 3f8a96efe355..ddc06ab34dae 100644
--- a/games-fps/quakeforge/ChangeLog
+++ b/games-fps/quakeforge/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-fps/quakeforge
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quakeforge/ChangeLog,v 1.16 2007/03/12 15:05:00 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quakeforge/ChangeLog,v 1.17 2007/07/08 22:36:21 tupone Exp $
+
+*quakeforge-0.5.5-r2 (08 Jul 2007)
+
+ 08 Jul 2007; Tupone Alfredo <tupone@gentoo.org>
+ +files/quakeforge-0.5.5-amd64.patch, +quakeforge-0.5.5-r2.ebuild:
+ Build for amd64. Bug #165523 by Luke-Jr
12 Mar 2007; Marius Mauch <genone@gentoo.org> quakeforge-0.5.5.ebuild,
quakeforge-0.5.5-r1.ebuild:
diff --git a/games-fps/quakeforge/files/digest-quakeforge-0.5.5-r2 b/games-fps/quakeforge/files/digest-quakeforge-0.5.5-r2
new file mode 100644
index 000000000000..e2b268f899bc
--- /dev/null
+++ b/games-fps/quakeforge/files/digest-quakeforge-0.5.5-r2
@@ -0,0 +1,3 @@
+MD5 b750b491ce24135f1a4a1360029de3a2 quakeforge-0.5.5.tar.bz2 1954072
+RMD160 1caf8d7b272c9e588708ac39841d46aac2c5df79 quakeforge-0.5.5.tar.bz2 1954072
+SHA256 9ff29340f571fc26d19992a32f58e767e1b811248688f383083bc2ccb263ec6a quakeforge-0.5.5.tar.bz2 1954072
diff --git a/games-fps/quakeforge/files/quakeforge-0.5.5-amd64.patch b/games-fps/quakeforge/files/quakeforge-0.5.5-amd64.patch
new file mode 100644
index 000000000000..ed33e45343fc
--- /dev/null
+++ b/games-fps/quakeforge/files/quakeforge-0.5.5-amd64.patch
@@ -0,0 +1,14 @@
+diff -Naur quakeforge-0.5.5/libs/video/renderer/sw/Makefile.in quakeforge-0.5.5-modified/libs/video/renderer/sw/Makefile.in
+--- quakeforge-0.5.5/libs/video/renderer/sw/Makefile.in 2004-05-02 16:52:12.000000000 -0400
++++ quakeforge-0.5.5-modified/libs/video/renderer/sw/Makefile.in 2007-06-24 22:29:59.000000000 -0400
+@@ -403,8 +403,8 @@
+ target_vendor = @target_vendor@
+ vid_libs = @vid_libs@
+ AUTOMAKE_OPTIONS = foreign
+-AM_CFLAGS = @PREFER_NON_PIC@
+-AM_CCASFLAGS = @PREFER_NON_PIC@
++AM_CFLAGS = -fPIC
++AM_CCASFLAGS = -fPIC
+ INCLUDES = -I$(top_srcdir)/include
+ @ASM_ARCH_FALSE@asm =
+ @ASM_ARCH_TRUE@asm = libasm.la
diff --git a/games-fps/quakeforge/quakeforge-0.5.5-r2.ebuild b/games-fps/quakeforge/quakeforge-0.5.5-r2.ebuild
new file mode 100644
index 000000000000..e333c5e1f25a
--- /dev/null
+++ b/games-fps/quakeforge/quakeforge-0.5.5-r2.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quakeforge/quakeforge-0.5.5-r2.ebuild,v 1.1 2007/07/08 22:36:21 tupone Exp $
+
+inherit eutils autotools games
+
+DESCRIPTION="A new 3d engine based off of id Softwares's legendary Quake and QuakeWorld game engine"
+HOMEPAGE="http://www.quakeforge.net/"
+SRC_URI="mirror://sourceforge/quake/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="cdinstall debug 3dfx fbcon opengl sdl svga X ncurses vorbis zlib ipv6 xv dga alsa oss"
+RESTRICT="userpriv"
+
+RDEPEND="3dfx? ( media-libs/glide-v3 )
+ opengl? ( virtual/opengl )
+ sdl? ( media-libs/libsdl )
+ svga? ( media-libs/svgalib )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXxf86vm )
+ ncurses? ( sys-libs/ncurses )
+ vorbis? ( media-libs/libogg media-libs/libvorbis )
+ zlib? ( sys-libs/zlib )
+ xv? (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXxf86vm )
+ dga? ( x11-libs/libXxf86dga )
+ alsa? ( media-libs/alsa-lib )"
+DEPEND="${RDEPEND}
+ cdinstall? ( games-fps/quake1-data )
+ sys-devel/bison
+ sys-devel/flex"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PV}"-ipv6.patch \
+ "${FILESDIR}/${P}"-gcc41.patch \
+ "${FILESDIR}/${P}"-keys.patch \
+ "${FILESDIR}/${P}"-amd64.patch
+}
+
+src_compile() {
+ #i should do this at some point :x ... i guess if you disable all shared stuff
+ #and enable all the static options explicitly, static works ... (or so ive been told)
+ #if ! use static ; then
+ # myconf="${myconf} --enable-shared=yes --enable-static=no"
+ #else
+ # myconf="${myconf} --enable-shared=no --enable-static=yes"
+ #fi
+
+ local debugopts
+ use debug \
+ && debugopts="--enable-debug --disable-optimize --enable-profile" \
+ || debugopts="--disable-debug --disable-profile"
+
+ local clients=${QF_CLIENTS}
+ use 3dfx && clients="${clients},3dfx"
+ use fbcon && clients="${clients},fbdev"
+ use opengl && clients="${clients},glx"
+ use sdl && clients="${clients},sdl,sdl32"
+ use sdl && use opengl && clients="${clients},sgl"
+ use svga && clients="${clients},svga"
+ use X && clients="${clients},x11"
+ use X && use opengl && clients="${clients},wgl"
+ [ "${clients:0:1}" == "," ] && clients=${clients:1}
+
+ local servers=${QF_SERVERS:-master,nq,qw,qtv}
+
+ local tools=${QF_TOOLS:-all}
+
+ local svgaconf # use old school way for broken conf opts
+ use svga \
+ && svgaconf="--with-svga=/usr" \
+ || svgaconf="--without-svga"
+
+ addpredict "$(games_get_libdir)"
+ egamesconf \
+ $(use_enable ncurses curses) \
+ $(use_enable vorbis) \
+ $(use_enable zlib) \
+ $(use_with ipv6) \
+ $(use_with fbcon fbdev) \
+ ${svgaconf} \
+ $(use_with X x) \
+ $(use_enable xv vidmode) \
+ $(use_enable dga) \
+ $(use_enable sdl) \
+ --disable-xmms \
+ $(use_enable alsa) \
+ $(use_enable oss) \
+ --enable-sound \
+ --disable-optimize \
+ ${debugopts} \
+ --with-global-cfg="${GAMES_SYSCONFDIR}"/quakeforge.conf \
+ --with-sharepath="${GAMES_DATADIR}"/quake1 \
+ --with-clients=${clients} \
+ --with-servers=${servers} \
+ --with-tools=${tools} \
+ || die
+ make || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ mv "${D}/${GAMES_PREFIX}"/include "${D}"/usr/
+ dodoc ChangeLog NEWS TODO doc/*
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ # same warning used in quake1 / quakeforge / nprquake-sdl
+ games_pkg_postinst
+ echo
+ elog "Before you can play, you must make sure"
+ elog "${PN} can find your Quake .pak files"
+ elog
+ elog "You have 2 choices to do this"
+ elog "1 Copy pak*.pak files to ${GAMES_DATADIR}/quake1/id1"
+ elog "2 Symlink pak*.pak files in ${GAMES_DATADIR}/quake1/id1"
+ elog
+ elog "Example:"
+ elog "my pak*.pak files are in /mnt/secondary/Games/Quake/Id1/"
+ elog "ln -s /mnt/secondary/Games/Quake/Id1/pak0.pak ${GAMES_DATADIR}/quake1/id1/pak0.pak"
+ elog
+ elog "You only need pak0.pak to play the demo version,"
+ elog "the others are needed for registered version"
+}