summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-03-30 01:31:27 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-03-30 01:31:27 +0000
commit86cccc1377f7a99311ba146cc9fc1b6941aa4b9b (patch)
tree457fe640df20c78d8fc4a0cbed7d89aac910d680 /games-fps
parentFixed fwcutter version. (diff)
downloadgentoo-2-86cccc1377f7a99311ba146cc9fc1b6941aa4b9b.tar.gz
gentoo-2-86cccc1377f7a99311ba146cc9fc1b6941aa4b9b.tar.bz2
gentoo-2-86cccc1377f7a99311ba146cc9fc1b6941aa4b9b.zip
Cleaned out some older ebuilds.
(Portage version: 2.1_pre6-r2)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/alephone/ChangeLog6
-rw-r--r--games-fps/alephone/alephone-20040417.ebuild46
-rw-r--r--games-fps/alephone/files/20040417-gcc34.patch24
-rw-r--r--games-fps/alephone/files/digest-alephone-200404171
4 files changed, 5 insertions, 72 deletions
diff --git a/games-fps/alephone/ChangeLog b/games-fps/alephone/ChangeLog
index 6a46a5a6f438..ea8f63342484 100644
--- a/games-fps/alephone/ChangeLog
+++ b/games-fps/alephone/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-fps/alephone
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/alephone/ChangeLog,v 1.7 2006/03/20 22:07:29 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/alephone/ChangeLog,v 1.8 2006/03/30 01:31:27 wolf31o2 Exp $
+
+ 30 Mar 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+ -files/20040417-gcc34.patch, -alephone-20040417.ebuild:
+ Cleaned out some older ebuilds.
20 Mar 2006; Chris Gianelloni <wolf31o2@gentoo.org>
alephone-20051119.ebuild:
diff --git a/games-fps/alephone/alephone-20040417.ebuild b/games-fps/alephone/alephone-20040417.ebuild
deleted file mode 100644
index d2374bfdcc8d..000000000000
--- a/games-fps/alephone/alephone-20040417.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/alephone/alephone-20040417.ebuild,v 1.3 2005/09/26 18:10:42 wolf31o2 Exp $
-
-inherit eutils games
-
-DESCRIPTION="An enhanced version of the classic Mac game, Marathon"
-HOMEPAGE="http://source.bungie.org/"
-SRC_URI="mirror://sourceforge/marathon/aleph-${PV}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 x86"
-IUSE="opengl lua"
-
-DEPEND="opengl? ( virtual/opengl )
- media-libs/libsdl
- media-libs/sdl-image
- media-libs/sdl-net
- lua? ( dev-lang/lua )"
-
-S=${WORKDIR}/aleph_${PV}
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch "${FILESDIR}"/${PV}-gcc34.patch
- NO_CONFIGURE=bah ./autogen.sh || die "autogen failed"
-}
-
-src_compile() {
- egamesconf $(use_enable opengl) || die
- if ! use lua ; then
- # stupid configure script doesnt have an option
- sed -i '/HAVE_LUA/d' config.h || die "sed HAVE_LUA"
- sed -i '/^LIBS/s:-llua -llualib::' $(find -name Makefile) || die "sed -llua"
- fi
- emake || die
-}
-
-src_install() {
- make DESTDIR="${D}" install || die
- dodoc AUTHORS README docs/Cheat_Codes
- dohtml docs/MML.html
- prepgamesdirs
-}
diff --git a/games-fps/alephone/files/20040417-gcc34.patch b/games-fps/alephone/files/20040417-gcc34.patch
deleted file mode 100644
index a6a96fac5748..000000000000
--- a/games-fps/alephone/files/20040417-gcc34.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff -Naur aleph_20040417.orig/Source_Files/GameWorld/TickBasedCircularQueue.h aleph_20040417.new/Source_Files/GameWorld/TickBasedCircularQueue.h
---- aleph_20040417.orig/Source_Files/GameWorld/TickBasedCircularQueue.h 2005-01-02 18:33:55.919198281 +0000
-+++ aleph_20040417.new/Source_Files/GameWorld/TickBasedCircularQueue.h 2005-01-02 18:36:07.587086057 +0000
-@@ -166,7 +166,7 @@
- class MutableElementsTickBasedCircularQueue : public ConcreteTickBasedCircularQueue<tValueType> {
- public:
- MutableElementsTickBasedCircularQueue(int inBufferCapacity) : ConcreteTickBasedCircularQueue<tValueType>(inBufferCapacity) {}
-- tValueType& at(int32 inTick) { return elementForTick(inTick); }
-+ tValueType& at(int32 inTick) { return this->elementForTick(inTick); }
- tValueType& operator [](int32 inTick) { return at(inTick); }
- };
-
-diff -Naur aleph_20040417.orig/Source_Files/ModelView/Dim3_Loader.cpp aleph_20040417.new/Source_Files/ModelView/Dim3_Loader.cpp
---- aleph_20040417.orig/Source_Files/ModelView/Dim3_Loader.cpp 2005-01-02 18:33:55.886203321 +0000
-+++ aleph_20040417.new/Source_Files/ModelView/Dim3_Loader.cpp 2005-01-02 18:34:29.291100734 +0000
-@@ -225,7 +225,7 @@
- {
- size_t NumBones = Model.Bones.size();
- BoneIndices.resize(NumBones);
-- fill(BoneIndices.begin(),BoneIndices.end(),UNONE); // No bones listed -- yet
-+ fill(BoneIndices.begin(),BoneIndices.end(),(size_t) UNONE); // No bones listed -- yet
- vector<Model3D_Bone> SortedBones(NumBones);
- vector<size_t> BoneStack(NumBones);
- vector<bool> BonesUsed(NumBones);
diff --git a/games-fps/alephone/files/digest-alephone-20040417 b/games-fps/alephone/files/digest-alephone-20040417
deleted file mode 100644
index 10582c22ea9c..000000000000
--- a/games-fps/alephone/files/digest-alephone-20040417
+++ /dev/null
@@ -1 +0,0 @@
-MD5 331d36c73672984df6ab5cd373552b22 aleph-20040417.tar.bz2 2293780