summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-07-05 15:57:37 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-07-05 15:57:37 +0000
commitd9939efbba9427114ad8c06e4afa93a44cb5f92b (patch)
tree2705296a3709e9142c9426302a55fa02ef1e109a /games-fps/warsow
parentKeyworded ~x86-fbsd. (diff)
downloadgentoo-2-d9939efbba9427114ad8c06e4afa93a44cb5f92b.tar.gz
gentoo-2-d9939efbba9427114ad8c06e4afa93a44cb5f92b.tar.bz2
gentoo-2-d9939efbba9427114ad8c06e4afa93a44cb5f92b.zip
Install BattlEye, bug #184305
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'games-fps/warsow')
-rw-r--r--games-fps/warsow/ChangeLog7
-rw-r--r--games-fps/warsow/files/digest-warsow-0.3.1-r115
-rw-r--r--games-fps/warsow/warsow-0.3.1-r1.ebuild128
3 files changed, 149 insertions, 1 deletions
diff --git a/games-fps/warsow/ChangeLog b/games-fps/warsow/ChangeLog
index 0336c6dbf34b..b061c544e3a8 100644
--- a/games-fps/warsow/ChangeLog
+++ b/games-fps/warsow/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-fps/warsow
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/warsow/ChangeLog,v 1.6 2007/06/29 22:33:34 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/warsow/ChangeLog,v 1.7 2007/07/05 15:57:37 nyhm Exp $
+
+*warsow-0.3.1-r1 (05 Jul 2007)
+
+ 05 Jul 2007; Tristan Heaven <nyhm@gentoo.org> +warsow-0.3.1-r1.ebuild:
+ Install BattlEye, bug #184305
*warsow-0.3.1 (29 Jun 2007)
diff --git a/games-fps/warsow/files/digest-warsow-0.3.1-r1 b/games-fps/warsow/files/digest-warsow-0.3.1-r1
new file mode 100644
index 000000000000..85537f92d180
--- /dev/null
+++ b/games-fps/warsow/files/digest-warsow-0.3.1-r1
@@ -0,0 +1,15 @@
+MD5 346ff15316b1bc76aeb14ded36a0f721 BEClient_x64.so 83017
+RMD160 e453c4c42052893a130a4ebd4aa5956245c720a5 BEClient_x64.so 83017
+SHA256 228dfb2f8bdc9e7ff83af23e4c49ae2f79172838150d444014fd5dfaf181b9d3 BEClient_x64.so 83017
+MD5 53358d90883d765931f3c9abb15127ed BEServer_x64.so 86257
+RMD160 031588b49ba1c9578ae9eb4cefcb77a6be0ef3e4 BEServer_x64.so 86257
+SHA256 085a79475f5c9ec647c743bb488b57ef1b720da466a85c1ab26ffe634bd2420f BEServer_x64.so 86257
+MD5 d5eac4a33b3543dbc40d984b84e657f8 warsow.png 1692
+RMD160 098a1505a74a20eb4bdfeda4cf2c537a9524ce23 warsow.png 1692
+SHA256 086968e72271b248ef32609ed1818ff9f5c355297b1eee3cbee9e41f4e18a954 warsow.png 1692
+MD5 74fc786f3a983d82b6ea37868c76a148 warsow_0.31_linux.tar.gz 92611004
+RMD160 fa1dfab5797e25cf52821491858cf3d62e98e013 warsow_0.31_linux.tar.gz 92611004
+SHA256 69c4a6464c3132240d50f9ad39a7521ebadee0c113b5f09fc3a4ace1a048e5eb warsow_0.31_linux.tar.gz 92611004
+MD5 10b684718f7108e7eca42d5ddde3d5e3 warsow_0.31_sdk.zip 17903715
+RMD160 8187d62ca7b581ef71e0d5f27194058e58aa71ed warsow_0.31_sdk.zip 17903715
+SHA256 83df0b458cabebc742de042b8649a695d23b07a611a8215cbca907d6eae64db0 warsow_0.31_sdk.zip 17903715
diff --git a/games-fps/warsow/warsow-0.3.1-r1.ebuild b/games-fps/warsow/warsow-0.3.1-r1.ebuild
new file mode 100644
index 000000000000..3d79c62e2ae9
--- /dev/null
+++ b/games-fps/warsow/warsow-0.3.1-r1.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/warsow/warsow-0.3.1-r1.ebuild,v 1.1 2007/07/05 15:57:37 nyhm Exp $
+
+inherit eutils toolchain-funcs versionator games
+
+MY_P=${PN}_$(delete_version_separator 2)
+DESCRIPTION="Multiplayer FPS based on the QFusion engine (evolved from Quake 2)"
+HOMEPAGE="http://www.warsow.net/"
+SRC_URI="http://k3rmit.org/wsw/${MY_P}_linux.tar.gz
+ http://k3rmit.org/wsw/${MY_P}_sdk.zip
+ mirror://gentoo/${PN}.png
+ amd64? (
+ http://www.battleye.com/wsw/BEClient_x64.so
+ http://www.battleye.com/wsw/BEServer_x64.so
+ )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug dedicated irc openal opengl"
+
+UIRDEPEND="media-libs/jpeg
+ media-libs/libvorbis
+ media-libs/libsdl
+ net-misc/curl
+ virtual/opengl
+ x11-libs/libXinerama
+ x11-libs/libXxf86dga
+ x11-libs/libXxf86vm
+ openal? ( media-libs/openal )"
+RDEPEND="opengl? ( ${UIRDEPEND} )
+ !opengl? ( !dedicated? ( ${UIRDEPEND} ) )"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ x11-misc/makedepend"
+
+S=${WORKDIR}/${MY_P}/source
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ rm -f "${WORKDIR}"/${PN}/docs/gnu.txt
+
+ sed -i \
+ -e '/fs_usehomedir =/ s:0:1:' \
+ -e "/fs_basepath =/ s:\.:${GAMES_DATADIR}/${PN}:" \
+ qcommon/files.c \
+ || die "sed files.c failed"
+
+ epatch "${FILESDIR}"/${P}-build.patch
+}
+
+src_compile() {
+ yesno() { use ${1} && echo YES || echo NO ; }
+
+ if use opengl || ! use dedicated ; then
+ local client="YES"
+ else
+ local client="NO"
+ fi
+
+ emake \
+ BUILD_CLIENT=${client} \
+ BUILD_SERVER=$(yesno dedicated) \
+ BUILD_IRC=$(yesno irc) \
+ BUILD_SND_OPENAL=$(yesno openal) \
+ DEBUG_BUILD=$(yesno debug) \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getCC)" \
+ || die "emake failed"
+}
+
+src_install() {
+ cd release
+
+ if use opengl || ! use dedicated ; then
+ newgamesbin ${PN}.* ${PN} || die "newgamesbin ${PN} failed"
+ doicon "${DISTDIR}"/${PN}.png
+ make_desktop_entry ${PN} Warsow
+ fi
+
+ if use dedicated ; then
+ newgamesbin wsw_server.* ${PN}-ded || die "newgamesbin ${PN}-ded failed"
+ fi
+
+ exeinto "$(games_get_libdir)"/${PN}
+ doexe */*.so || die "doexe failed"
+
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r "${WORKDIR}"/${PN}/basewsw || die "doins failed"
+
+ local so
+ for so in basewsw/*.so ; do
+ dosym "$(games_get_libdir)"/${PN}/${so##*/} \
+ "${GAMES_DATADIR}"/${PN}/${so} || die "dosym ${so} failed"
+ done
+
+ dodir "${GAMES_DATADIR}"/${PN}/libs
+ for so in libs/*.so ; do
+ dosym "$(games_get_libdir)"/${PN}/${so##*/} \
+ "${GAMES_DATADIR}"/${PN}/${so} || die "dosym ${so} failed"
+ done
+
+ dodir "${GAMES_DATADIR}"/${PN}/BattlEye
+ exeinto "$(games_get_libdir)"/${PN}
+
+ if use x86 ; then
+ cd "${WORKDIR}"/${PN}
+ for so in BattlEye/*_x86.so ; do
+ doexe ${so} || die "doexe ${so} failed"
+ dosym "$(games_get_libdir)"/${PN}/${so##*/} \
+ "${GAMES_DATADIR}"/${PN}/${so} \
+ || die "dosym ${so} failed"
+ done
+ elif use amd64 ; then
+ cd "${DISTDIR}"
+ for so in *_x64.so ; do
+ doexe ${so} || die "doexe ${so} failed"
+ dosym "$(games_get_libdir)"/${PN}/${so} \
+ "${GAMES_DATADIR}"/${PN}/BattlEye/${so} \
+ || die "dosym ${so} failed"
+ done
+ fi
+
+ dodoc "${WORKDIR}"{/${PN},}/docs/*
+ prepgamesdirs
+}