summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-07-09 23:32:16 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-07-09 23:32:16 +0000
commit22afe1cf6d9e774acce2a9e77bdcf1fb04d1d9ee (patch)
treeba58d877ffc41b7c14f6bfbd42eb265f652aa8d6 /games-fps/urbanterror
parentversion bump (bug #476292, thx to Zack) (diff)
downloadgentoo-2-22afe1cf6d9e774acce2a9e77bdcf1fb04d1d9ee.tar.gz
gentoo-2-22afe1cf6d9e774acce2a9e77bdcf1fb04d1d9ee.tar.bz2
gentoo-2-22afe1cf6d9e774acce2a9e77bdcf1fb04d1d9ee.zip
revbump to update the game engine
(Portage version: 2.2.0_alpha187/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-fps/urbanterror')
-rw-r--r--games-fps/urbanterror/ChangeLog8
-rw-r--r--games-fps/urbanterror/files/urbanterror-4.2.013-build.patch60
-rw-r--r--games-fps/urbanterror/urbanterror-4.2.013-r1.ebuild (renamed from games-fps/urbanterror/urbanterror-4.2.013.ebuild)6
3 files changed, 44 insertions, 30 deletions
diff --git a/games-fps/urbanterror/ChangeLog b/games-fps/urbanterror/ChangeLog
index 90a70c8795c2..1517dd378514 100644
--- a/games-fps/urbanterror/ChangeLog
+++ b/games-fps/urbanterror/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-fps/urbanterror
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/urbanterror/ChangeLog,v 1.27 2013/07/04 21:01:10 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/urbanterror/ChangeLog,v 1.28 2013/07/09 23:32:16 hasufell Exp $
+
+*urbanterror-4.2.013-r1 (09 Jul 2013)
+
+ 09 Jul 2013; Julian Ospald <hasufell@gentoo.org> -urbanterror-4.2.013.ebuild,
+ +urbanterror-4.2.013-r1.ebuild, files/urbanterror-4.2.013-build.patch:
+ revbump to update the game engine
04 Jul 2013; Julian Ospald <hasufell@gentoo.org> urbanterror-4.2.013.ebuild:
update check-reqs wrt #475766
diff --git a/games-fps/urbanterror/files/urbanterror-4.2.013-build.patch b/games-fps/urbanterror/files/urbanterror-4.2.013-build.patch
index 820bd0872544..868c3ccad82c 100644
--- a/games-fps/urbanterror/files/urbanterror-4.2.013-build.patch
+++ b/games-fps/urbanterror/files/urbanterror-4.2.013-build.patch
@@ -1,47 +1,55 @@
---- Makefile
-+++ Makefile
-@@ -213,7 +213,7 @@
+commit dc89402ef3305202a2ec51e6c2c073bb1f65fb54
+Author: hasufell <hasufell@gentoo.org>
+Date: Wed Jul 10 01:25:27 2013 +0200
+
+ respect CFLAGS/LDFLAGS
+
+diff --git a/Makefile b/Makefile
+index 3c134d5..54989f3 100644
+--- a/Makefile
++++ b/Makefile
+@@ -213,7 +213,7 @@ ifeq ($(PLATFORM),linux)
endif
endif
-- BASE_CFLAGS = -Wall -fno-strict-aliasing -Wimplicit -Wstrict-prototypes -pipe
-+ BASE_CFLAGS = -Wall -fno-strict-aliasing -Wimplicit -Wstrict-prototypes
+- BASE_CFLAGS = -Wall -Wimplicit -Wstrict-prototypes -pipe
++ BASE_CFLAGS = -Wall -Wimplicit -Wstrict-prototypes
ifeq ($(USE_OPENAL),1)
BASE_CFLAGS += -DUSE_OPENAL=1
-@@ -239,19 +239,15 @@
+@@ -238,18 +238,17 @@ ifeq ($(PLATFORM),linux)
+ else
BASE_CFLAGS += -I/usr/X11R6/include
endif
-
-- OPTIMIZE = -O3 -ffast-math -funroll-loops -fomit-frame-pointer
-+ OPTIMIZE = -ffast-math -funroll-loops
-
- ifeq ($(ARCH),x86_64)
-- OPTIMIZE = -O3 -fomit-frame-pointer -ffast-math -funroll-loops \
-- -falign-loops=2 -falign-jumps=2 -falign-functions=2 \
-- -fstrength-reduce
-+ OPTIMIZE = -ffast-math -funroll-loops
+- #Anything more then -O2 and *mmx *msse/2/ causes hitching with urbanterror\
+-#also -march is illrelavent unless you know your target cpu
+- OPTIMIZE = -O2 -mmmx -msse -msse2 -msse3
++ # what an idiotic comment
++ OPTIMIZE =
+ #having x86_x64 implys having full SSE support up to SSE3 so we will use it,\
+ #for old cpus we don't care because anything pre Pentium 4/Althlon 1600+ won't run UrbanTerror
+ ifeq ($(ARCH),x86_64)
+- OPTIMIZE = -O2 -msse -msse2 -msse3
++ OPTIMIZE =
# experimental x86_64 jit compiler! you need GNU as
HAVE_VM_COMPILED = true
else
ifeq ($(ARCH),i386)
-- OPTIMIZE = -O3 -march=i586 -fomit-frame-pointer -ffast-math \
-- -funroll-loops -falign-loops=2 -falign-jumps=2 \
-- -falign-functions=2 -fstrength-reduce
-+ OPTIMIZE = -ffast-math -funroll-loops
+- OPTIMIZE = -O2 -mmmx
++ OPTIMIZE =
+
HAVE_VM_COMPILED=true
else
- ifeq ($(ARCH),ppc)
-@@ -265,7 +261,7 @@
+@@ -264,7 +263,7 @@ ifeq ($(PLATFORM),linux)
BASE_CFLAGS += -DNO_VM_COMPILED
endif
-- DEBUG_CFLAGS = $(BASE_CFLAGS) -g -O0
+- DEBUG_CFLAGS = $(BASE_CFLAGS) -g -O0 -wall
+ DEBUG_CFLAGS = $(BASE_CFLAGS) $(OPTIMIZE)
RELEASE_CFLAGS=$(BASE_CFLAGS) -DNDEBUG $(OPTIMIZE)
-@@ -274,7 +270,7 @@
+@@ -273,7 +272,7 @@ ifeq ($(PLATFORM),linux)
SHLIBLDFLAGS=-shared $(LDFLAGS)
THREAD_LDFLAGS=-lpthread
@@ -50,20 +58,20 @@
ifeq ($(USE_SDL),1)
CLIENT_LDFLAGS=$(shell sdl-config --libs)
-@@ -1157,13 +1153,13 @@
+@@ -1157,13 +1156,13 @@ endif
$(B)/Quake3-UrT.$(ARCH)$(BINEXT): $(Q3OBJ) $(Q3POBJ) $(LIBSDLMAIN)
$(echo_cmd) "LD $@"
- $(Q)$(CC) -o $@ $(Q3OBJ) $(Q3POBJ) $(CLIENT_LDFLAGS) \
- $(LDFLAGS) $(LIBSDLMAIN)
-+ $(Q)$(CC) -o $@ $(Q3OBJ) $(Q3POBJ) \
++ $(Q)$(CC) $(CFLAGS) -o $@ $(Q3OBJ) $(Q3POBJ) \
+ $(LDFLAGS) $(CLIENT_LDFLAGS) $(LIBSDLMAIN)
$(B)/Quake3-UrT-smp.$(ARCH)$(BINEXT): $(Q3OBJ) $(Q3POBJ_SMP) $(LIBSDLMAIN)
$(echo_cmd) "LD $@"
- $(Q)$(CC) -o $@ $(Q3OBJ) $(Q3POBJ_SMP) $(CLIENT_LDFLAGS) \
- $(THREAD_LDFLAGS) $(LDFLAGS) $(LIBSDLMAIN)
-+ $(Q)$(CC) -o $@ $(Q3OBJ) $(Q3POBJ_SMP) \
++ $(Q)$(CC) $(CFLAGS) -o $@ $(Q3OBJ) $(Q3POBJ_SMP) \
+ $(LDFLAGS) $(THREAD_LDFLAGS) $(CLIENT_LDFLAGS) $(LIBSDLMAIN)
ifneq ($(strip $(LIBSDLMAIN)),)
diff --git a/games-fps/urbanterror/urbanterror-4.2.013.ebuild b/games-fps/urbanterror/urbanterror-4.2.013-r1.ebuild
index ba52344b8c9a..3f66fd67189a 100644
--- a/games-fps/urbanterror/urbanterror-4.2.013.ebuild
+++ b/games-fps/urbanterror/urbanterror-4.2.013-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/urbanterror/urbanterror-4.2.013.ebuild,v 1.2 2013/07/04 21:01:10 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/urbanterror/urbanterror-4.2.013-r1.ebuild,v 1.1 2013/07/09 23:32:16 hasufell Exp $
EAPI=5
@@ -11,7 +11,7 @@ DESCRIPTION="Hollywood tactical shooter based on the ioquake3 engine"
HOMEPAGE="http://www.urbanterror.info/home/"
SRC_URI="http://cdn.urbanterror.info/urt/42/zips/UrbanTerror42_full${PREV_PV:4:3}.zip
http://cdn.urbanterror.info/urt/42/zips/UrbanTerror-${PREV_PV}-to-${PV}.zip
- https://github.com/Barbatos/ioq3-for-UrbanTerror-4/archive/release-${PREV_PV}.tar.gz -> ${PN}-${PREV_PV}.tar.gz
+ https://github.com/Barbatos/ioq3-for-UrbanTerror-4/archive/release-${PV}.tar.gz -> ${P}.tar.gz
http://upload.wikimedia.org/wikipedia/en/5/56/Urbanterror.svg -> ${PN}.svg"
LICENSE="GPL-2 Q3AEULA"
@@ -37,7 +37,7 @@ DEPEND="${RDEPEND}
app-arch/unzip
dedicated? ( curl? ( net-misc/curl ) )"
-S=${WORKDIR}/ioq3-for-UrbanTerror-4-release-${PREV_PV}
+S=${WORKDIR}/ioq3-for-UrbanTerror-4-release-${PV}
S_DATA=${WORKDIR}/UrbanTerror42
CHECKREQS_DISK_BUILD="3300M"